aboutsummaryrefslogtreecommitdiff
path: root/databases/gnome-db
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-05-01 20:23:03 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-05-01 20:23:03 +0000
commit17b6cc0afe9b40f3959b94130e056a822adc30b4 (patch)
tree1e3b468b04c0618f2192a0c1300447f2fc6e1b17 /databases/gnome-db
parent253e18d9cd0b644fc1994189c627927d065600c9 (diff)
downloadports-17b6cc0afe9b40f3959b94130e056a822adc30b4.tar.gz
ports-17b6cc0afe9b40f3959b94130e056a822adc30b4.zip
Notes
Diffstat (limited to 'databases/gnome-db')
-rw-r--r--databases/gnome-db/Makefile3
-rw-r--r--databases/gnome-db/files/patch-configure16
-rw-r--r--databases/gnome-db/files/patch-doc::C::reference::Makefile.in14
-rw-r--r--databases/gnome-db/files/patch-ltmain.sh36
-rw-r--r--databases/gnome-db/pkg-plist11
5 files changed, 34 insertions, 46 deletions
diff --git a/databases/gnome-db/Makefile b/databases/gnome-db/Makefile
index 8d39545bb314..f0a1ace2ae14 100644
--- a/databases/gnome-db/Makefile
+++ b/databases/gnome-db/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomedb
PORTVERSION= 0.2.96
+PORTREVISION= 1
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-db
@@ -21,7 +22,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOMECTRL= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/databases/gnome-db/files/patch-configure b/databases/gnome-db/files/patch-configure
index 9547ff98afc8..8925b93fafb4 100644
--- a/databases/gnome-db/files/patch-configure
+++ b/databases/gnome-db/files/patch-configure
@@ -1,9 +1,17 @@
$FreeBSD$
---- configure.orig Mon Mar 4 10:42:41 2002
-+++ configure Mon Mar 4 10:47:57 2002
-@@ -8876,7 +8876,7 @@
+--- configure.orig Mon Apr 15 15:30:28 2002
++++ configure Wed May 1 11:51:50 2002
+@@ -5905,6 +5905,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -8876,7 +8877,7 @@
PERL_CC=`perl -MConfig -e 'print $Config{cc},"\n";'`
PERL_LD=`perl -MConfig -e 'print $Config{ld},"\n";'`
PERL_CCOPTS=`perl -MExtUtils::Embed -e ccopts`
@@ -12,7 +20,7 @@ $FreeBSD$
-@@ -8906,7 +8906,7 @@
+@@ -8906,7 +8907,7 @@
GNOMEDB_CFLAGS="`gda-config --cflags client` `gnome-config --cflags xml oaf bonobox print gdk_pixbuf`"
GNOMEDB_LIBS="`gda-config --libs client` `gnome-config --libs xml oaf bonobox print gdk_pixbuf`"
diff --git a/databases/gnome-db/files/patch-doc::C::reference::Makefile.in b/databases/gnome-db/files/patch-doc::C::reference::Makefile.in
new file mode 100644
index 000000000000..b9c8dda0e901
--- /dev/null
+++ b/databases/gnome-db/files/patch-doc::C::reference::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- doc/C/reference/Makefile.in 2002/05/01 08:49:53 1.1
++++ doc/C/reference/Makefile.in 2002/05/01 08:50:40
+@@ -174,7 +174,7 @@
+
+
+ DOC_MAIN_SGML_FILE = libgnomedb-reference.sgml
+-DOC_DIR = $(datadir)/html
++DOC_DIR = $(prefix)/share/doc/gnomedb
+ TARGET_DIR = $(DOC_DIR)/libgnomedb-reference
+
+ DOC_DIR_INSTALL_FILES = libgnomedb.args libgnomedb.hierarchy libgnomedb.signals libgnomedb.types libgnomedb-decl.txt libgnomedb-sections.txt
diff --git a/databases/gnome-db/files/patch-ltmain.sh b/databases/gnome-db/files/patch-ltmain.sh
deleted file mode 100644
index 91c341790451..000000000000
--- a/databases/gnome-db/files/patch-ltmain.sh
+++ /dev/null
@@ -1,36 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Sun Jan 20 16:11:07 2002
-+++ ltmain.sh Tue Jan 22 13:34:20 2002
-@@ -1060,6 +1060,7 @@
-
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2442,6 +2443,9 @@
- *-*-openbsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test $build_libtool_need_lc = "yes"; then
-@@ -4208,10 +4212,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/databases/gnome-db/pkg-plist b/databases/gnome-db/pkg-plist
index 7891f9fa9981..51f76bec637e 100644
--- a/databases/gnome-db/pkg-plist
+++ b/databases/gnome-db/pkg-plist
@@ -38,6 +38,11 @@ lib/bonobo/monikers/libdatabase_moniker.so
lib/libgnomedb.a
lib/libgnomedb.so
lib/libgnomedb.so.0
+share/doc/gnomedb/libgnomedb-decl.txt
+share/doc/gnomedb/libgnomedb-sections.txt
+share/doc/gnomedb/libgnomedb.args
+share/doc/gnomedb/libgnomedb.hierarchy
+share/doc/gnomedb/libgnomedb.types
share/gnome/apps/Applications/gnomedb-fe.desktop
share/gnome/help/gnome-db/C/comlib.html
share/gnome/help/gnome-db/C/components.html
@@ -110,11 +115,6 @@ share/gnome/help/gnome-db/pt_BR/manager.html
share/gnome/help/gnome-db/pt_BR/topic.dat
share/gnome/help/gnome-db/pt_BR/widgetlib-overview.html
share/gnome/help/gnome-db/pt_BR/widgetlib.html
-share/gnome/html/libgnomedb-decl.txt
-share/gnome/html/libgnomedb-sections.txt
-share/gnome/html/libgnomedb.args
-share/gnome/html/libgnomedb.hierarchy
-share/gnome/html/libgnomedb.types
share/gnome/idl/GNOME_Database_UI.idl
share/gnome/oaf/GNOME_DB_Builder.oaf
share/gnome/oaf/GNOME_DB_ComponentFactory.oaf
@@ -172,5 +172,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-db.mo
@dirrm share/gnome/help/gnome-db/C
@dirrm share/gnome/help/gnome-db
@dirrm share/gnome/apps/Applications
+@dirrm share/doc/gnomedb
@dirrm include/libgnomedb-%%VERSION%%/gnome-db
@dirrm include/libgnomedb-%%VERSION%%