aboutsummaryrefslogtreecommitdiff
path: root/databases/gomdb
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-10-14 05:44:49 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-10-14 05:44:49 +0000
commit19f4c2999fd2d24e0bbc0df2cf516be97ea9e9b5 (patch)
treeaf9705c85ca94ccdda7b12e2d39641132be88845 /databases/gomdb
parent1e0fd5f37630c72748c7305083c87a3df945b8c0 (diff)
Notes
Diffstat (limited to 'databases/gomdb')
-rw-r--r--databases/gomdb/Makefile37
-rw-r--r--databases/gomdb/distinfo2
-rw-r--r--databases/gomdb/pkg-descr3
-rw-r--r--databases/gomdb/pkg-plist18
4 files changed, 60 insertions, 0 deletions
diff --git a/databases/gomdb/Makefile b/databases/gomdb/Makefile
new file mode 100644
index 000000000000..b58a8a6a373c
--- /dev/null
+++ b/databases/gomdb/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= gomdb
+PORTVERSION= 20140824
+CATEGORIES= databases
+
+MAINTAINER= cheffo@freebsd-bg.org
+COMMENT= Go wrapper for LMDB - OpenLDAP Lightning Memory-Mapped Database
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= go:${PORTSDIR}/lang/go
+
+ONLY_FOR_ARCHS= i386 amd64
+
+USES= compiler
+
+USE_GITHUB= yes
+GH_ACCOUNT= szferi
+GH_PROJECT= gomdb
+GH_TAGNAME= 6bcb5a
+
+.include <bsd.port.pre.mk>
+
+#Build fails on FreeBSD10+ if value of "CC" is not set to "clang" (checked by configure)
+
+.if ${COMPILER_TYPE} == clang
+CC= clang
+.else
+USE_GCC= yes
+.endif
+
+CONFIGURE_ENV+= CC=${CC}
+GO_ENV+= ${CONFIGURE_ENV}
+
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/gomdb/distinfo b/databases/gomdb/distinfo
new file mode 100644
index 000000000000..c9c66bd606c5
--- /dev/null
+++ b/databases/gomdb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (szferi-gomdb-20140824-6bcb5a_GH0.tar.gz) = 61067d3131b988f00fb01373e90fd71c27a417ab4d664dc19b5500d3a4953877
+SIZE (szferi-gomdb-20140824-6bcb5a_GH0.tar.gz) = 103059
diff --git a/databases/gomdb/pkg-descr b/databases/gomdb/pkg-descr
new file mode 100644
index 000000000000..4d018341835b
--- /dev/null
+++ b/databases/gomdb/pkg-descr
@@ -0,0 +1,3 @@
+Go wrapper for OpenLDAP Lightning Memory-Mapped Database, LMDB.
+
+WWW: https://github.com/szferi/gomdb
diff --git a/databases/gomdb/pkg-plist b/databases/gomdb/pkg-plist
new file mode 100644
index 000000000000..101894e5fbc3
--- /dev/null
+++ b/databases/gomdb/pkg-plist
@@ -0,0 +1,18 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/bench_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/cursor.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/env.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/env_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/error_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/example_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/lmdb.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/mdb.c
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/mdb.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/mdb_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/midl.c
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/midl.h
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/txn.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/val.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/val_test.go