aboutsummaryrefslogtreecommitdiff
path: root/databases/gosqlite3
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-04-14 00:56:10 +0000
committerWen Heping <wen@FreeBSD.org>2011-04-14 00:56:10 +0000
commit803c8aa1c5611f742dd2fa2bc968dc77fc08385c (patch)
tree1ffff910c20f9287295fe3df14160f822212b126 /databases/gosqlite3
parenta4eccde1aaa40c7abce8f8374968ec456f6c3a9b (diff)
downloadports-803c8aa1c5611f742dd2fa2bc968dc77fc08385c.tar.gz
ports-803c8aa1c5611f742dd2fa2bc968dc77fc08385c.zip
Notes
Diffstat (limited to 'databases/gosqlite3')
-rw-r--r--databases/gosqlite3/Makefile29
-rw-r--r--databases/gosqlite3/distinfo2
-rw-r--r--databases/gosqlite3/pkg-descr3
3 files changed, 34 insertions, 0 deletions
diff --git a/databases/gosqlite3/Makefile b/databases/gosqlite3/Makefile
new file mode 100644
index 000000000000..cf04765e9d63
--- /dev/null
+++ b/databases/gosqlite3/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gosqlite3
+# Date created: Apr 11, 2011
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gosqlite3
+PORTVERSION= 20110316
+CATEGORIES= databases
+MASTER_SITES= LOCAL/wen
+DISTNAME= ${GITHUB_USER}-${PORTNAME}-${GIT_REVISION}
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A Go interface for SQLite3
+
+LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
+
+PLIST_FILES= ${GO_LIBDIR}/sqlite3.a
+
+USE_GO= yes
+MAKE_ARGS+= CGO_CFLAGS+="-I${LOCALBASE}/include" CFLAGS="-I${LOCALBASE}/${GO_LIBDIR}" CGO_LDFLAGS="-L${LOCALBASE}/lib -lsqlite3"
+
+GITHUB_USER= feyeleanor
+GIT_REVISION= 0f3e536
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/gosqlite3/distinfo b/databases/gosqlite3/distinfo
new file mode 100644
index 000000000000..b5e4af3a6bbd
--- /dev/null
+++ b/databases/gosqlite3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (feyeleanor-gosqlite3-0f3e536.tar.gz) = 8f6f538846865e6d9e317e5deb30e1c7418f589a8e6c325e53f242678c84d811
+SIZE (feyeleanor-gosqlite3-0f3e536.tar.gz) = 7125
diff --git a/databases/gosqlite3/pkg-descr b/databases/gosqlite3/pkg-descr
new file mode 100644
index 000000000000..5dc3e81315fd
--- /dev/null
+++ b/databases/gosqlite3/pkg-descr
@@ -0,0 +1,3 @@
+A Go interface for SQLite3, modelled after the C interface.
+
+WWW: http://kuroneko.github.com/gosqlite3/