aboutsummaryrefslogtreecommitdiff
path: root/databases/hiredis
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2011-05-02 23:24:32 +0000
committerBeech Rintoul <beech@FreeBSD.org>2011-05-02 23:24:32 +0000
commita2d101a80dd5901849247d048abf0e69271e12c3 (patch)
tree262a93e7b478f624dac72185c5fb4b6d2112538f /databases/hiredis
parent49539058e933e474f0946796d89b65e9b45f8840 (diff)
downloadports-a2d101a80dd5901849247d048abf0e69271e12c3.tar.gz
ports-a2d101a80dd5901849247d048abf0e69271e12c3.zip
Notes
Diffstat (limited to 'databases/hiredis')
-rw-r--r--databases/hiredis/Makefile4
-rw-r--r--databases/hiredis/distinfo4
-rw-r--r--databases/hiredis/files/patch-Makefile11
3 files changed, 15 insertions, 4 deletions
diff --git a/databases/hiredis/Makefile b/databases/hiredis/Makefile
index 570feb5d4b62..fc588f8133a0 100644
--- a/databases/hiredis/Makefile
+++ b/databases/hiredis/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hiredis
-DISTVERSION= 0.9.2
+DISTVERSION= 0.10.0
CATEGORIES= databases
MASTER_SITES= https://github.com/antirez/hiredis/tarball/v${DISTVERSION}/
DISTNAME= antirez-${PORTNAME}-v${DISTVERSION}-0-g${GITVERSION}
@@ -16,7 +16,7 @@ COMMENT= Minimalistic C client library for the Redis database
LICENSE= BSD
-GITVERSION= 0fbfa45
+GITVERSION= 6d026b7
FETCH_ARGS= -pRr
WRKSRC= ${WRKDIR}/antirez-${PORTNAME}-${GITVERSION}
diff --git a/databases/hiredis/distinfo b/databases/hiredis/distinfo
index ce5bd6c61804..ba787b311a23 100644
--- a/databases/hiredis/distinfo
+++ b/databases/hiredis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (antirez-hiredis-v0.9.2-0-g0fbfa45.tar.gz) = 02cf8653bb1afa8e56545103e00b4d7cd64bc34db6cae44465bde9919e420b4d
-SIZE (antirez-hiredis-v0.9.2-0-g0fbfa45.tar.gz) = 29669
+SHA256 (antirez-hiredis-v0.10.0-0-g6d026b7.tar.gz) = fe96fc37b1af6c9ee07ee3965bbaaded16caaf595888d01b6cae9dfd7bd21d20
+SIZE (antirez-hiredis-v0.10.0-0-g6d026b7.tar.gz) = 38528
diff --git a/databases/hiredis/files/patch-Makefile b/databases/hiredis/files/patch-Makefile
new file mode 100644
index 000000000000..b512a3be05f2
--- /dev/null
+++ b/databases/hiredis/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2011-04-22 02:15:50.000000000 -0800
++++ Makefile 2011-05-02 14:33:21.000000000 -0800
+@@ -89,7 +89,7 @@
+ endif
+
+ hiredis-%: %.o $(STLIBNAME)
+- $(CC) -o $@ $(CCOPT) $(DEBUG) $(LDFLAGS) $(STLIBNAME) $<
++ $(CC) -o $@ $(CCOPT) $(DEBUG) $(LDFLAGS) $< $(STLIBNAME)
+
+ test: hiredis-test
+ ./hiredis-test