aboutsummaryrefslogtreecommitdiff
path: root/databases/hk_classes/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
commit9346b215f04cc84bbb7125ff2fcf03978f859a21 (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /databases/hk_classes/Makefile
parent49ac3accb4fc378c681317849f4ae94655a61423 (diff)
Notes
Diffstat (limited to 'databases/hk_classes/Makefile')
-rw-r--r--databases/hk_classes/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index 1852a8cf14b4..ed4f5de3759c 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= SF/hk-classes/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ Library for rapid development of database applications
-BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone \
- pkg-config>0:${PORTSDIR}/devel/pkg-config
+BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
xml2.5:${PORTSDIR}/textproc/libxml2
@@ -21,6 +20,7 @@ USE_BZIP2= yes
USE_ICONV= yes
USE_PYTHON= yes
USE_GETTEXT= yes
+USE_PKGCONFIG= yes
CXXFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -largp -lintl
USE_AUTOTOOLS= libtool