aboutsummaryrefslogtreecommitdiff
path: root/databases/influxdb
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-02-08 17:59:45 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-02-08 17:59:45 +0000
commit9e9b5e7e05610c9fa81ba3472d5396f772f99fe4 (patch)
treec870c97cdafd88612dd4d6eb7d0f18066711f452 /databases/influxdb
parent8b2a23e265d0c4ef83d4c052c7750b47f8791945 (diff)
downloadports-9e9b5e7e05610c9fa81ba3472d5396f772f99fe4.tar.gz
ports-9e9b5e7e05610c9fa81ba3472d5396f772f99fe4.zip
Notes
Diffstat (limited to 'databases/influxdb')
-rw-r--r--databases/influxdb/Makefile166
-rw-r--r--databases/influxdb/distinfo58
-rw-r--r--databases/influxdb/files/patch-cluster_client__pool.go11
-rw-r--r--databases/influxdb/files/patch-cluster_shard__writer.go11
-rw-r--r--databases/influxdb/pkg-descr21
-rw-r--r--databases/influxdb/pkg-plist2
6 files changed, 137 insertions, 132 deletions
diff --git a/databases/influxdb/Makefile b/databases/influxdb/Makefile
index a2e1c1902b66..61a44937b71b 100644
--- a/databases/influxdb/Makefile
+++ b/databases/influxdb/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= influxdb
-PORTVERSION= 0.9.6.1
+PORTVERSION= 0.10.0
DISTVERSIONPREFIX= v
CATEGORIES= databases net-mgmt
@@ -18,42 +18,68 @@ USE_RC_SUBR= influxd
USE_GITHUB= yes
GH_ACCOUNT= influxdb:DEFAULT \
- alecthomas:log4go \
- armon:go_metrics \
- BurntSushi:toml \
- bmizerany:pat \
- boltdb:bolt \
- cheffo:crypto,go_uuid \
- collectd:go_collectd \
- dgryski:go_bits,go_bitstream \
- fatih:pool \
+ BurntSushi:BurntSushi_toml \
+ armon:armon_go_metrics \
+ bmizerany:bmizerany_pat \
+ boltdb:boltdb_bolt \
+ collectd:collectd_go_collectd \
+ davecgh:davecgh_go_spew \
+ dgryski:dgryski_go_bits \
+ dgryski:dgryski_go_bitstream \
+ fatih:fatih_pool \
gogo:gogo_protobuf \
- golang:golang_protobuf,golang_snappy \
- hashicorp:raft,raft_boltdb,go_msgpack \
- influxdb:enterprise_client \
- influxdata:usage_client \
- jwilder:encoding \
- kimor79:gollectd \
- peterh:liner \
- rakyll:statik \
- paulbellamy:ratecounter
-GH_PROJECT= bolt:bolt crypto:crypto encoding:encoding \
- enterprise-client:enterprise_client go-bits:go_bits \
- go-bitstream:go_bitstream go-collectd:go_collectd \
- go-metrics:go_metrics go-msgpack:go_msgpack gollectd:gollectd \
- liner:liner log4go:log4go pat:pat pool:pool \
- protobuf:gogo_protobuf protobuf:golang_protobuf \
- raft-boltdb:raft_boltdb raft:raft ratecounter:ratecounter \
- snappy:golang_snappy, statik:statik toml:toml go-uuid:go_uuid \
- usage-client:usage_client
-GH_TAGNAME= b34b35e:bolt 056c9bc:toml 1351f93:crypto 4d47685:liner \
- 5c3c713:log4go 274df12:statik e492fd3:gogo_protobuf \
- 61d0dee:gollectd 68415e7:golang_protobuf 06b6099:go_metrics \
- b8a3500:pat cba550e:pool d1e82c1:raft_boltdb ed3ca8a:go_uuid \
- d136cd1:raft fa3f638:go_msgpack 723cc1e:golang_snappy \
- 9fc824c:go_collectd 86c69b3:go_bits 27cd597:go_bitstream \
- 07d88d4:encoding 25665cb:enterprise_client 5a11f58:ratecounter \
- 475977e:usage_client
+ golang:golang_crypto,golang_snappy \
+ hashicorp:hashicorp_go_msgpack,hashicorp_raft,hashicorp_raft_boltdb \
+ influxdb:influxdb_usage_client \
+ jwilder:jwilder_encoding \
+ kimor79:kimor79_gollectd \
+ paulbellamy:paulbellamy_ratecounter \
+ peterh:peterh_liner \
+ rakyll:rakyll_statik
+
+GH_PROJECT= bolt:boltdb_bolt \
+ crypto:golang_crypto \
+ encoding:jwilder_encoding \
+ go-bits:dgryski_go_bits \
+ go-bitstream:dgryski_go_bitstream \
+ go-collectd:collectd_go_collectd \
+ go-metrics:armon_go_metrics \
+ go-msgpack:hashicorp_go_msgpack \
+ go-spew:davecgh_go_spew \
+ gollectd:kimor79_gollectd \
+ liner:peterh_liner \
+ pat:bmizerany_pat \
+ pool:fatih_pool \
+ protobuf:gogo_protobuf \
+ raft-boltdb:hashicorp_raft_boltdb \
+ raft:hashicorp_raft \
+ ratecounter:paulbellamy_ratecounter \
+ snappy:golang_snappy \
+ statik:rakyll_statik \
+ toml:BurntSushi_toml \
+ usage-client:influxdb_usage_client
+
+GH_TAGNAME= 5c4df71:BurntSushi_toml \
+ 345426c:armon_go_metrics \
+ b8a3500:bmizerany_pat \
+ 2f846c3:boltdb_bolt \
+ 9fc824c:collectd_go_collectd \
+ 5215b55:davecgh_go_spew \
+ 86c69b3:dgryski_go_bits \
+ 27cd597:dgryski_go_bitstream \
+ cba550e:fatih_pool \
+ 82d16f7:gogo_protobuf \
+ 1f22c01:golang_crypto \
+ 894fd46:golang_snappy \
+ fa3f638:hashicorp_go_msgpack \
+ 057b893:hashicorp_raft \
+ d1e82c1:hashicorp_raft_boltdb \
+ 475977e:influxdb_usage_client \
+ 07d88d4:jwilder_encoding \
+ 61d0dee:kimor79_gollectd \
+ 5a11f58:paulbellamy_ratecounter \
+ ad1edfd:peterh_liner \
+ 274df12:rakyll_statik
SUB_FILES= influxd
SUB_LIST+= INFLUXD_USER=${INFLUXD_USER} \
@@ -81,14 +107,13 @@ GROUPS= ${INFLUXD_GROUP}
STRIP= # stripping can break go binaries
post-patch:
- @${MKDIR} ${WRKSRC}/src/code.google.com/p
@${MKDIR} ${WRKSRC}/src/github.com/BurntSushi
@${MKDIR} ${WRKSRC}/src/github.com/armon
@${MKDIR} ${WRKSRC}/src/github.com/bmizerany
@${MKDIR} ${WRKSRC}/src/github.com/boltdb
@${MKDIR} ${WRKSRC}/src/collectd.org
+ @${MKDIR} ${WRKSRC}/src/github.com/davecgh
@${MKDIR} ${WRKSRC}/src/github.com/dgryski
- @${MKDIR} ${WRKSRC}/src/github.com/fatih
@${MKDIR} ${WRKSRC}/src/github.com/gogo
@${MKDIR} ${WRKSRC}/src/github.com/golang
@${MKDIR} ${WRKSRC}/src/github.com/hashicorp
@@ -99,44 +124,45 @@ post-patch:
@${MKDIR} ${WRKSRC}/src/github.com/peterh
@${MKDIR} ${WRKSRC}/src/github.com/rakyll
@${MKDIR} ${WRKSRC}/src/golang.org/x
+ @${MKDIR} ${WRKSRC}/src/gopkg.in/fatih
@${MKDIR} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}
-.for src in LICENSE_OF_DEPENDENCIES.md Makefile build-docker.sh build.py \
- circle-test.sh circle.yml client cluster cmd errors.go etc importer \
- influxql influxvar.go meta models monitor nightly.sh package.sh \
- pkg scripts services shared snapshot statik stress tcp \
- test-32bit-docker.sh tests toml tsdb uuid
+.for src in Dockerfile LICENSE LICENSE_OF_DEPENDENCIES.md Makefile \
+ build-docker.sh build.py build.sh circle-test.sh circle.yml \
+ client cluster cmd errors.go etc gobuild.sh importer influxql \
+ influxvar.go models monitor nightly.sh node.go package.sh pkg \
+ scripts services shared statik stress tcp test.sh tests toml tsdb uuid
@${MV} ${WRKSRC}/${src} \
${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}
.endfor
- @${MV} ${WRKSRC_bolt} ${WRKSRC}/src/github.com/boltdb/bolt
- @${MV} ${WRKSRC_crypto} ${WRKSRC}/src/golang.org/x/crypto
- @${MV} ${WRKSRC_encoding} ${WRKSRC}/src/github.com/jwilder/encoding
- @${MV} ${WRKSRC_enterprise_client} ${WRKSRC}/src/github.com/influxdb/enterprise-client
- @${MV} ${WRKSRC_usage_client} ${WRKSRC}/src/github.com/influxdb/usage-client
- @${MV} ${WRKSRC_go_bits} ${WRKSRC}/src/github.com/dgryski/go-bits
- @${MV} ${WRKSRC_go_bitstream} ${WRKSRC}/src/github.com/dgryski/go-bitstream
- @${MV} ${WRKSRC_go_collectd}/api ${WRKSRC}/src/collectd.org/api
- @${MV} ${WRKSRC_go_collectd}/network ${WRKSRC}/src/collectd.org/network
- @${MV} ${WRKSRC_go_collectd}/cdtime ${WRKSRC}/src/collectd.org/cdtime
- @${MV} ${WRKSRC_go_metrics} ${WRKSRC}/src/github.com/armon/go-metrics
- @${MV} ${WRKSRC_go_uuid} ${WRKSRC}/src/code.google.com/p/go-uuid
- @${MV} ${WRKSRC_go_msgpack} ${WRKSRC}/src/github.com/hashicorp/go-msgpack
- @${MV} ${WRKSRC_gogo_protobuf} ${WRKSRC}/src/github.com/gogo/protobuf
- @${MV} ${WRKSRC_golang_protobuf} ${WRKSRC}/src/github.com/golang/protobuf
- @${MV} ${WRKSRC_gollectd} ${WRKSRC}/src/github.com/kimor79/gollectd
- @${MV} ${WRKSRC_liner} ${WRKSRC}/src/github.com/peterh/liner
- @${MV} ${WRKSRC_log4go} ${WRKSRC}/src/code.google.com/p/log4go
- @${MV} ${WRKSRC_pat} ${WRKSRC}/src/github.com/bmizerany/pat
- @${MV} ${WRKSRC_pool} ${WRKSRC}/src/github.com/fatih/pool
- @${MV} ${WRKSRC_raft_boltdb} ${WRKSRC}/src/github.com/hashicorp/raft-boltdb
- @${MV} ${WRKSRC_raft} ${WRKSRC}/src/github.com/hashicorp/raft
- @${MV} ${WRKSRC_ratecounter} ${WRKSRC}/src/github.com/paulbellamy/ratecounter
- @${MV} ${WRKSRC_statik} ${WRKSRC}/src/github.com/rakyll/statik
+ @${MV} ${WRKSRC_BurntSushi_toml} ${WRKSRC}/src/github.com/BurntSushi/toml
+ @${MV} ${WRKSRC_boltdb_bolt} ${WRKSRC}/src/github.com/boltdb/bolt
+ @${MV} ${WRKSRC_davecgh_go_spew} ${WRKSRC}/src/github.com/davecgh/go-spew
+ @${MV} ${WRKSRC_golang_crypto} ${WRKSRC}/src/golang.org/x/crypto
@${MV} ${WRKSRC_golang_snappy} ${WRKSRC}/src/github.com/golang/snappy
- @${MV} ${WRKSRC_toml} ${WRKSRC}/src/github.com/BurntSushi/toml
+ @${MV} ${WRKSRC_jwilder_encoding} ${WRKSRC}/src/github.com/jwilder/encoding
+ @${MV} ${WRKSRC_influxdb_usage_client} ${WRKSRC}/src/github.com/influxdb/usage-client
+ @${MV} ${WRKSRC_dgryski_go_bits} ${WRKSRC}/src/github.com/dgryski/go-bits
+ @${MV} ${WRKSRC_dgryski_go_bitstream} ${WRKSRC}/src/github.com/dgryski/go-bitstream
+ @${MV} ${WRKSRC_collectd_go_collectd}/api ${WRKSRC}/src/collectd.org/api
+ @${MV} ${WRKSRC_collectd_go_collectd}/cdtime ${WRKSRC}/src/collectd.org/cdtime
+ @${MV} ${WRKSRC_collectd_go_collectd}/exec ${WRKSRC}/src/collectd.org/exec
+ @${MV} ${WRKSRC_collectd_go_collectd}/export ${WRKSRC}/src/collectd.org/export
+ @${MV} ${WRKSRC_collectd_go_collectd}/format ${WRKSRC}/src/collectd.org/format
+ @${MV} ${WRKSRC_collectd_go_collectd}/network ${WRKSRC}/src/collectd.org/network
+ @${MV} ${WRKSRC_armon_go_metrics} ${WRKSRC}/src/github.com/armon/go-metrics
+ @${MV} ${WRKSRC_hashicorp_go_msgpack} ${WRKSRC}/src/github.com/hashicorp/go-msgpack
+ @${MV} ${WRKSRC_hashicorp_raft} ${WRKSRC}/src/github.com/hashicorp/raft
+ @${MV} ${WRKSRC_hashicorp_raft_boltdb} ${WRKSRC}/src/github.com/hashicorp/raft-boltdb
+ @${MV} ${WRKSRC_gogo_protobuf} ${WRKSRC}/src/github.com/gogo/protobuf
+ @${MV} ${WRKSRC_kimor79_gollectd} ${WRKSRC}/src/github.com/kimor79/gollectd
+ @${MV} ${WRKSRC_peterh_liner} ${WRKSRC}/src/github.com/peterh/liner
+ @${MV} ${WRKSRC_bmizerany_pat} ${WRKSRC}/src/github.com/bmizerany/pat
+ @${MV} ${WRKSRC_fatih_pool} ${WRKSRC}/src/gopkg.in/fatih/pool.v2
+ @${MV} ${WRKSRC_paulbellamy_ratecounter} ${WRKSRC}/src/github.com/paulbellamy/ratecounter
+ @${MV} ${WRKSRC_rakyll_statik} ${WRKSRC}/src/github.com/rakyll/statik
do-build:
- @cd ${WRKSRC}/src/github.com/influxdb/ && ${SETENV} GOPATH=${WRKSRC} go install ./...
+ @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/ && ${SETENV} GOPATH=${WRKSRC} go install ./...
do-install:
${MKDIR} ${STAGEDIR}${INFLUXD_DBDIR} \
@@ -146,6 +172,8 @@ do-install:
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/influxd ${STAGEDIR}${PREFIX}/bin/influxd
${INSTALL_PROGRAM} ${WRKSRC}/bin/influx ${STAGEDIR}${PREFIX}/bin/influx
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/influx_inspect ${STAGEDIR}${PREFIX}/bin/influx_inspect
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/influx_tsm ${STAGEDIR}${PREFIX}/bin/influx_tsm
@${SED} -i .bak -e \
"s|/tmp/influxdb/development|/var/db/influxdb|g" \
${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}/etc/config.sample.toml
diff --git a/databases/influxdb/distinfo b/databases/influxdb/distinfo
index 5f311375cb96..dd3d461a8091 100644
--- a/databases/influxdb/distinfo
+++ b/databases/influxdb/distinfo
@@ -1,50 +1,44 @@
-SHA256 (influxdb-influxdb-v0.9.6.1_GH0.tar.gz) = 4e5e2a83f885d1c531ea538397cef1de94717eab02c7e589b9696f22dd65d3e2
-SIZE (influxdb-influxdb-v0.9.6.1_GH0.tar.gz) = 1134698
-SHA256 (alecthomas-log4go-5c3c713_GH0.tar.gz) = ea492017025d02f1204ba744fc01130b547da7e07b661598cac83a3ca63c6255
-SIZE (alecthomas-log4go-5c3c713_GH0.tar.gz) = 16187
-SHA256 (armon-go-metrics-06b6099_GH0.tar.gz) = 9536fa2418200cc060edeb24fa3c778abbed7dfce626784663aa39b411477a8a
-SIZE (armon-go-metrics-06b6099_GH0.tar.gz) = 13229
-SHA256 (BurntSushi-toml-056c9bc_GH0.tar.gz) = 73125940543e2922a77bee42f068f35383b5e260e5fbab867efcb7a59a05671a
-SIZE (BurntSushi-toml-056c9bc_GH0.tar.gz) = 37104
+SHA256 (influxdb-influxdb-v0.10.0_GH0.tar.gz) = 42a8410766047955084a25a98da0a914124081c7ab8b3d994e824063b3914f4a
+SIZE (influxdb-influxdb-v0.10.0_GH0.tar.gz) = 1167832
+SHA256 (BurntSushi-toml-5c4df71_GH0.tar.gz) = b5456c373ff033e29a7ed86fff52ee0b9a06ec34f9db2c40c4137ffccfafd5eb
+SIZE (BurntSushi-toml-5c4df71_GH0.tar.gz) = 37094
+SHA256 (armon-go-metrics-345426c_GH0.tar.gz) = 1a46954fcd70725f4831fda117f68d1e551c3a6ba9c0df8f1021bbc254195d4c
+SIZE (armon-go-metrics-345426c_GH0.tar.gz) = 13603
SHA256 (bmizerany-pat-b8a3500_GH0.tar.gz) = 6468a8b27db2bed1edf6eb845da6f7466221c7b0b41112d77710e4ac76926a2f
SIZE (bmizerany-pat-b8a3500_GH0.tar.gz) = 5205
-SHA256 (boltdb-bolt-b34b35e_GH0.tar.gz) = e1ab58b0a50d6b3537b0c5be8d5ef358ddcd64ecb112cadd9046173af1747156
-SIZE (boltdb-bolt-b34b35e_GH0.tar.gz) = 76007
-SHA256 (cheffo-crypto-1351f93_GH0.tar.gz) = 29ddf6009158914fb35f9d8e27c48164428dedac6a1314215e1717ae913d96f0
-SIZE (cheffo-crypto-1351f93_GH0.tar.gz) = 860364
-SHA256 (cheffo-go-uuid-ed3ca8a_GH0.tar.gz) = 3ad72804ee9b735add1039ec8cffd445fefd66852a3b7c0b82baf428696ca921
-SIZE (cheffo-go-uuid-ed3ca8a_GH0.tar.gz) = 41022
+SHA256 (boltdb-bolt-2f846c3_GH0.tar.gz) = 0a3f4642d068c28885c46ea6cbd398ebcf3486af2b8fbd19ac3d7f3c8e58f7ed
+SIZE (boltdb-bolt-2f846c3_GH0.tar.gz) = 78088
SHA256 (collectd-go-collectd-9fc824c_GH0.tar.gz) = 4d6f6d88f85e48eff7fa5443145ab62c30463b102dbcc70c3309519b7e01e546
SIZE (collectd-go-collectd-9fc824c_GH0.tar.gz) = 24548
+SHA256 (davecgh-go-spew-5215b55_GH0.tar.gz) = a73d6352d8172dfb648e6aa25a8b81ed5c1895295090c876bef01d017264cbac
+SIZE (davecgh-go-spew-5215b55_GH0.tar.gz) = 41794
SHA256 (dgryski-go-bits-86c69b3_GH0.tar.gz) = 92e7227b8527dacd387bd89536b8d349e7d57131ead1071329a94133a5e67780
SIZE (dgryski-go-bits-86c69b3_GH0.tar.gz) = 2137
SHA256 (dgryski-go-bitstream-27cd597_GH0.tar.gz) = 9bd56e5019d84d31b7ffd68feca5f61db683588c9bb2033763dfc84c99d5c370
SIZE (dgryski-go-bitstream-27cd597_GH0.tar.gz) = 2801
SHA256 (fatih-pool-cba550e_GH0.tar.gz) = fdcbcf67872333b16b74647bc4c8aa8100de81f58f0ea99ff83a519bf142e4cb
SIZE (fatih-pool-cba550e_GH0.tar.gz) = 4854
-SHA256 (gogo-protobuf-e492fd3_GH0.tar.gz) = 914aafa56baa6c24c24c8732b53c09b111a4324b7a50d3bb9af4ec3797d03c47
-SIZE (gogo-protobuf-e492fd3_GH0.tar.gz) = 1570750
-SHA256 (golang-protobuf-68415e7_GH0.tar.gz) = 5b54f372d62be2b0a13a2d757950d922b4ccdd12180178798bcd4927a26848a0
-SIZE (golang-protobuf-68415e7_GH0.tar.gz) = 178721
-SHA256 (golang-snappy-723cc1e_GH0.tar.gz) = 205b26745b6ceb62b762f07282842cafb4f4b0395b9ab14b0349a990e299fbed
-SIZE (golang-snappy-723cc1e_GH0.tar.gz) = 10075
-SHA256 (hashicorp-raft-d136cd1_GH0.tar.gz) = 550bfaed021d46ffe6ae4873c43125c934d69d6210c2c422fa33ea0205a79516
-SIZE (hashicorp-raft-d136cd1_GH0.tar.gz) = 59284
-SHA256 (hashicorp-raft-boltdb-d1e82c1_GH0.tar.gz) = 68bb2996a4ec490c099612efcc255ad721014aaf42afbf9f0b21fcf8361162d9
-SIZE (hashicorp-raft-boltdb-d1e82c1_GH0.tar.gz) = 8879
+SHA256 (gogo-protobuf-82d16f7_GH0.tar.gz) = 9080f1109a6a7d41cf70894d756d1787349c27c8805b28ebcf176e8ce9622730
+SIZE (gogo-protobuf-82d16f7_GH0.tar.gz) = 1640868
+SHA256 (golang-crypto-1f22c01_GH0.tar.gz) = 28dcb3d3a9249fcc1db0e4829318c8e3c876e584c07bbccd34c18a0b8ee96c1b
+SIZE (golang-crypto-1f22c01_GH0.tar.gz) = 901862
+SHA256 (golang-snappy-894fd46_GH0.tar.gz) = c66d0be89fe08f14af8aaffc352b2b620dfd488c6698064644d1e3a8b13c8876
+SIZE (golang-snappy-894fd46_GH0.tar.gz) = 10119
SHA256 (hashicorp-go-msgpack-fa3f638_GH0.tar.gz) = 6353c623d5d58c7ca03e2bdac63f9da7da8848fb1f5f7f239b33e3ce6fe6c6bd
SIZE (hashicorp-go-msgpack-fa3f638_GH0.tar.gz) = 49496
-SHA256 (influxdb-enterprise-client-25665cb_GH0.tar.gz) = 867a109025936d030b1d43e35df4e88ed7a9f267c8bf33b5e110293f6c7ef694
-SIZE (influxdb-enterprise-client-25665cb_GH0.tar.gz) = 6531
-SHA256 (influxdata-usage-client-475977e_GH0.tar.gz) = b62bc789b1e508b3904a9514705d0d5c362e9788028eeab97c588927a94d59f7
-SIZE (influxdata-usage-client-475977e_GH0.tar.gz) = 6620
+SHA256 (hashicorp-raft-057b893_GH0.tar.gz) = 01490a9454a0b346d78a7c81b5bb0b0c20c2e52828a7cc23640638e53ad03251
+SIZE (hashicorp-raft-057b893_GH0.tar.gz) = 60534
+SHA256 (hashicorp-raft-boltdb-d1e82c1_GH0.tar.gz) = 68bb2996a4ec490c099612efcc255ad721014aaf42afbf9f0b21fcf8361162d9
+SIZE (hashicorp-raft-boltdb-d1e82c1_GH0.tar.gz) = 8879
+SHA256 (influxdb-usage-client-475977e_GH0.tar.gz) = b62bc789b1e508b3904a9514705d0d5c362e9788028eeab97c588927a94d59f7
+SIZE (influxdb-usage-client-475977e_GH0.tar.gz) = 6620
SHA256 (jwilder-encoding-07d88d4_GH0.tar.gz) = c061d88b954e13a5c1c74b964e9b56c9a670f3f3ec8c8f563827f5323b8e2ae7
SIZE (jwilder-encoding-07d88d4_GH0.tar.gz) = 9462
SHA256 (kimor79-gollectd-61d0dee_GH0.tar.gz) = 217d827fb26d1cf7b1fa3bae7fa51fc5b25ff2141151ffa7d328d015cd4fb498
SIZE (kimor79-gollectd-61d0dee_GH0.tar.gz) = 9508
-SHA256 (peterh-liner-4d47685_GH0.tar.gz) = 49dbb396f03cdb4358955066db8411bc51eade6e294688a456c771f76e50d276
-SIZE (peterh-liner-4d47685_GH0.tar.gz) = 18603
-SHA256 (rakyll-statik-274df12_GH0.tar.gz) = 47cb3d4bc95171baeac813c0373cdfc232c4339fb09f251a76df247615216d49
-SIZE (rakyll-statik-274df12_GH0.tar.gz) = 77898
SHA256 (paulbellamy-ratecounter-5a11f58_GH0.tar.gz) = e493c6c8d673ecda63e9c0bd4e63a5af11362878c0c95f0e46711ccad1462eba
SIZE (paulbellamy-ratecounter-5a11f58_GH0.tar.gz) = 2877
+SHA256 (peterh-liner-ad1edfd_GH0.tar.gz) = 8cafe3e527eebcb6858c76e7abe532f6faf941266b7f37dee9373956956409fd
+SIZE (peterh-liner-ad1edfd_GH0.tar.gz) = 18803
+SHA256 (rakyll-statik-274df12_GH0.tar.gz) = 47cb3d4bc95171baeac813c0373cdfc232c4339fb09f251a76df247615216d49
+SIZE (rakyll-statik-274df12_GH0.tar.gz) = 77898
diff --git a/databases/influxdb/files/patch-cluster_client__pool.go b/databases/influxdb/files/patch-cluster_client__pool.go
deleted file mode 100644
index 6f7c858c7683..000000000000
--- a/databases/influxdb/files/patch-cluster_client__pool.go
+++ /dev/null
@@ -1,11 +0,0 @@
---- cluster/client_pool.go.orig 2015-06-23 14:38:16 UTC
-+++ cluster/client_pool.go
-@@ -4,7 +4,7 @@ import (
- "net"
- "sync"
-
-- "gopkg.in/fatih/pool.v2"
-+ "github.com/fatih/pool"
- )
-
- type clientPool struct {
diff --git a/databases/influxdb/files/patch-cluster_shard__writer.go b/databases/influxdb/files/patch-cluster_shard__writer.go
deleted file mode 100644
index 1978be55cd1e..000000000000
--- a/databases/influxdb/files/patch-cluster_shard__writer.go
+++ /dev/null
@@ -1,11 +0,0 @@
---- cluster/shard_writer.go.orig 2015-12-08 15:03:30 UTC
-+++ cluster/shard_writer.go
-@@ -7,7 +7,7 @@ import (
-
- "github.com/influxdb/influxdb/meta"
- "github.com/influxdb/influxdb/models"
-- "gopkg.in/fatih/pool.v2"
-+ "github.com/fatih/pool"
- )
-
- const (
diff --git a/databases/influxdb/pkg-descr b/databases/influxdb/pkg-descr
index 8cd9fca3d6af..3da2e5f5697f 100644
--- a/databases/influxdb/pkg-descr
+++ b/databases/influxdb/pkg-descr
@@ -1,13 +1,16 @@
-An open-source, distributed, time series database with no external dependencies.
-InfluxDB is the new home for all of your metrics, events, and analytics.
+An open-source, distributed, time series database with no external
+dependencies. InfluxDB is the new home for all of your metrics,
+events, and analytics.
-InfluxDB is a time series, metrics, and analytics database. It'written in Go and
-has no external dependencies. That means once you install it there's nothing
-else to manage (like Redis, ZooKeeper, HBase, or whatever).
+InfluxDB is a time series, metrics, and analytics database. It'written
+in Go and has no external dependencies. That means once you install
+it there's nothing else to manage (like Redis, ZooKeeper, HBase,
+or whatever).
-InfluxDB is targeted at use cases for DevOps, metrics, sensor data, and
-real-time analytics. It arose from our need for a database like this on more
-than a few previous products we' built. You can read more about our jurney from
-SaaS application to open source time series database.
+InfluxDB is targeted at use cases for DevOps, metrics, sensor data,
+and real-time analytics. It arose from our need for a database like
+this on more than a few previous products we' built. You can read
+more about our jurney from SaaS application to open source time
+series database.
WWW: http://influxdb.com
diff --git a/databases/influxdb/pkg-plist b/databases/influxdb/pkg-plist
index 0edbca6eb68b..97901ae04761 100644
--- a/databases/influxdb/pkg-plist
+++ b/databases/influxdb/pkg-plist
@@ -1,4 +1,6 @@
bin/influx
+bin/influx_inspect
+bin/influx_tsm
bin/influxd
@dir(%%INFLUXD_USER%%,%%INFLUXD_GROUP%%,0750) %%INFLUXD_DBDIR%%
@dir(%%INFLUXD_USER%%,%%INFLUXD_GROUP%%,0750) %%INFLUXD_LOGDIR%%