aboutsummaryrefslogtreecommitdiff
path: root/databases/innotop
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2016-06-14 15:02:04 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2016-06-14 15:02:04 +0000
commit3c091c9514a6940fd0d45e1ece96fde850ebf988 (patch)
tree25a85857c50996bee45fa8245efbf53de1fc7784 /databases/innotop
parent47a6d54a5423d93624add0ea816845d31dc8b297 (diff)
downloadports-3c091c9514a6940fd0d45e1ece96fde850ebf988.tar.gz
ports-3c091c9514a6940fd0d45e1ece96fde850ebf988.zip
Notes
Diffstat (limited to 'databases/innotop')
-rw-r--r--databases/innotop/Makefile13
-rw-r--r--databases/innotop/distinfo5
-rw-r--r--databases/innotop/files/patch-innotop11
3 files changed, 10 insertions, 19 deletions
diff --git a/databases/innotop/Makefile b/databases/innotop/Makefile
index 86bc19ba6329..91e3117e2780 100644
--- a/databases/innotop/Makefile
+++ b/databases/innotop/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= innotop
-PORTVERSION= 1.9.1
-PORTREVISION= 2
+PORTVERSION= 1.11.1
CATEGORIES= databases
-MASTER_SITES= GOOGLE_CODE
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= MySQL and InnoDB monitoring program
@@ -16,9 +14,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql \
p5-DBI>=1.46:databases/p5-DBI \
p5-Term-ReadKey>=2.10:devel/p5-Term-ReadKey
-RUN_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql \
- p5-DBI>=1.46:databases/p5-DBI \
- p5-Term-ReadKey>=2.10:devel/p5-Term-ReadKey
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_GITHUB= yes
+GH_ACCOUNT= innotop
+GH_PROJECT= innotop
+GH_TAGNAME= v${PORTVERSION}
USES= perl5
USE_PERL5= configure
diff --git a/databases/innotop/distinfo b/databases/innotop/distinfo
index c50486e915cf..1b8aca5be1a4 100644
--- a/databases/innotop/distinfo
+++ b/databases/innotop/distinfo
@@ -1,2 +1,3 @@
-SHA256 (innotop-1.9.1.tar.gz) = 117e5af58a83af79b6cf99877b25b1479197597be5a7d51b245a0ad9c69f4d3d
-SIZE (innotop-1.9.1.tar.gz) = 147677
+TIMESTAMP = 1465911515
+SHA256 (innotop-innotop-1.11.1-v1.11.1_GH0.tar.gz) = c93a4fb496ce1749aaaf0a70f0899ed1fa1aa5cd231208b6b3424285c77dc1b7
+SIZE (innotop-innotop-1.11.1-v1.11.1_GH0.tar.gz) = 178295
diff --git a/databases/innotop/files/patch-innotop b/databases/innotop/files/patch-innotop
deleted file mode 100644
index da2806602882..000000000000
--- a/databases/innotop/files/patch-innotop
+++ /dev/null
@@ -1,11 +0,0 @@
---- innotop.orig 2014-06-17 08:31:31.000000000 -0400
-+++ innotop 2014-06-17 08:32:19.000000000 -0400
-@@ -470,7 +470,7 @@
- # too many locks to print, the output might be truncated)
-
- my $time_text;
-- if ( $mysqlversion =~ /^5\.6/ ) {
-+ if ( defined $mysqlversion && $mysqlversion =~ /^5\.6/ ) {
- ( $time_text ) = $fulltext =~ m/^([0-9-]* [0-9:]*) [0-9a-f]* INNODB MONITOR OUTPUT/m;
- $innodb_data{'ts'} = [ parse_innodb_timestamp_56( $time_text ) ];
- } else {