aboutsummaryrefslogtreecommitdiff
path: root/databases/kbibtex/Makefile
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2005-08-28 11:54:16 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2005-08-28 11:54:16 +0000
commit79eaa94291e584ea52037bf61ffb434421a0c720 (patch)
treed05df7f6ad94420e04183ce9799e62318520489e /databases/kbibtex/Makefile
parent64a123c1423a75e39f2354b0293a8f2e2031b8fb (diff)
downloadports-79eaa94291e584ea52037bf61ffb434421a0c720.tar.gz
ports-79eaa94291e584ea52037bf61ffb434421a0c720.zip
Notes
Diffstat (limited to 'databases/kbibtex/Makefile')
-rw-r--r--databases/kbibtex/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
new file mode 100644
index 000000000000..c905836a127a
--- /dev/null
+++ b/databases/kbibtex/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: kbibtex
+# Date created: Mon Aug 8 18:43:04 CEST 2005
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= kbibtex
+PORTVERSION= 0.1
+CATEGORIES= databases kde
+MASTER_SITES= http://www.unix-ag.uni-kl.de/~fischer/${PORTNAME}/download/
+
+MAINTAINER= markus@FreeBSD.org
+COMMENT= BibTeX editor for KDE
+
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
+
+USE_BZIP2= yes
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${TOUCH} ${WRKSRC}/config.h.in
+
+.include <bsd.port.mk>