aboutsummaryrefslogtreecommitdiff
path: root/databases/kumofs/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-01-19 03:52:31 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-01-19 03:52:31 +0000
commitae4d8268eae817bf4d05ea7b614306957dca6675 (patch)
treecaf489f8ed3aeddefa506fae257e462ed710c0b6 /databases/kumofs/Makefile
parent58ea3885ec8465def118ea4d3476d872f063c3aa (diff)
downloadports-ae4d8268eae817bf4d05ea7b614306957dca6675.tar.gz
ports-ae4d8268eae817bf4d05ea7b614306957dca6675.zip
Notes
Diffstat (limited to 'databases/kumofs/Makefile')
-rw-r--r--databases/kumofs/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/databases/kumofs/Makefile b/databases/kumofs/Makefile
new file mode 100644
index 000000000000..814e9207dbc1
--- /dev/null
+++ b/databases/kumofs/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: msgpack
+# Date created: 18 Jan 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kumofs
+PORTVERSION= 0.3.0
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= kuriyama
+DISTNAME= kumofs-${GIT_REVISION}
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Scalabe and highly available distributed key-value store
+
+LIB_DEPENDS= msgpack:${PORTSDIR}/devel/msgpack \
+ tokyocabinet:${PORTSDIR}/databases/tokyocabinet
+RUN_DEPENDS= rubygem-msgpack>0:${PORTSDIR}/devel/rubygem-msgpack
+
+WRKSRC= ${WRKDIR}/etolabo-kumofs-${GIT_REVISION}
+USE_AUTOTOOLS= libtool:22 autoheader:262 autoconf:262 automake:110 aclocal:110
+ACLOCAL_ARGS= # empty
+AUTOMAKE_ARGS= --add-missing --copy
+CONFIGURE_ARGS= --with-msgpack=${LOCALBASE}
+USE_GMAKE= yes
+USE_RUBY= yes
+
+GIT_REVISION= 2a0c402
+
+MAN1= kumoctl.1 \
+ kumohash.1 \
+ kumolog.1 \
+ kumomergedb.1 \
+ kumostat.1 \
+ kumotop.1
+
+pre-configure:
+ cd ${WRKSRC}; ${TOUCH} README
+ cd ${WRKSRC}; ${LIBTOOLIZE} --force --copy
+
+.include <bsd.port.mk>