aboutsummaryrefslogtreecommitdiff
path: root/databases/kyototycoon
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-30 09:08:13 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-30 09:08:13 +0000
commit0968e3d22360a20fbf90e414e9948c03a4096cfa (patch)
treeea26ac2f78584448dea684041756ecc7d94fe1ac /databases/kyototycoon
parentf6144636aca5f5d38a1010eaca117442e16d6d38 (diff)
downloadports-0968e3d22360a20fbf90e414e9948c03a4096cfa.tar.gz
ports-0968e3d22360a20fbf90e414e9948c03a4096cfa.zip
- Allow build with clang [1]
- Remove explicit -lstdc++ - Bump PORTREVISION for package change Submitted by: vanilla [1]
Notes
Notes: svn path=/head/; revision=338064
Diffstat (limited to 'databases/kyototycoon')
-rw-r--r--databases/kyototycoon/Makefile6
-rw-r--r--databases/kyototycoon/files/patch-ktdbext.h10
2 files changed, 13 insertions, 3 deletions
diff --git a/databases/kyototycoon/Makefile b/databases/kyototycoon/Makefile
index 69f621fcf87c..0a051c66ba8f 100644
--- a/databases/kyototycoon/Makefile
+++ b/databases/kyototycoon/Makefile
@@ -3,6 +3,7 @@
PORTNAME= kyototycoon
PORTVERSION= 0.9.56
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://fallabs.com/${PORTNAME}/pkg/ \
LOCAL/sunpoet
@@ -16,19 +17,18 @@ LIB_DEPENDS= libkyotocabinet.so:${PORTSDIR}/databases/kyotocabinet
OPTIONS_DEFINE= DOCS
-CONFIGURE_ARGS= --enable-profile --enable-uyield
+CONFIGURE_ARGS= --enable-uyield
CPPFLAGS+= -fPIC
GNU_CONFIGURE= yes
MAKE_ARGS= PCDIR=${PREFIX}/libdata/pkgconfig
REINPLACE_ARGS= -i ''
-USE_GCC= any
USE_LDCONFIG= yes
USES= gmake pkgconfig
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure ${WRKSRC}/doc/spex.html ${WRKSRC}/example/Makefile
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g; s|-lstdc++ ||g' ${WRKSRC}/configure ${WRKSRC}/doc/spex.html ${WRKSRC}/example/Makefile
.if !${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '/DOCDIR/d' ${WRKSRC}/Makefile.in
.endif
diff --git a/databases/kyototycoon/files/patch-ktdbext.h b/databases/kyototycoon/files/patch-ktdbext.h
new file mode 100644
index 000000000000..20d980ff81e3
--- /dev/null
+++ b/databases/kyototycoon/files/patch-ktdbext.h
@@ -0,0 +1,10 @@
+--- ktdbext.h.orig 2012-05-25 01:44:34.000000000 +0800
++++ ktdbext.h 2013-12-28 01:21:30.081508681 +0800
+@@ -16,6 +16,7 @@
+ #ifndef _KTDBEXT_H // duplication check
+ #define _KTDBEXT_H
+
++#include <myconf.h>
+ #include <ktcommon.h>
+ #include <ktutil.h>
+ #include <ktulog.h>