aboutsummaryrefslogtreecommitdiff
path: root/databases/libdbi-drivers
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:43:46 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:43:46 +0000
commit14bc5a6c1142609693b3dcef0cd7e6a4b4755cb3 (patch)
tree761cd23e07e2b5224d73f540985d84eede599029 /databases/libdbi-drivers
parent7ef963090c1ba3fae0e4ab7630e60ff49fe6a9f0 (diff)
downloadports-14bc5a6c1142609693b3dcef0cd7e6a4b4755cb3.tar.gz
ports-14bc5a6c1142609693b3dcef0cd7e6a4b4755cb3.zip
Notes
Diffstat (limited to 'databases/libdbi-drivers')
-rw-r--r--databases/libdbi-drivers/Makefile40
1 files changed, 14 insertions, 26 deletions
diff --git a/databases/libdbi-drivers/Makefile b/databases/libdbi-drivers/Makefile
index a8727a444c95..5ec9a5a17be3 100644
--- a/databases/libdbi-drivers/Makefile
+++ b/databases/libdbi-drivers/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: libdbi-drivers
-# Date created: Oct 30, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= libdbi-drivers
DISTVERSION= 0.8.3-1
@@ -22,23 +18,15 @@ CONFIGURE_ARGS= --disable-static \
--with-dbi-incdir=${LOCALBASE}/include/dbi
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${DISTVERSION}
-OPTIONS= MYSQL "With MySQL Driver" on \
- MSQL "With MSQL Driver" off \
- PGSQL "With PostgreSQL Driver" on \
- SQLITE2 "With SQLite 2 Driver" off \
- SQLITE3 "With SQLite 3 Driver" on \
- FIREBIRD "With Firebird Driver (BROKEN)" off \
- FREETDS "With FreeTDS Driver" off
+OPTIONS_MULTI= DRIVER
+OPTIONS_MULTI_DRIVER= MYSQL MSQL PGSQL SQLITE2 SQLITE3 FIREBIRD FREETDS
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT= MYSQL PGSQL SQLITE3
+SQLITE2_DESC= SQLite 2 Database
-.if defined(WITHOUT_MYSQL) && defined(WITHOUT_MSQL) && defined(WITHOUT_PGSQL) \
- && defined(WITHOUT_SQLITE2) && defined(WITHOUT_SQLITE3) \
- && defined(WITHOUT_FIREBIRD) && defined(WITHOUT_FREETDS)
-IGNORE= choose at least one driver
-.endif
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql
PLIST_SUB+= MYSQL=""
@@ -46,7 +34,7 @@ PLIST_SUB+= MYSQL=""
PLIST_SUB+= MYSQL="@comment "
.endif
-.if defined(WITH_MSQL)
+.if ${PORT_OPTIONS:MMSQL}
LIB_DEPENDS+= msql.1:${PORTSDIR}/databases/msql
CONFIGURE_ARGS+= --with-msql
PLIST_SUB+= MSQL=""
@@ -54,7 +42,7 @@ PLIST_SUB+= MSQL=""
PLIST_SUB+= MSQL="@comment "
.endif
-.if !defined(WITHOUT_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
CONFIGURE_ARGS+= --with-pgsql
PLIST_SUB+= PGSQL=""
@@ -62,7 +50,7 @@ PLIST_SUB+= PGSQL=""
PLIST_SUB+= PGSQL="@comment "
.endif
-.if defined(WITH_SQLITE2)
+.if ${PORT_OPTIONS:MSQLITE2}
LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite2
CONFIGURE_ARGS+= --with-sqlite
PLIST_SUB+= SQLITE2=""
@@ -70,7 +58,7 @@ PLIST_SUB+= SQLITE2=""
PLIST_SUB+= SQLITE2="@comment "
.endif
-.if !defined(WITHOUT_SQLITE3)
+.if ${PORT_OPTIONS:MSQLITE3}
LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
CONFIGURE_ARGS+= --with-sqlite3
PLIST_SUB+= SQLITE3=""
@@ -78,7 +66,7 @@ PLIST_SUB+= SQLITE3=""
PLIST_SUB+= SQLITE3="@comment "
.endif
-.if defined(WITH_FIREBIRD)
+.if ${PORT_OPTIONS:MFIREBIRD}
LIB_DEPENDS+= gds.2:${PORTSDIR}/databases/firebird20-client
CONFIGURE_ARGS+= --with-firebird
PLIST_SUB+= FIREBIRD=""
@@ -86,7 +74,7 @@ PLIST_SUB+= FIREBIRD=""
PLIST_SUB+= FIREBIRD="@comment "
.endif
-.if defined(WITH_FREETDS)
+.if ${PORT_OPTIONS:MFREETDS}
LIB_DEPENDS+= tds.5:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+= --with-freetds
PLIST_SUB+= FREETDS=""
@@ -102,4 +90,4 @@ post-patch:
-e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/configure
@${TOUCH} ${WRKSRC}/drivers/*/dbd_*/*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>