aboutsummaryrefslogtreecommitdiff
path: root/databases/libdbi/files
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2014-03-03 20:36:13 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2014-03-03 20:36:13 +0000
commitece3fc944f87c183445640b9860beb17eeee60d7 (patch)
tree458218dd744a14a1dace39dd8db89af446c78b57 /databases/libdbi/files
parentf1c9f1c38f3a42c0a89451b4e6dfd30c8b18766c (diff)
Notes
Diffstat (limited to 'databases/libdbi/files')
-rw-r--r--databases/libdbi/files/patch-Makefile.in30
-rw-r--r--databases/libdbi/files/patch-src__dbi_result.c25
2 files changed, 44 insertions, 11 deletions
diff --git a/databases/libdbi/files/patch-Makefile.in b/databases/libdbi/files/patch-Makefile.in
index 56bbbcc84e03..fab511a999f8 100644
--- a/databases/libdbi/files/patch-Makefile.in
+++ b/databases/libdbi/files/patch-Makefile.in
@@ -1,11 +1,19 @@
---- Makefile.in.orig 2010-09-01 07:22:52.000000000 +0800
-+++ Makefile.in 2011-03-07 14:25:30.000000000 +0800
-@@ -195,7 +195,7 @@
- top_srcdir = @top_srcdir@
- AUTOMAKE_OPTIONS = foreign dist-zip
- ACLOCAL_AMFLAGS = -I m4
--SUBDIRS = src include @docs_subdirs@
-+SUBDIRS = src include
- EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL README README.win32 README.osx TODO NEWS libdbi.spec.in config.h.in Makefile.w32 autogen.sh drivers/example/AUTHORS drivers/example/Makefile.am drivers/example/README drivers/example/TODO drivers/example/.cvsignore drivers/example/dbd_example.c drivers/example/dbd_example.h drivers/example/dbd_example.sgml
- all: config.h
- $(MAKE) $(AM_MAKEFLAGS) all-recursive
+*** Makefile.in.orig Sun May 19 23:08:33 2013
+--- Makefile.in Sun May 19 23:08:47 2013
+***************
+*** 291,297 ****
+ top_srcdir = @top_srcdir@
+ AUTOMAKE_OPTIONS = foreign dist-zip
+ ACLOCAL_AMFLAGS = -I m4
+! SUBDIRS = src include @docs_subdirs@
+ EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL README README.win32 README.osx TODO NEWS UPGRADING libdbi.spec.in config.h.in Makefile.w32 autogen.sh drivers/example/AUTHORS drivers/example/Makefile.am drivers/example/README drivers/example/TODO drivers/example/.cvsignore drivers/example/dbd_example.c drivers/example/dbd_example.h drivers/example/dbd_example.sgml
+
+ # we use exec here to install the .pc file with the library, not with
+--- 291,297 ----
+ top_srcdir = @top_srcdir@
+ AUTOMAKE_OPTIONS = foreign dist-zip
+ ACLOCAL_AMFLAGS = -I m4
+! SUBDIRS = src include
+ EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL README README.win32 README.osx TODO NEWS UPGRADING libdbi.spec.in config.h.in Makefile.w32 autogen.sh drivers/example/AUTHORS drivers/example/Makefile.am drivers/example/README drivers/example/TODO drivers/example/.cvsignore drivers/example/dbd_example.c drivers/example/dbd_example.h drivers/example/dbd_example.sgml
+
+ # we use exec here to install the .pc file with the library, not with
diff --git a/databases/libdbi/files/patch-src__dbi_result.c b/databases/libdbi/files/patch-src__dbi_result.c
new file mode 100644
index 000000000000..8929152875d6
--- /dev/null
+++ b/databases/libdbi/files/patch-src__dbi_result.c
@@ -0,0 +1,25 @@
+*** ./src/dbi_result.c.orig Mon May 20 00:19:40 2013
+--- ./src/dbi_result.c Mon May 20 00:20:19 2013
+***************
+*** 1470,1479 ****
+ switch (RESULT->field_attribs[fieldidx] & DBI_INTEGER_SIZEMASK) {
+ case DBI_INTEGER_SIZE1:
+ if (RESULT->field_attribs[fieldidx] & DBI_INTEGER_UNSIGNED) {
+! snprintf(newstring, 32, "%hu", RESULT->rows[RESULT->currowidx]->field_values[fieldidx].d_char);
+ }
+ else {
+! snprintf(newstring, 32, "%hd", RESULT->rows[RESULT->currowidx]->field_values[fieldidx].d_char);
+ }
+ break;
+ case DBI_INTEGER_SIZE2:
+--- 1470,1479 ----
+ switch (RESULT->field_attribs[fieldidx] & DBI_INTEGER_SIZEMASK) {
+ case DBI_INTEGER_SIZE1:
+ if (RESULT->field_attribs[fieldidx] & DBI_INTEGER_UNSIGNED) {
+! snprintf(newstring, 32, "%hhu", RESULT->rows[RESULT->currowidx]->field_values[fieldidx].d_char);
+ }
+ else {
+! snprintf(newstring, 32, "%hhd", RESULT->rows[RESULT->currowidx]->field_values[fieldidx].d_char);
+ }
+ break;
+ case DBI_INTEGER_SIZE2: