aboutsummaryrefslogtreecommitdiff
path: root/databases/libgda2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /databases/libgda2
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'databases/libgda2')
-rw-r--r--databases/libgda2/Makefile21
-rw-r--r--databases/libgda2/distinfo4
-rw-r--r--databases/libgda2/files/patch-doc::libgda-C.omf.in8
-rw-r--r--databases/libgda2/files/patch-doc_C_Makefile.in18
-rw-r--r--databases/libgda2/files/patch-libgda_gda-util.c11
-rw-r--r--databases/libgda2/files/patch-ltmain.sh51
-rw-r--r--databases/libgda2/files/patch-po_Makefile.in.in10
-rw-r--r--databases/libgda2/files/patch-providers_ldap_gda-ldap-provider.c20
-rw-r--r--databases/libgda2/files/patch-providers_mdb_gda-mdb-provider.c20
-rw-r--r--databases/libgda2/files/patch-providers_mysql_gda-mysql-provider.c30
-rw-r--r--databases/libgda2/files/patch-providers_mysql_gda-mysql-recordset.c24
-rw-r--r--databases/libgda2/files/patch-providers_oracle_utils.c11
-rw-r--r--databases/libgda2/files/patch-providers_sqlite_gda-sqlite-provider.c20
-rw-r--r--databases/libgda2/files/patch-providers_xml_gda-xml-provider.c11
-rw-r--r--databases/libgda2/pkg-plist257
15 files changed, 178 insertions, 338 deletions
diff --git a/databases/libgda2/Makefile b/databases/libgda2/Makefile
index 9028bea115c0..6045013e614a 100644
--- a/databases/libgda2/Makefile
+++ b/databases/libgda2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= libgda2
-PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTVERSION= 1.2.1
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/1.0
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/1.2
DISTNAME= libgda-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -24,11 +23,12 @@ RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier glib20 libxslt
+USE_GNOME= gnomeprefix gnomehack glib20 libxslt
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
+CONFIGURE_ARGS= --without-bdb
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
@@ -47,10 +47,6 @@ post-patch:
WITH_MYSQL= yes
.endif
-.if exists(${LOCALBASE}/lib/libpq.so.3)
-WITH_PGSQL= yes
-.endif
-
.if exists(${LOCALBASE}/lib/libldap.so.2)
WITH_LDAP=yes
.endif
@@ -111,7 +107,7 @@ LIB_DEPENDS+= gds.1:${PORTSDIR}/databases/firebird
CONFIGURE_ARGS+= --with-firebird=${LOCALBASE}/firebird
PLIST_SUB+= FIREBIRD:=""
.else
-CONFIGURE_ARGS+= --without-firebird
+CONFIGURE_ARGS+= --without-interbase
PLIST_SUB+= FIREBIRD:="@comment "
.endif
@@ -152,7 +148,7 @@ PLIST_SUB+= ODBC:="@comment "
.endif
.if !defined(WITHOUT_SQLITE) && defined(WITH_SQLITE)
-LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite2
+LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite
CONFIGURE_ARGS+= --with-sqlite=${LOCALBASE}
PLIST_SUB+= SQLITE:=""
.else
@@ -164,9 +160,6 @@ pre-everything::
.if !defined(WITH_MYSQL)
@${ECHO_MSG} "You can enable support for MySQL databases by defining WITH_MYSQL."
.endif
-.if !defined(WITH_PGSQL)
- @${ECHO_MSG} "You can enable support for PostgreSQL databases by defining WITH_PGSQL."
-.endif
.if !defined(WITH_LDAP)
@${ECHO_MSG} "You can enable support for LDAP databases by defining WITH_LDAP."
.endif
diff --git a/databases/libgda2/distinfo b/databases/libgda2/distinfo
index c0592ec3808a..d03935fd78c2 100644
--- a/databases/libgda2/distinfo
+++ b/databases/libgda2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/libgda-1.0.4.tar.bz2) = c13d884dc61a3819c91422880147864d
-SIZE (gnome2/libgda-1.0.4.tar.bz2) = 1112201
+MD5 (gnome2/libgda-1.2.1.tar.bz2) = 513a3b7adb66fa5641bae5394f60c017
+SIZE (gnome2/libgda-1.2.1.tar.bz2) = 1223001
diff --git a/databases/libgda2/files/patch-doc::libgda-C.omf.in b/databases/libgda2/files/patch-doc::libgda-C.omf.in
index cc83c742bedd..f98b540c5562 100644
--- a/databases/libgda2/files/patch-doc::libgda-C.omf.in
+++ b/databases/libgda2/files/patch-doc::libgda-C.omf.in
@@ -1,11 +1,11 @@
---- doc/libgda-C.omf.in.orig Thu Oct 2 11:54:08 2003
-+++ doc/libgda-C.omf.in Thu Oct 2 11:54:58 2003
+--- doc/libgda-C.omf.in.orig Mon Feb 28 05:30:59 2005
++++ doc/libgda-C.omf.in Thu Mar 3 14:07:24 2005
@@ -16,7 +16,7 @@
</description>
<type>user's guide</type>
<format mime="text/html"/>
-- <identifier url="file:/@prefix@/share/gtk-doc/html/libgda/index.html"/>
-+ <identifier url="file:/@prefix@/share/doc/libgda/index.html"/>
+- <identifier url="file:@prefix@/share/gtk-doc/html/libgda/index.html"/>
++ <identifier url="file:@prefix@/share/doc/libgda/index.html"/>
<language code="C"/>
<relation seriesid="ebe4f574-a94d-11d6-8bc3-bd1f202a92f8"/>
<rights type="GNU FDL" license.version="1.1"/>
diff --git a/databases/libgda2/files/patch-doc_C_Makefile.in b/databases/libgda2/files/patch-doc_C_Makefile.in
index 718a4a1ebe6f..ef37c3190b54 100644
--- a/databases/libgda2/files/patch-doc_C_Makefile.in
+++ b/databases/libgda2/files/patch-doc_C_Makefile.in
@@ -1,11 +1,11 @@
---- doc/C/Makefile.in.orig Sun Jun 2 22:17:05 2002
-+++ doc/C/Makefile.in Sun Jun 2 22:17:27 2002
-@@ -152,7 +152,7 @@
- cxxflags_set = @cxxflags_set@
-
- DOC_MODULE = libgda
+--- doc/C/Makefile.in.orig Thu Jul 22 10:35:19 2004
++++ doc/C/Makefile.in Thu Jul 22 10:35:48 2004
+@@ -116,7 +116,7 @@
+ HISTORY_LIB = @HISTORY_LIB@
+ HISTORY_LIB_FALSE = @HISTORY_LIB_FALSE@
+ HISTORY_LIB_TRUE = @HISTORY_LIB_TRUE@
-HTML_DIR = $(datadir)/gtk-doc/html
+HTML_DIR = $(prefix)/share/doc
-
- # The top-level SGML file. Change it if you want.
- DOC_MAIN_SGML_FILE = $(DOC_MODULE)-docs.sgml
+ IBMDB2_CFLAGS = @IBMDB2_CFLAGS@
+ IBMDB2_FALSE = @IBMDB2_FALSE@
+ IBMDB2_LIBS = @IBMDB2_LIBS@
diff --git a/databases/libgda2/files/patch-libgda_gda-util.c b/databases/libgda2/files/patch-libgda_gda-util.c
deleted file mode 100644
index 61a7cded1fdb..000000000000
--- a/databases/libgda2/files/patch-libgda_gda-util.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libgda/gda-util.c.orig Sat Jul 17 11:02:21 2004
-+++ libgda/gda-util.c Sat Jul 17 11:03:07 2004
-@@ -60,7 +60,7 @@
- case GDA_VALUE_TYPE_TIME : return "time";
- case GDA_VALUE_TYPE_TIMESTAMP : return "timestamp";
- case GDA_VALUE_TYPE_TINYINT : return "tinyint";
-- default:
-+ default: ;
- }
-
- return "string";
diff --git a/databases/libgda2/files/patch-ltmain.sh b/databases/libgda2/files/patch-ltmain.sh
deleted file mode 100644
index 860ddda642f7..000000000000
--- a/databases/libgda2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Tue Aug 5 18:08:30 2003
-+++ ltmain.sh Wed Aug 6 08:18:27 2003
-@@ -1278,7 +1278,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1288,8 +1288,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -3008,6 +3016,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5457,10 +5468,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/databases/libgda2/files/patch-po_Makefile.in.in b/databases/libgda2/files/patch-po_Makefile.in.in
new file mode 100644
index 000000000000..1e6984b6bbca
--- /dev/null
+++ b/databases/libgda2/files/patch-po_Makefile.in.in
@@ -0,0 +1,10 @@
+--- po/Makefile.in.in.orig Sat Aug 14 00:43:46 2004
++++ po/Makefile.in.in Sat Aug 14 00:45:54 2004
+@@ -35,6 +35,7 @@
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
++mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+
+ CC = @CC@
+ GENCAT = @GENCAT@
diff --git a/databases/libgda2/files/patch-providers_ldap_gda-ldap-provider.c b/databases/libgda2/files/patch-providers_ldap_gda-ldap-provider.c
deleted file mode 100644
index 182c120967dc..000000000000
--- a/databases/libgda2/files/patch-providers_ldap_gda-ldap-provider.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- providers/ldap/gda-ldap-provider.c.orig Sat Jul 17 11:06:48 2004
-+++ providers/ldap/gda-ldap-provider.c Sat Jul 17 11:06:57 2004
-@@ -275,7 +275,7 @@
- switch (feature) {
- case GDA_CONNECTION_FEATURE_SQL :
- return TRUE;
-- default :
-+ default : ;
- }
-
- return FALSE;
-@@ -466,7 +466,7 @@
- return get_ldap_tables (cnc, params);
- case GDA_CONNECTION_SCHEMA_TYPES :
- return get_ldap_types (cnc, params);
-- default :
-+ default : ;
- }
-
- return NULL;
diff --git a/databases/libgda2/files/patch-providers_mdb_gda-mdb-provider.c b/databases/libgda2/files/patch-providers_mdb_gda-mdb-provider.c
deleted file mode 100644
index a56a2df2a1a0..000000000000
--- a/databases/libgda2/files/patch-providers_mdb_gda-mdb-provider.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- providers/mdb/gda-mdb-provider.c.orig Sat Jul 17 11:05:48 2004
-+++ providers/mdb/gda-mdb-provider.c Sat Jul 17 11:06:12 2004
-@@ -389,7 +389,7 @@
- g_strfreev (arr);
- }
- break;
-- default :
-+ default : ;
- }
-
- return reclist;
-@@ -438,7 +438,7 @@
- case GDA_CONNECTION_FEATURE_PROCEDURES :
- case GDA_CONNECTION_FEATURE_SQL :
- return TRUE;
-- default :
-+ default : ;
- }
-
- return FALSE;
diff --git a/databases/libgda2/files/patch-providers_mysql_gda-mysql-provider.c b/databases/libgda2/files/patch-providers_mysql_gda-mysql-provider.c
deleted file mode 100644
index 4b13d3f74cb5..000000000000
--- a/databases/libgda2/files/patch-providers_mysql_gda-mysql-provider.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- patch-providers_mysql_gda-mysql-provider.c begins here ---
---- providers/mysql/gda-mysql-provider.c.orig Sat Aug 14 22:14:57 2004
-+++ providers/mysql/gda-mysql-provider.c Sat Aug 14 22:15:59 2004
-@@ -510,7 +510,7 @@
-
- g_free (str);
- break;
-- default:
-+ default: ;
- }
-
- return reclist;
-@@ -655,7 +655,7 @@
- case GDA_CONNECTION_FEATURE_SQL :
- case GDA_CONNECTION_FEATURE_TRANSACTIONS :
- return TRUE;
-- default :
-+ default : ;
- }
-
- return FALSE;
-@@ -1187,7 +1187,7 @@
- return get_mysql_tables (cnc, params);
- case GDA_CONNECTION_SCHEMA_TYPES :
- return get_mysql_types (cnc, params);
-- default :
-+ default : ;
- }
-
- return NULL;
diff --git a/databases/libgda2/files/patch-providers_mysql_gda-mysql-recordset.c b/databases/libgda2/files/patch-providers_mysql_gda-mysql-recordset.c
index 758d31ca4869..b0d7ad4862b1 100644
--- a/databases/libgda2/files/patch-providers_mysql_gda-mysql-recordset.c
+++ b/databases/libgda2/files/patch-providers_mysql_gda-mysql-recordset.c
@@ -1,11 +1,13 @@
---- providers/mysql/gda-mysql-recordset.c.orig Mon Feb 17 21:42:16 2003
-+++ providers/mysql/gda-mysql-recordset.c Mon Feb 17 21:42:57 2003
-@@ -102,7 +102,7 @@
- break;
- case FIELD_TYPE_LONGLONG :
- case FIELD_TYPE_INT24 :
-- gda_value_set_bigint (field, thevalue ? atoll (thevalue) : 0);
-+ gda_value_set_bigint (field, thevalue ? strtoll(thevalue, &thevalue, 10) : 0);
- break;
- case FIELD_TYPE_SHORT :
- gda_value_set_smallint (field, thevalue ? atoi (thevalue) : 0);
+--- providers/mysql/gda-mysql-recordset.c.orig Thu Jul 22 10:40:31 2004
++++ providers/mysql/gda-mysql-recordset.c Thu Jul 22 10:42:51 2004
+@@ -67,8 +67,8 @@
+ case FIELD_TYPE_LONGLONG :
+ case FIELD_TYPE_INT24 :
+ if (is_unsigned)
+- gda_value_set_biguint (gda_value, atoll (value));
+- gda_value_set_bigint (gda_value, atoll (value));
++ gda_value_set_biguint (gda_value, strtoll (value, &value, 10));
++ gda_value_set_bigint (gda_value, strtoll (value, &value, 10));
+ break;
+ case FIELD_TYPE_SHORT :
+ if (is_unsigned)
diff --git a/databases/libgda2/files/patch-providers_oracle_utils.c b/databases/libgda2/files/patch-providers_oracle_utils.c
deleted file mode 100644
index a38974770e24..000000000000
--- a/databases/libgda2/files/patch-providers_oracle_utils.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- providers/oracle/utils.c.orig Sat Jul 17 11:07:46 2004
-+++ providers/oracle/utils.c Sat Jul 17 11:08:12 2004
-@@ -110,7 +110,7 @@
- break;
- case OCI_HTYPE_ENV:
- gda_connection_add_error (cnc, gda_oracle_make_error (priv_data->henv, type, file, line));
-- default:
-+ default: ;
- }
- break;
- default:
diff --git a/databases/libgda2/files/patch-providers_sqlite_gda-sqlite-provider.c b/databases/libgda2/files/patch-providers_sqlite_gda-sqlite-provider.c
deleted file mode 100644
index 66454f222810..000000000000
--- a/databases/libgda2/files/patch-providers_sqlite_gda-sqlite-provider.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- providers/sqlite/gda-sqlite-provider.c.orig Sat Jul 17 11:09:00 2004
-+++ providers/sqlite/gda-sqlite-provider.c Sat Jul 17 11:09:07 2004
-@@ -623,7 +623,7 @@
- case GDA_CONNECTION_FEATURE_TRIGGERS :
- case GDA_CONNECTION_FEATURE_VIEWS :
- return TRUE;
-- default:
-+ default: ;
- }
-
- return FALSE;
-@@ -809,7 +809,7 @@
- return get_tables (cnc);
- case GDA_CONNECTION_SCHEMA_TYPES :
- return get_types ();
-- default:
-+ default: ;
- }
-
- return NULL;
diff --git a/databases/libgda2/files/patch-providers_xml_gda-xml-provider.c b/databases/libgda2/files/patch-providers_xml_gda-xml-provider.c
deleted file mode 100644
index 487d19514fc6..000000000000
--- a/databases/libgda2/files/patch-providers_xml_gda-xml-provider.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- providers/xml/gda-xml-provider.c.orig Sat Jul 17 11:05:02 2004
-+++ providers/xml/gda-xml-provider.c Sat Jul 17 11:05:11 2004
-@@ -681,7 +681,7 @@
- return get_tables (cnc, xmldb);
- case GDA_CONNECTION_SCHEMA_TYPES :
- return get_types (cnc);
-- default :
-+ default : ;
- }
-
- return NULL;
diff --git a/databases/libgda2/pkg-plist b/databases/libgda2/pkg-plist
index 47a454eadc30..b2da31b8cbaa 100644
--- a/databases/libgda2/pkg-plist
+++ b/databases/libgda2/pkg-plist
@@ -2,79 +2,79 @@ bin/gda-config-tool
bin/gda-report-test
bin/gda-run
etc/libgda/config
-include/libgda-report/gda-report-document.h
-include/libgda-report/gda-report-item-detail.h
-include/libgda-report/gda-report-item-label.h
-include/libgda-report/gda-report-item-pagefooter.h
-include/libgda-report/gda-report-item-pageheader.h
-include/libgda-report/gda-report-item-repfield.h
-include/libgda-report/gda-report-item-report.h
-include/libgda-report/gda-report-item-reportfooter.h
-include/libgda-report/gda-report-item-reportheader.h
-include/libgda-report/gda-report-item-sqlquery.h
-include/libgda-report/gda-report-item.h
-include/libgda-report/gda-report-result.h
-include/libgda-report/gda-report-types.h
-include/libgda-report/gda-report-valid.h
-include/libgda-report/gda-report.h
-include/libgda/gda-blob.h
-include/libgda/gda-client.h
-include/libgda/gda-command.h
-include/libgda/gda-config.h
-include/libgda/gda-connection.h
-include/libgda/gda-data-model-array.h
-include/libgda/gda-data-model-hash.h
-include/libgda/gda-data-model-list.h
-include/libgda/gda-data-model.h
-include/libgda/gda-enum-types.h
-include/libgda/gda-error.h
-include/libgda/gda-export.h
-include/libgda/gda-field.h
-include/libgda/gda-log.h
-include/libgda/gda-marshal.h
-include/libgda/gda-parameter.h
-include/libgda/gda-quark-list.h
-include/libgda/gda-row.h
-include/libgda/gda-select.h
-include/libgda/gda-server-provider.h
-include/libgda/gda-table.h
-include/libgda/gda-transaction.h
-include/libgda/gda-util.h
-include/libgda/gda-value.h
-include/libgda/gda-xml-connection.h
-include/libgda/gda-xml-database.h
-include/libgda/gda-xml-document.h
-include/libgda/gda-xql-atom.h
-include/libgda/gda-xql-bin.h
-include/libgda/gda-xql-column.h
-include/libgda/gda-xql-const.h
-include/libgda/gda-xql-delete.h
-include/libgda/gda-xql-dml.h
-include/libgda/gda-xql-dual.h
-include/libgda/gda-xql-field.h
-include/libgda/gda-xql-func.h
-include/libgda/gda-xql-insert.h
-include/libgda/gda-xql-item.h
-include/libgda/gda-xql-join.h
-include/libgda/gda-xql-list.h
-include/libgda/gda-xql-query.h
-include/libgda/gda-xql-select.h
-include/libgda/gda-xql-stack.h
-include/libgda/gda-xql-target.h
-include/libgda/gda-xql-update.h
-include/libgda/gda-xql-utils.h
-include/libgda/gda-xql-value.h
-include/libgda/gda-xql-valueref.h
-include/libgda/libgda.h
+include/libgda-1.2/libgda-report/gda-report-document.h
+include/libgda-1.2/libgda-report/gda-report-item-detail.h
+include/libgda-1.2/libgda-report/gda-report-item-label.h
+include/libgda-1.2/libgda-report/gda-report-item-pagefooter.h
+include/libgda-1.2/libgda-report/gda-report-item-pageheader.h
+include/libgda-1.2/libgda-report/gda-report-item-repfield.h
+include/libgda-1.2/libgda-report/gda-report-item-report.h
+include/libgda-1.2/libgda-report/gda-report-item-reportfooter.h
+include/libgda-1.2/libgda-report/gda-report-item-reportheader.h
+include/libgda-1.2/libgda-report/gda-report-item-sqlquery.h
+include/libgda-1.2/libgda-report/gda-report-item.h
+include/libgda-1.2/libgda-report/gda-report-result.h
+include/libgda-1.2/libgda-report/gda-report-types.h
+include/libgda-1.2/libgda-report/gda-report-valid.h
+include/libgda-1.2/libgda-report/gda-report.h
+include/libgda-1.2/libgda/gda-blob.h
+include/libgda-1.2/libgda/gda-client.h
+include/libgda-1.2/libgda/gda-command.h
+include/libgda-1.2/libgda/gda-config.h
+include/libgda-1.2/libgda/gda-connection.h
+include/libgda-1.2/libgda/gda-data-model-array.h
+include/libgda-1.2/libgda/gda-data-model-hash.h
+include/libgda-1.2/libgda/gda-data-model-list.h
+include/libgda-1.2/libgda/gda-data-model.h
+include/libgda-1.2/libgda/gda-enum-types.h
+include/libgda-1.2/libgda/gda-error.h
+include/libgda-1.2/libgda/gda-field.h
+include/libgda-1.2/libgda/gda-log.h
+include/libgda-1.2/libgda/gda-marshal.h
+include/libgda-1.2/libgda/gda-parameter.h
+include/libgda-1.2/libgda/gda-quark-list.h
+include/libgda-1.2/libgda/gda-row.h
+include/libgda-1.2/libgda/gda-select.h
+include/libgda-1.2/libgda/gda-server-provider.h
+include/libgda-1.2/libgda/gda-table.h
+include/libgda-1.2/libgda/gda-transaction.h
+include/libgda-1.2/libgda/gda-util.h
+include/libgda-1.2/libgda/gda-value.h
+include/libgda-1.2/libgda/gda-xml-connection.h
+include/libgda-1.2/libgda/gda-xml-database.h
+include/libgda-1.2/libgda/gda-xml-document.h
+include/libgda-1.2/libgda/gda-xql-atom.h
+include/libgda-1.2/libgda/gda-xql-bin.h
+include/libgda-1.2/libgda/gda-xql-column.h
+include/libgda-1.2/libgda/gda-xql-const.h
+include/libgda-1.2/libgda/gda-xql-delete.h
+include/libgda-1.2/libgda/gda-xql-dml.h
+include/libgda-1.2/libgda/gda-xql-dual.h
+include/libgda-1.2/libgda/gda-xql-field.h
+include/libgda-1.2/libgda/gda-xql-func.h
+include/libgda-1.2/libgda/gda-xql-insert.h
+include/libgda-1.2/libgda/gda-xql-item.h
+include/libgda-1.2/libgda/gda-xql-join.h
+include/libgda-1.2/libgda/gda-xql-list.h
+include/libgda-1.2/libgda/gda-xql-query.h
+include/libgda-1.2/libgda/gda-xql-select.h
+include/libgda-1.2/libgda/gda-xql-stack.h
+include/libgda-1.2/libgda/gda-xql-target.h
+include/libgda-1.2/libgda/gda-xql-update.h
+include/libgda-1.2/libgda/gda-xql-utils.h
+include/libgda-1.2/libgda/gda-xql-value.h
+include/libgda-1.2/libgda/gda-xql-valueref.h
+include/libgda-1.2/libgda/libgda.h
+include/libgda-1.2/sql/sql_parser.h
lib/libgda-2.a
lib/libgda-2.so
-lib/libgda-2.so.2
+lib/libgda-2.so.3
lib/libgda-report-2.a
lib/libgda-report-2.so
-lib/libgda-report-2.so.2
+lib/libgda-report-2.so.3
lib/libgdasql.a
lib/libgdasql.so
-lib/libgdasql.so.0
+lib/libgdasql.so.3
%%FIREBIRD:%%lib/libgda/providers/libgda-firebird.so
%%FREETDS:%%lib/libgda/providers/libgda-freetds.so
%%LDAP:%%lib/libgda/providers/libgda-ldap.so
@@ -87,7 +87,10 @@ lib/libgdasql.so.0
lib/libgda/providers/libgda-xml.so
libdata/pkgconfig/libgda.pc
%%DOCSDIR%%/architecture.html
-%%DOCSDIR%%/c694.html
+%%DOCSDIR%%/ch06.html
+%%DOCSDIR%%/ch09s04.html
+%%DOCSDIR%%/ch09s05.html
+%%DOCSDIR%%/ch09s06.html
%%DOCSDIR%%/compiling.html
%%DOCSDIR%%/connecting.html
%%DOCSDIR%%/connections.html
@@ -104,13 +107,63 @@ libdata/pkgconfig/libgda.pc
%%DOCSDIR%%/fdl-section9.html
%%DOCSDIR%%/fdl-using.html
%%DOCSDIR%%/fdl.html
-%%DOCSDIR%%/gdavalue.html
+%%DOCSDIR%%/home.png
%%DOCSDIR%%/index.html
%%DOCSDIR%%/index.sgml
%%DOCSDIR%%/installation-configuring.html
%%DOCSDIR%%/installation-installing.html
%%DOCSDIR%%/installation.html
%%DOCSDIR%%/introduction.html
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/libgda.devhelp
+%%DOCSDIR%%/libgda-GdaClient.html
+%%DOCSDIR%%/libgda-GdaConnection.html
+%%DOCSDIR%%/libgda-GdaDataModel.html
+%%DOCSDIR%%/libgda-GdaDataModelArray.html
+%%DOCSDIR%%/libgda-GdaDataModelHash.html
+%%DOCSDIR%%/libgda-GdaDataModelList.html
+%%DOCSDIR%%/libgda-GdaError.html
+%%DOCSDIR%%/libgda-GdaExport.html
+%%DOCSDIR%%/libgda-GdaReportDocument.html
+%%DOCSDIR%%/libgda-GdaReportItem.html
+%%DOCSDIR%%/libgda-GdaReportItemDetail.html
+%%DOCSDIR%%/libgda-GdaReportItemLabel.html
+%%DOCSDIR%%/libgda-GdaReportItemPageFooter.html
+%%DOCSDIR%%/libgda-GdaReportItemPageHeader.html
+%%DOCSDIR%%/libgda-GdaReportItemRepField.html
+%%DOCSDIR%%/libgda-GdaReportItemReport.html
+%%DOCSDIR%%/libgda-GdaReportItemReportFooter.html
+%%DOCSDIR%%/libgda-GdaReportItemReportHeader.html
+%%DOCSDIR%%/libgda-GdaReportItemSqlQuery.html
+%%DOCSDIR%%/libgda-GdaReportResult.html
+%%DOCSDIR%%/libgda-GdaReportValid.html
+%%DOCSDIR%%/libgda-GdaSelect.html
+%%DOCSDIR%%/libgda-GdaServerProvider.html
+%%DOCSDIR%%/libgda-GdaTable.html
+%%DOCSDIR%%/libgda-GdaTransaction.html
+%%DOCSDIR%%/libgda-GdaXmlConnection.html
+%%DOCSDIR%%/libgda-GdaXmlDatabase.html
+%%DOCSDIR%%/libgda-GdaXmlDocument.html
+%%DOCSDIR%%/libgda-GdaXqlAtom.html
+%%DOCSDIR%%/libgda-GdaXqlBin.html
+%%DOCSDIR%%/libgda-GdaXqlColumn.html
+%%DOCSDIR%%/libgda-GdaXqlConst.html
+%%DOCSDIR%%/libgda-GdaXqlDelete.html
+%%DOCSDIR%%/libgda-GdaXqlDml.html
+%%DOCSDIR%%/libgda-GdaXqlDual.html
+%%DOCSDIR%%/libgda-GdaXqlField.html
+%%DOCSDIR%%/libgda-GdaXqlFunc.html
+%%DOCSDIR%%/libgda-GdaXqlInsert.html
+%%DOCSDIR%%/libgda-GdaXqlItem.html
+%%DOCSDIR%%/libgda-GdaXqlJoin.html
+%%DOCSDIR%%/libgda-GdaXqlList.html
+%%DOCSDIR%%/libgda-GdaXqlQuery.html
+%%DOCSDIR%%/libgda-GdaXqlSelect.html
+%%DOCSDIR%%/libgda-GdaXqlStack.html
+%%DOCSDIR%%/libgda-GdaXqlTarget.html
+%%DOCSDIR%%/libgda-GdaXqlUpdate.html
+%%DOCSDIR%%/libgda-GdaXqlValue.html
+%%DOCSDIR%%/libgda-GdaXqlValueRef.html
%%DOCSDIR%%/libgda-api.html
%%DOCSDIR%%/libgda-gda-blob.html
%%DOCSDIR%%/libgda-gda-command.html
@@ -124,69 +177,23 @@ libdata/pkgconfig/libgda.pc
%%DOCSDIR%%/libgda-gda-util.html
%%DOCSDIR%%/libgda-gda-value.html
%%DOCSDIR%%/libgda-gda-xql-utils.html
-%%DOCSDIR%%/libgda-gdaclient.html
-%%DOCSDIR%%/libgda-gdaconnection.html
-%%DOCSDIR%%/libgda-gdadatamodel.html
-%%DOCSDIR%%/libgda-gdadatamodelarray.html
-%%DOCSDIR%%/libgda-gdadatamodelhash.html
-%%DOCSDIR%%/libgda-gdadatamodellist.html
-%%DOCSDIR%%/libgda-gdaerror.html
-%%DOCSDIR%%/libgda-gdaexport.html
-%%DOCSDIR%%/libgda-gdareportdocument.html
-%%DOCSDIR%%/libgda-gdareportitem.html
-%%DOCSDIR%%/libgda-gdareportitemdetail.html
-%%DOCSDIR%%/libgda-gdareportitemlabel.html
-%%DOCSDIR%%/libgda-gdareportitempagefooter.html
-%%DOCSDIR%%/libgda-gdareportitempageheader.html
-%%DOCSDIR%%/libgda-gdareportitemrepfield.html
-%%DOCSDIR%%/libgda-gdareportitemreport.html
-%%DOCSDIR%%/libgda-gdareportitemreportfooter.html
-%%DOCSDIR%%/libgda-gdareportitemreportheader.html
-%%DOCSDIR%%/libgda-gdareportitemsqlquery.html
-%%DOCSDIR%%/libgda-gdareportresult.html
-%%DOCSDIR%%/libgda-gdareportvalid.html
-%%DOCSDIR%%/libgda-gdaselect.html
-%%DOCSDIR%%/libgda-gdaserverprovider.html
-%%DOCSDIR%%/libgda-gdatable.html
-%%DOCSDIR%%/libgda-gdatransaction.html
-%%DOCSDIR%%/libgda-gdaxmlconnection.html
-%%DOCSDIR%%/libgda-gdaxmldatabase.html
-%%DOCSDIR%%/libgda-gdaxmldocument.html
-%%DOCSDIR%%/libgda-gdaxqlatom.html
-%%DOCSDIR%%/libgda-gdaxqlbin.html
-%%DOCSDIR%%/libgda-gdaxqlcolumn.html
-%%DOCSDIR%%/libgda-gdaxqlconst.html
-%%DOCSDIR%%/libgda-gdaxqldelete.html
-%%DOCSDIR%%/libgda-gdaxqldml.html
-%%DOCSDIR%%/libgda-gdaxqldual.html
-%%DOCSDIR%%/libgda-gdaxqlfield.html
-%%DOCSDIR%%/libgda-gdaxqlfunc.html
-%%DOCSDIR%%/libgda-gdaxqlinsert.html
-%%DOCSDIR%%/libgda-gdaxqlitem.html
-%%DOCSDIR%%/libgda-gdaxqljoin.html
-%%DOCSDIR%%/libgda-gdaxqllist.html
-%%DOCSDIR%%/libgda-gdaxqlquery.html
-%%DOCSDIR%%/libgda-gdaxqlselect.html
-%%DOCSDIR%%/libgda-gdaxqlstack.html
-%%DOCSDIR%%/libgda-gdaxqltarget.html
-%%DOCSDIR%%/libgda-gdaxqlupdate.html
-%%DOCSDIR%%/libgda-gdaxqlvalue.html
-%%DOCSDIR%%/libgda-gdaxqlvalueref.html
%%DOCSDIR%%/libgda-libgda.html
%%DOCSDIR%%/libgda-provider-class.html
%%DOCSDIR%%/libgda-provider-recordset.html
%%DOCSDIR%%/libgda-providers.html
%%DOCSDIR%%/libgda-reports.html
+%%DOCSDIR%%/libgda-server-provider-details.html
%%DOCSDIR%%/libgda-xql.html
%%DOCSDIR%%/main_example.html
+%%DOCSDIR%%/manage-gdavalue.html
%%DOCSDIR%%/managing-errors.html
%%DOCSDIR%%/migration-configuration.html
%%DOCSDIR%%/migration-executing-commands.html
%%DOCSDIR%%/migration.html
%%DOCSDIR%%/processing-queries.html
-%%DOCSDIR%%/x863.html
-%%DOCSDIR%%/x892.html
-%%DOCSDIR%%/x897.html
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
share/gnome/libgda/xml/gda-report.dtd
share/gnome/libgda/xml/gda-report-result.dtd
share/gnome/libgda/xml/gda-xml-query.dtd
@@ -208,12 +215,12 @@ share/locale/ga/LC_MESSAGES/libgda-2.mo
share/locale/gl/LC_MESSAGES/libgda-2.mo
share/locale/hr/LC_MESSAGES/libgda-2.mo
share/locale/hu/LC_MESSAGES/libgda-2.mo
-share/locale/id/LC_MESSAGES/libgda-2.mo
share/locale/it/LC_MESSAGES/libgda-2.mo
share/locale/ja/LC_MESSAGES/libgda-2.mo
share/locale/ko/LC_MESSAGES/libgda-2.mo
share/locale/ml/LC_MESSAGES/libgda-2.mo
share/locale/ms/LC_MESSAGES/libgda-2.mo
+share/locale/nb/LC_MESSAGES/libgda-2.mo
share/locale/nl/LC_MESSAGES/libgda-2.mo
share/locale/no/LC_MESSAGES/libgda-2.mo
share/locale/pl/LC_MESSAGES/libgda-2.mo
@@ -222,6 +229,7 @@ share/locale/pt_BR/LC_MESSAGES/libgda-2.mo
share/locale/ru/LC_MESSAGES/libgda-2.mo
share/locale/sk/LC_MESSAGES/libgda-2.mo
share/locale/sl/LC_MESSAGES/libgda-2.mo
+share/locale/sq/LC_MESSAGES/libgda-2.mo
share/locale/sr/LC_MESSAGES/libgda-2.mo
share/locale/sr@Latn/LC_MESSAGES/libgda-2.mo
share/locale/sv/LC_MESSAGES/libgda-2.mo
@@ -235,7 +243,8 @@ share/locale/zh_TW/LC_MESSAGES/libgda-2.mo
@dirrm share/gnome/libgda
@dirrm lib/libgda/providers
@dirrm lib/libgda
-@dirrm include/libgda/sql
-@dirrm include/libgda
-@dirrm include/libgda-report
+@dirrm include/libgda-1.2/sql
+@dirrm include/libgda-1.2/libgda-report
+@dirrm include/libgda-1.2/libgda
+@dirrm include/libgda-1.2
@dirrm etc/libgda