aboutsummaryrefslogtreecommitdiff
path: root/databases/libgnomedb/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 05:38:33 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 05:38:33 +0000
commit5b1bcf9d5008282e604a0dfe34445bafc1d582aa (patch)
treeda2c3e359b80412fd33cbab01102938d15f34ee1 /databases/libgnomedb/Makefile
parentc2e72ecb4e55e0535db90476a44e49dac3006bac (diff)
Notes
Diffstat (limited to 'databases/libgnomedb/Makefile')
-rw-r--r--databases/libgnomedb/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/databases/libgnomedb/Makefile b/databases/libgnomedb/Makefile
index a1e951b53db3..342f2e6f0e1a 100644
--- a/databases/libgnomedb/Makefile
+++ b/databases/libgnomedb/Makefile
@@ -3,13 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/databases/libgnomedb/Makefile,v 1.25 2005/10/13 20:20:19 marcus Exp $
#
PORTNAME= libgnomedb
-PORTVERSION= 1.2.2
+PORTVERSION= 1.9.100
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/libgnomedb/1.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -20,7 +21,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgda2 gtksourceview \
intlhack
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -28,4 +29,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GCONF_SCHEMAS= libgnomedb.schemas
+PLIST_SUB= VERSION=${PORTVERSION:R}
+
.include <bsd.port.mk>