aboutsummaryrefslogtreecommitdiff
path: root/databases/mantis/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-24 10:59:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-24 10:59:21 +0000
commit3161ba348e4cfd4e34ebfc75331509e638f64454 (patch)
tree3dc33fada775353501f63ab75c87d07420a82740 /databases/mantis/Makefile
parent127c0c75947935bb51cff529cafdd1daa192aae9 (diff)
Notes
Diffstat (limited to 'databases/mantis/Makefile')
-rw-r--r--databases/mantis/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/databases/mantis/Makefile b/databases/mantis/Makefile
index 8efd18f10ffc..d128d824e956 100644
--- a/databases/mantis/Makefile
+++ b/databases/mantis/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= mantis
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.5
CATEGORIES= databases www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mantisbt
+DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= dan@langille.org
COMMENT= A bug tracking system written in PHP
@@ -19,18 +20,20 @@ USE_MYSQL= yes
USE_APACHE= yes
USE_PHP= yes
+MANTISDIR?= www/${PORTNAME}
+
SUB_FILES= pkg-message
+SUB_LIST= MANTISDIR=${MANTISDIR}
-post-patch:
- @${RM} ${WRKSRC}/.cvsignore
- @${RM} ${WRKSRC}/core/.cvsignore
+PLIST_SUB= MANTISDIR=${MANTISDIR}
do-install:
- @${ECHO} "Installing in ${PREFIX}/www/mantis"
- ${MKDIR} ${PREFIX}/www/mantis
- ${CP} -R ${WRKSRC}/* ${PREFIX}/www/mantis
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/www/mantis
+ @${ECHO} "Installing in ${PREFIX}/${MANTISDIR}"
+ ${MKDIR} ${PREFIX}/${MANTISDIR}
+ ${CP} -R ${WRKSRC}/* ${PREFIX}/${MANTISDIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MANTISDIR}
+post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>