aboutsummaryrefslogtreecommitdiff
path: root/databases/mariadb-client
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-04-30 20:16:58 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-04-30 20:16:58 +0000
commitab97efbf32c19094e4cd61c3233be31b3a19ef39 (patch)
tree7bb13b731aad8ae8876969f404be4a1743e601ab /databases/mariadb-client
parent179a39f7358089bbf44f7cfb9895aeb542b9d5ce (diff)
downloadports-ab97efbf32c19094e4cd61c3233be31b3a19ef39.tar.gz
ports-ab97efbf32c19094e4cd61c3233be31b3a19ef39.zip
Notes
Diffstat (limited to 'databases/mariadb-client')
-rw-r--r--databases/mariadb-client/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/databases/mariadb-client/Makefile b/databases/mariadb-client/Makefile
index a959768bf2fe..6d8d4a4fb17a 100644
--- a/databases/mariadb-client/Makefile
+++ b/databases/mariadb-client/Makefile
@@ -19,11 +19,11 @@ MASTER_SITES= http://www.percona.com/downloads/MariaDB/${PORTNAME}-${PORTVERSION
MAINTAINER= dgeo@centrale-marseille.fr
COMMENT= A database server - drop-in replacement functionality for MySQL
-
+
LICENSE= GPLv2
-
+
CONFLICTS= mysql-server-[0-9]* mysql-client-[0-9]* mysql-scripts-[0-9]*
-
+
CONFIGURE_ARGS= --with-embedded-server
CPPFLAGS+= -I${LOCALBASE}/include
@@ -125,7 +125,7 @@ LIB_DEPENDS+= event-1.4:${PORTSDIR}/devel/libevent
CONFIGURE_ARGS+= --with-libevent=bundled
.endif
.if defined(WITH_ARIADB)
-PLIST_SUB+= ARIADB=""
+PLIST_SUB+= ARIADB=""
CONFIGURE_ARGS+= --with-plugin-aria --with-aria-tmp-tables
.else
CONFIGURE_ARGS+= --without-plugin-aria
@@ -176,8 +176,8 @@ PLIST_SUB+= INNODB="@comment "
.if defined(WITH_XTRADB)
PLIST_SUB+= XTRADB=""
.else
-CONFIGURE_ARGS+= --without-plugin-xtradb
-PLIST_SUB+= XTRADB="@comment "
+CONFIGURE_ARGS+= --without-plugin-xtradb
+PLIST_SUB+= XTRADB="@comment "
.endif
.if defined(WITH_OQGRAPH)
CONFIGURE_ARGS+= --with-plugin-oqgraph
@@ -208,7 +208,7 @@ WITH_PARTITION=yes
# ndb_print_backup_file.1 ndb_print_schema_file.1 \
# ndb_print_sys_file.1 ndb_restore.1 ndb_select_all.1 \
# ndb_select_count.1 ndb_show_tables.1 ndb_size.pl.1 ndb_waiter.1
-PLIST_SUB+= NDB=""
+PLIST_SUB+= NDB=""
.else
CONFIGURE_ARGS+= --without-plugin-ndbcluster
PLIST_SUB+= NDB="@comment "
@@ -235,12 +235,12 @@ pre-fetch:
@${ECHO} " WITH_XCHARSET=list Define other built-in charsets (selected: ${WITH_XCHARSET})."
@${ECHO} " WITH_COLLATION=collate Define default collation (def: latin1_swedish_ci selected: ${WITH_COLLATION})."
@${ECHO} ""
-
+
post-patch:
@${REINPLACE_CMD} -e '/^install:/ s|^\(install:\).*$$|\1|' \
${WRKSRC}/mysql-test/Makefile.in ${WRKSRC}/sql-bench/Makefile.in
-
+
port-install:
@${CAT} pkg-message
-
+
.include <bsd.port.mk>