aboutsummaryrefslogtreecommitdiff
path: root/databases/mariadb-scripts/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2011-04-29 16:24:56 +0000
committerBeech Rintoul <beech@FreeBSD.org>2011-04-29 16:24:56 +0000
commit8042ee8a11c90c846bee45454179de1c0e0e4b2b (patch)
treeec77b6e426a1a95d53062a0c806c286a0fcfe355 /databases/mariadb-scripts/Makefile
parent58d6ef4f23455e40e3e4109b7223e8101a87a27a (diff)
downloadports-8042ee8a11c90c846bee45454179de1c0e0e4b2b.tar.gz
ports-8042ee8a11c90c846bee45454179de1c0e0e4b2b.zip
Notes
Diffstat (limited to 'databases/mariadb-scripts/Makefile')
-rw-r--r--databases/mariadb-scripts/Makefile168
1 files changed, 162 insertions, 6 deletions
diff --git a/databases/mariadb-scripts/Makefile b/databases/mariadb-scripts/Makefile
index 3399cdfde041..a959768bf2fe 100644
--- a/databases/mariadb-scripts/Makefile
+++ b/databases/mariadb-scripts/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mariadb
-PORTVERSION= 5.2.4
+PORTVERSION= 5.2.5
CATEGORIES= databases
MASTER_SITES= http://www.percona.com/downloads/MariaDB/${PORTNAME}-${PORTVERSION}/kvm-tarbake-jaunty-x86/ \
http://ftp.osuosl.org/pub/mariadb/${PORTNAME}-${PORTVERSION}/kvm-tarbake-jaunty-x86/ \
@@ -18,13 +18,16 @@ MASTER_SITES= http://www.percona.com/downloads/MariaDB/${PORTNAME}-${PORTVERSION
http://mirrors.fe.up.pt/pub/mariadb/${PORTNAME}-${PORTVERSION}/kvm-tarbake-jaunty-x86/
MAINTAINER= dgeo@centrale-marseille.fr
-COMMENT= A database server that offers drop-in replacement functionality for MySQL
-
+COMMENT= A database server - drop-in replacement functionality for MySQL
+
LICENSE= GPLv2
+
+CONFLICTS= mysql-server-[0-9]* mysql-client-[0-9]* mysql-scripts-[0-9]*
+
+CONFIGURE_ARGS= --with-embedded-server
-CONFLICTS= mysql-server-[0-9]* mysql-client-[0-9]*
+CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS= --with-embedded-server
DATADIR= ${PREFIX}/share/mysql
GNU_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/lib/mysql
@@ -83,8 +86,161 @@ MAN1= comp_err.1 \
MAN8= mysqld.8 \
mysqlmanager.8
+OPTIONS= ARIADB "Aria storage engine" On \
+ ARCHIVE "Archive storage plugin" On \
+ BLACKHOLE "Blackhole storage engine" On \
+ FEDERATED "Federated (old) storage engine" Off \
+ FEDERATEDX "FederatedX storage engine (Federated replacement)" On \
+ INNODB "InnoDB (old) engine" Off \
+ XTRADB "XtraDB (InnoDB replacement) engine" On \
+ OQGRAPH "Open Query Graph Computation engine" Off \
+ PBXT "MVCC-based transactional engine" Off \
+ PARTITION "Partitioning support" Off \
+ SPHINX "SE client for Sphinx search daemon" On \
+ NDB "Enable NDB support (imply PARTITION)" Off \
+ EXAMPLES "Example engine,daemon and ftsearch plugins" Off \
+ PORTEVENT "Use libevent from ports" Off \
+ SSL "Activate SSL support (yassl)" Off \
+ OPENSSL "Use OpenSSL instead of bundled yassl" Off
+
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+CONFIGURE_ARGS+= --enable-assembler
+.endif
+.if defined(WITH_SSL)
+.if defined(WITH_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
+.else
+CONFIGURE_ARGS+= --with-ssl=bundled
+.endif
+.else
+CONFIGURE_ARGS+= --without-ssl
+.endif
+.if defined(WITH_PORTEVENT)
+CONFIGURE_ARGS+= --with-libevent=${LOCALBASE}
+LIB_DEPENDS+= event-1.4:${PORTSDIR}/devel/libevent
+.else
+CONFIGURE_ARGS+= --with-libevent=bundled
+.endif
+.if defined(WITH_ARIADB)
+PLIST_SUB+= ARIADB=""
+CONFIGURE_ARGS+= --with-plugin-aria --with-aria-tmp-tables
+.else
+CONFIGURE_ARGS+= --without-plugin-aria
+PLIST_SUB+= ARIADB="@comment "
+.endif
+.if defined(WITH_SPHINX)
+PLIST_SUB+= SPHINX=""
+.else
+CONFIGURE_ARGS+= --without-plugin-sphinx
+PLIST_SUB+= SPHINX="@comment "
+.endif
+.if defined(WITH_ARIADB)
+PLIST_SUB+= ARIADB=""
+.else
+CONFIGURE_ARGS+= --without-plugin-aria
+PLIST_SUB+= ARIADB="@comment "
+.endif
+.if defined(WITH_ARCHIVE)
+PLIST_SUB+= ARCHIVE=""
+.else
+CONFIGURE_ARGS+= --without-plugin-archive
+PLIST_SUB+= ARCHIVE="@comment "
+.endif
+.if defined(WITH_BLACKHOLE)
+PLIST_SUB+= BLACKHOLE=""
+.else
+CONFIGURE_ARGS+= --without-plugin-blackhole
+PLIST_SUB+= BLACKHOLE="@comment "
+.endif
+.if defined(WITH_FEDERATED)
+PLIST_SUB+= FEDERATED=""
+.else
+CONFIGURE_ARGS+= --without-plugin-federated
+PLIST_SUB+= FEDERATED="@comment "
+.endif
+.if defined(WITH_FEDERATEDX)
+PLIST_SUB+= FEDERATEDX=""
+.else
+CONFIGURE_ARGS+= --without-plugin-federatedx
+PLIST_SUB+= FEDERATEDX="@comment "
+.endif
+.if defined(WITH_INNODB)
+PLIST_SUB+= INNODB=""
+.else
+CONFIGURE_ARGS+= --without-plugin-innodb_plugin
+PLIST_SUB+= INNODB="@comment "
+.endif
+.if defined(WITH_XTRADB)
+PLIST_SUB+= XTRADB=""
+.else
+CONFIGURE_ARGS+= --without-plugin-xtradb
+PLIST_SUB+= XTRADB="@comment "
+.endif
+.if defined(WITH_OQGRAPH)
+CONFIGURE_ARGS+= --with-plugin-oqgraph
+PLIST_SUB+= OQGRAPH=""
+LIB_DEPENDS+= boost_system.4:${PORTSDIR}/devel/boost-libs
+.else
+CONFIGURE_ARGS+= --without-plugin-oqgraph
+PLIST_SUB+= OQGRAPH="@comment "
+.endif
+.if defined(WITH_PBXT)
+CONFIGURE_ARGS+= --with-plugin-pbxt
+PLIST_SUB+= PBXT=""
+.else
+CONFIGURE_ARGS+= --without-plugin-pbxt
+PLIST_SUB+= PBXT="@comment "
+.endif
+.if defined(WITH_EXAMPLES)
+PLIST_SUB+= EXAMPLES=""
+.else
+CONFIGURE_ARGS+= --without-plugin-example --without-plugin-daemon_example --without-plugin-ftexample
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
+.if defined(WITH_NDB)
+CONFIGURE_ARGS+= --with-plugin-ndbcluster
+WITH_PARTITION=yes
+#MAN1+= ndb_config.1 ndb_delete_all.1 ndb_desc.1 ndb_drop_index.1 \
+# ndb_drop_table.1 ndb_error_reporter.1 ndb_mgm.1 \
+# ndb_print_backup_file.1 ndb_print_schema_file.1 \
+# ndb_print_sys_file.1 ndb_restore.1 ndb_select_all.1 \
+# ndb_select_count.1 ndb_show_tables.1 ndb_size.pl.1 ndb_waiter.1
+PLIST_SUB+= NDB=""
+.else
+CONFIGURE_ARGS+= --without-plugin-ndbcluster
+PLIST_SUB+= NDB="@comment "
+.endif
+.if defined(WITH_PARTITION)
+CONFIGURE_ARGS+= --with-plugin-partition
+.else
+CONFIGURE_ARGS+= --without-plugin-partition
+.endif
+
+.if defined(WITH_CHARSET) && ${WITH_CHARSET} != ""
+CONFIGURE_ARGS+= --with-charset=${WITH_CHARSET}
+.endif
+.if defined(WITH_XCHARSET) && ${WITH_XCHARSET} != ""
+CONFIGURE_ARGS+= --with-extra-charsets=${WITH_XCHARSET}
+.endif
+.if defined(WITH_COLLATION) && ${WITH_COLLATION} != ""
+CONFIGURE_ARGS+= --with-collation=${WITH_COLLATION}
+.endif
+
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} " WITH_CHARSET=charset Define the primary built-in charset (def: latin1 selected: ${WITH_CHARSET})."
+ @${ECHO} " WITH_XCHARSET=list Define other built-in charsets (selected: ${WITH_XCHARSET})."
+ @${ECHO} " WITH_COLLATION=collate Define default collation (def: latin1_swedish_ci selected: ${WITH_COLLATION})."
+ @${ECHO} ""
+
post-patch:
@${REINPLACE_CMD} -e '/^install:/ s|^\(install:\).*$$|\1|' \
${WRKSRC}/mysql-test/Makefile.in ${WRKSRC}/sql-bench/Makefile.in
-
+
+port-install:
+ @${CAT} pkg-message
+
.include <bsd.port.mk>