aboutsummaryrefslogtreecommitdiff
path: root/databases/mdcached
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2012-02-27 15:28:27 +0000
committerAlex Dupre <ale@FreeBSD.org>2012-02-27 15:28:27 +0000
commitef0e1865f86118c9354336978ff41e87d8f17f81 (patch)
tree727b0c537031d677449fabccdf00aaae3dd623ed /databases/mdcached
parentd5c8a54e9061137eb52edb7f41bf9dca9f2afbf1 (diff)
downloadports-ef0e1865f86118c9354336978ff41e87d8f17f81.tar.gz
ports-ef0e1865f86118c9354336978ff41e87d8f17f81.zip
Bullet Cache is a memory database intended to be used much like memcached,
but offering much higher flexibility through use of record tags which can be used to perform bulk operations on sets of records. It has its own binary network protocol which is accessible through Unix domain sockets and through TCP. It is indended to be accessed through a high-performance C library. WWW: http://mdcached.sourceforge.net/ PR: ports/164872 Submitted by: Ivan Voras <ivoras@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=292308
Diffstat (limited to 'databases/mdcached')
-rw-r--r--databases/mdcached/Makefile47
-rw-r--r--databases/mdcached/distinfo2
-rw-r--r--databases/mdcached/pkg-descr7
-rw-r--r--databases/mdcached/pkg-plist7
4 files changed, 63 insertions, 0 deletions
diff --git a/databases/mdcached/Makefile b/databases/mdcached/Makefile
new file mode 100644
index 000000000000..c62566760ac9
--- /dev/null
+++ b/databases/mdcached/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: mdcached
+# Date created: 3 February 2012
+# Whom: Ivan Voras <ivoras@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mdcached
+PORTVERSION= 1.0.2
+CATEGORIES= databases net
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ivoras@FreeBSD.org
+COMMENT= A high performance cache server similar to memcached
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}
+MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
+MAN1= ${PORTNAME}.1
+
+PORTDOCS= UserGuide.txt mdcached.txt
+
+post-patch:
+ @${REINPLACE_CMD} 's|ADDCFLAGS = -Wall -g -O3 -march=native|ADDCFLAGS = ${CFLAGS}|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} 's|/usr/local|${PREFIX}|' \
+ ${WRKSRC}/FreeBSD/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_LIB} ${WRKSRC}/lib${PORTNAME}.so.1 ${PREFIX}/lib
+ ${LN} -s lib${PORTNAME}.so.1 ${PREFIX}/lib/lib${PORTNAME}.so
+ ${INSTALL_LIB} ${WRKSRC}/lib${PORTNAME}.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/mc_protocol.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/mc_client.h ${PREFIX}/include
+ ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/FreeBSD/${PORTNAME} ${PREFIX}/etc/rc.d
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ for doc in ${PORTDOCS}; do \
+ ${INSTALL_DATA} ${WRKSRC}/doc/$${doc} ${DOCSDIR}; \
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/mdcached/distinfo b/databases/mdcached/distinfo
new file mode 100644
index 000000000000..4d8ed95c60de
--- /dev/null
+++ b/databases/mdcached/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mdcached-1.0.2.tgz) = c5d049331ac1ab869ad288a0416f40adc7454a37fe289898d0bc48b0b4f00db4
+SIZE (mdcached-1.0.2.tgz) = 268736
diff --git a/databases/mdcached/pkg-descr b/databases/mdcached/pkg-descr
new file mode 100644
index 000000000000..871f751012a3
--- /dev/null
+++ b/databases/mdcached/pkg-descr
@@ -0,0 +1,7 @@
+Bullet Cache is a memory database intended to be used much like memcached,
+but offering much higher flexibility through use of record tags which can be
+used to perform bulk operations on sets of records. It has its own binary
+network protocol which is accessible through Unix domain sockets and through
+TCP. It is indended to be accessed through a high-performance C library.
+
+WWW: http://mdcached.sourceforge.net/
diff --git a/databases/mdcached/pkg-plist b/databases/mdcached/pkg-plist
new file mode 100644
index 000000000000..c36a903f869b
--- /dev/null
+++ b/databases/mdcached/pkg-plist
@@ -0,0 +1,7 @@
+bin/mdcached
+etc/rc.d/mdcached
+include/mc_client.h
+include/mc_protocol.h
+lib/libmdcached.a
+lib/libmdcached.so
+lib/libmdcached.so.1