aboutsummaryrefslogtreecommitdiff
path: root/databases/memcachedb
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-07-12 09:09:44 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-07-12 09:09:44 +0000
commit16d061e03f8e5a6b33107cd94e315a79f9aa03a5 (patch)
tree86e09a55a2d5d7db2588b01ef35fea942e3b9330 /databases/memcachedb
parente8c512d5a7f24abf0fd7529ad355bca0381b24e1 (diff)
downloadports-16d061e03f8e5a6b33107cd94e315a79f9aa03a5.tar.gz
ports-16d061e03f8e5a6b33107cd94e315a79f9aa03a5.zip
Notes
Diffstat (limited to 'databases/memcachedb')
-rw-r--r--databases/memcachedb/Makefile15
-rw-r--r--databases/memcachedb/pkg-descr16
-rw-r--r--databases/memcachedb/pkg-plist6
3 files changed, 20 insertions, 17 deletions
diff --git a/databases/memcachedb/Makefile b/databases/memcachedb/Makefile
index 1c891acbaa49..b116c4b8778d 100644
--- a/databases/memcachedb/Makefile
+++ b/databases/memcachedb/Makefile
@@ -3,27 +3,26 @@
PORTNAME= memcachedb
PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= meritus@innervision.pl
-COMMENT= Distributed storage system designed for persistent
+COMMENT= Distributed storage system designed for persistence
+
+LICENSE= BSD3CLAUSE
LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
-CFLAGS= -I"${BDB_INCLUDE_DIR}"
+CFLAGS+= -I"${BDB_INCLUDE_DIR}"
CONFIGURE_ARGS= --enable-threads --with-bdb="${LOCALBASE}" \
--with-libevent="${LOCALBASE}"
GNU_CONFIGURE= yes
LDFLAGS+= -l"${BDB_LIB_NAME}" -L"${LOCALBASE}/lib"
-MCDBDIR?= /var/db/memcachedb
-USE_BDB= 47+
+USE_BDB= 48
USE_RC_SUBR= ${PORTNAME}
-NO_STAGE= yes
post-install:
- ${MKDIR} ${MCDBDIR} || ${TRUE}
- ${CHOWN} nobody:nobody ${MCDBDIR}
+ ${MKDIR} ${STAGEDIR}/var/db/memcachedb
.include <bsd.port.mk>
diff --git a/databases/memcachedb/pkg-descr b/databases/memcachedb/pkg-descr
index b49a7dd91c03..70d9e3ab4a29 100644
--- a/databases/memcachedb/pkg-descr
+++ b/databases/memcachedb/pkg-descr
@@ -1,10 +1,8 @@
-Memcachedb is a distributed storage system designed for persistent. We
-simplely hacked from memcached and tugela. But neither of them.
-Memcachedb is not a cache solution, it is a persistent solution for
-high-frequency writing and reading. It conforms to memcache protocol
-(not completed, see below), so any memcached client can have
-connectivity with memcachedb. Memcachedb uses Berkeley DB as a storing
-backend, so lots of features including transaction and replication are
-supported.
+MemcacheDB is a distributed storage system designed for persistence.
+It is not a cache solution, but a persistent storage engine for fast and
+reliable key-value based object storage and retrieval. It conforms to
+memcache protocol (not complete), so any memcached client can connect to
+it. MemcacheDB uses Berkeley DB as a storing backend, so lots of
+features including transaction and replication are supported.
-WWW: http://code.google.com/p/memcachedb/
+WWW: http://code.google.com/p/memcachedb/
diff --git a/databases/memcachedb/pkg-plist b/databases/memcachedb/pkg-plist
index d83f60f2f20d..85d1c3387005 100644
--- a/databases/memcachedb/pkg-plist
+++ b/databases/memcachedb/pkg-plist
@@ -1,3 +1,9 @@
@stopdaemon memcachedb
bin/memcachedb
+@owner nobody
+@group nobody
+@mode 770
@dirrmtry /var/db/memcachedb
+@mode
+@group
+@owner