aboutsummaryrefslogtreecommitdiff
path: root/databases/monetdb
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-08-10 12:24:04 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-08-10 12:24:04 +0000
commit0e9d4ee9f8bbccfa3bcfc44b6b198be7cd69485d (patch)
treed56f7623104e63e887712c321d76cf5cdc383fba /databases/monetdb
parentb43e712c3601cb19f611ae0ed44e69d14a9e8746 (diff)
downloadports-0e9d4ee9f8bbccfa3bcfc44b6b198be7cd69485d.tar.gz
ports-0e9d4ee9f8bbccfa3bcfc44b6b198be7cd69485d.zip
Notes
Diffstat (limited to 'databases/monetdb')
-rw-r--r--databases/monetdb/Makefile3
-rw-r--r--databases/monetdb/files/patch-configure15
2 files changed, 14 insertions, 4 deletions
diff --git a/databases/monetdb/Makefile b/databases/monetdb/Makefile
index 7fcf0b3af0e8..68f3a483bc5d 100644
--- a/databases/monetdb/Makefile
+++ b/databases/monetdb/Makefile
@@ -208,7 +208,8 @@ CONFIGURE_ARGS+= -with-password-backend=SHA512
# Compile chokes with version of flex on FreeBSD 8 and 9
# with "unknown flag '-'"
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-BUILD_DEPENDS+= flex:${PORTSDIR}/textproc/flex
+BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+CONFIGURE_ENV+= LEX=${LOCALBASE}/bin/flex
.endif
pre-install:
diff --git a/databases/monetdb/files/patch-configure b/databases/monetdb/files/patch-configure
index a3f7873f2264..0fce7bd2eedf 100644
--- a/databases/monetdb/files/patch-configure
+++ b/databases/monetdb/files/patch-configure
@@ -1,6 +1,14 @@
---- configure.orig 2014-02-02 18:41:42.664332968 +0100
-+++ configure 2014-02-02 18:41:59.346331204 +0100
-
+--- configure.orig 2013-11-20 11:27:41.000000000 +0000
++++ configure 2014-08-10 12:16:46.974210130 +0000
+@@ -17262,7 +17262,7 @@
+ ;;
+ esac
+ case "$LEX" in
+- flex*) : ;;
++ *flex*) : ;;
+ *)
+ if test "x$enable_jaql" = xyes; then
+ as_fn_error $? "MonetDB/JAQL requires flex" "$LINENO" 5
@@ -17802,6 +17802,7 @@
/* end confdefs.h. */
#include <stdio.h>
@@ -87,3 +95,4 @@
+if x"$have_zlib" = x"yes" ; then
$as_echo "#define HAVE_LIBZ 1" >>confdefs.h
+