aboutsummaryrefslogtreecommitdiff
path: root/databases/mrtg-mysql-load/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-02 19:25:11 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-02 19:25:11 +0000
commit270a21b5b0fd989124ccd100bae319909e908252 (patch)
treeab506cf50d29da72e161a8b72fa4dc841c048870 /databases/mrtg-mysql-load/Makefile
parent3718d819cf8717d981484f085926d309801e526c (diff)
downloadports-270a21b5b0fd989124ccd100bae319909e908252.tar.gz
ports-270a21b5b0fd989124ccd100bae319909e908252.zip
Notes
Diffstat (limited to 'databases/mrtg-mysql-load/Makefile')
-rw-r--r--databases/mrtg-mysql-load/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/databases/mrtg-mysql-load/Makefile b/databases/mrtg-mysql-load/Makefile
new file mode 100644
index 000000000000..2bfee2bbc365
--- /dev/null
+++ b/databases/mrtg-mysql-load/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mrtg-mysql-load
+# Date created: 2004-04-08
+# Whom: Piet Delport <pjd@303.za.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mrtg-mysql-load
+PORTVERSION= 1.02
+CATEGORIES= databases net-mgmt
+MASTER_SITES= http://www.bitbybit.dk/mysqlfaq/mrtg-mysql-load/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A MySQL load analysis fetcher for MRTG
+
+RUN_DEPENDS= mrtg:${PORTSDIR}/net-mgmt/mrtg \
+ mysqladmin:${PORTSDIR}/databases/mysql40-client
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+
+MAN1= ${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PERL%%|${PERL}|' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/etc/mrtg
+ @${INSTALL_DATA} ${WRKSRC}/mrtg-cfg.example ${PREFIX}/etc/mrtg/mrtg.cfg-mysql-load.example
+ @${INSTALL_DATA} ${WRKSRC}/mysql-load-cfg.example ${PREFIX}/etc/mrtg/mysql-load-cfg.example
+ @${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>