aboutsummaryrefslogtreecommitdiff
path: root/databases/msql
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-11-27 19:42:02 +0000
committerChris Rees <crees@FreeBSD.org>2011-11-27 19:42:02 +0000
commite5377361ed33e9cf649cd96c60f08cdc20dccd3c (patch)
tree6f7a3d3de6db3ee3b16c21d82a317b50c68acbe1 /databases/msql
parent52bd1e00f8f284827a861aeb9aaac688fbef37e9 (diff)
downloadports-e5377361ed33e9cf649cd96c60f08cdc20dccd3c.tar.gz
ports-e5377361ed33e9cf649cd96c60f08cdc20dccd3c.zip
Notes
Diffstat (limited to 'databases/msql')
-rw-r--r--databases/msql/Makefile28
-rw-r--r--databases/msql/files/post-install-notes9
-rw-r--r--databases/msql/pkg-deinstall15
-rw-r--r--databases/msql/pkg-install34
4 files changed, 24 insertions, 62 deletions
diff --git a/databases/msql/Makefile b/databases/msql/Makefile
index e8cc5c4abf50..d3d4e6124370 100644
--- a/databases/msql/Makefile
+++ b/databases/msql/Makefile
@@ -17,9 +17,13 @@ CONFLICTS= msql-3*
USE_LDCONFIG= YES
USE_PERL5= YES
+PKGMESSAGE= ${FILESDIR}/post-install-notes
+
+USERS= ${PORTNAME}
+GROUPS= ${USERS}
# Not free for commercial use.
-RESTRICTED= "restrictive copyright (no commercial use)"
+RESTRICTED= restrictive copyright (no commercial use)
CFLAGS+= -DANSI_ARGS
MAKE_ENV+= WRKSRC=${WRKSRC}
@@ -41,8 +45,6 @@ do-configure:
pre-install:
@${SETENV} ${MAKE_ENV} ${PERL} ${SCRIPTDIR}/check_old_version
- pwd
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/scripts/run_daemon ${PREFIX}/bin
@@ -62,14 +64,26 @@ post-install:
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/msql2.sh \
${PREFIX}/etc/rc.d/msql2.sh; \
fi
-.if !defined(BATCH)
- @ /usr/bin/more -e ${FILESDIR}/post-install-notes
-.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900000
+BROKEN= Broken on FreeBSD 9+
+.endif
+
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE=- You must manually obtain ${DISTFILES} from 'http://www.Hughes.com.au/download/' and place it in ${DISTDIR}. The distribution requires registration prior to use
+DISTFILE_INSTRUCTIONS= \n\
+- You must manually obtain ${DISTFILES} from \n\
+http://www.Hughes.com.au/download/\n\
+and place it in ${DISTDIR}.\n\
+The distribution requires registration prior to use.\n\n
+.endif
+
+pre-fetch:
+.if defined(DISTFILE_INSTRUCTIONS)
+ @${PRINTF} "${DISTFILE_INSTRUCTIONS}"
+ @exit 1
.endif
.include <bsd.port.post.mk>
diff --git a/databases/msql/files/post-install-notes b/databases/msql/files/post-install-notes
index a6f896f7838c..20b5029017de 100644
--- a/databases/msql/files/post-install-notes
+++ b/databases/msql/files/post-install-notes
@@ -21,14 +21,14 @@ your payment.
FreeBSD-specific port notes
---------------------------
-The port of mSQL 1.x lived in it's own tree, /usr/local/Minerva. At the
+The port of mSQL 1.x lived in its own tree, /usr/local/Minerva. At the
time, mSQL was a part of a larger project called Minerva, to which other
tools would be added. These other tools would also live in
/usr/local/Minerva.
As of the 2.x release of mSQL, the author of mSQL has put many of these
tools into the base mSQL distribution, and so it is no longer feasible to
-have the program live in it's own directory.
+have the program live in its own directory.
So, in keeping with the BSD directory tree structure, you will find the
following changes between the "official" mSQL 2.x distribution and the
@@ -44,12 +44,9 @@ Documentation states: Port uses:
/usr/local/Hughes/msql.conf /usr/local/etc/msql2/msql.conf
/usr/local/Hughes/msql.acl /usr/local/etc/msql2/msql.acl
-To start the daemon, run /usr/local/etc/rc.d/msql2.sh as root. This will
+To start the daemon, run /usr/local/etc/rc.d/msql2 as root. This will
start the daemon as the 'msql' user to make sure that the access permissions
are correct. This script will be executed upon system startup.
Remember that mSQL is not free for use. Please see
/usr/local/share/doc/msql/License for details.
-
---
-j.
diff --git a/databases/msql/pkg-deinstall b/databases/msql/pkg-deinstall
deleted file mode 100644
index 8275facaa13f..000000000000
--- a/databases/msql/pkg-deinstall
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-#
-
-if [ "$2" != "POST-DEINSTALL" ]; then
- exit 0
-fi
-
-USER=msql
-
-if pw usershow "${USER}" 2>/dev/null 1>&2; then
- echo "To delete MSQL user permanently, use 'pw userdel ${USER}'"
-fi
-
-exit 0
diff --git a/databases/msql/pkg-install b/databases/msql/pkg-install
deleted file mode 100644
index 97f3761cda54..000000000000
--- a/databases/msql/pkg-install
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-#
-
-if [ "$2" != "PRE-INSTALL" ]; then
- exit 0
-fi
-
-USER=msql
-GROUP=${USER}
-UID=98
-GID=${UID}
-
-if ! pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
- if pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
-fi
-
-if ! pw usershow "${USER}" 2>/dev/null 1>&2; then
- if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -s "/bin/sh" -d "/var/db/msqldb" \
- -c "mSQL-2 pseudo-user"; \
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
-fi
-exit 0