aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql++3/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-04-05 11:54:42 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-04-05 11:54:42 +0000
commit21d3c3e73fde13d7e9dae67dadf70c344208a994 (patch)
tree2af9a0d0ca0f171ff586abef320f256c7f0d6411 /databases/mysql++3/Makefile
parentcc3995f98849946f98e6f2d807ea2054465db5a0 (diff)
downloadports-21d3c3e73fde13d7e9dae67dadf70c344208a994.tar.gz
ports-21d3c3e73fde13d7e9dae67dadf70c344208a994.zip
Notes
Diffstat (limited to 'databases/mysql++3/Makefile')
-rw-r--r--databases/mysql++3/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/databases/mysql++3/Makefile b/databases/mysql++3/Makefile
new file mode 100644
index 000000000000..214d2ef681d1
--- /dev/null
+++ b/databases/mysql++3/Makefile
@@ -0,0 +1,42 @@
+# ports collection makefile for: MySQL++
+# Date created: 2008-04-03
+# Whom: Vlad GALU <dudu@dudu.ro>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysql++
+PORTVERSION= 3.0.1
+CATEGORIES= databases devel
+MASTER_SITES= http://tangentsoft.net/mysql++/releases/ \
+ T32.TecNik93.com/ports/others_ports/${PORTNAME}/sources/
+PKGNAMESUFFIX= -mysql${MYSQL_VER}
+
+MAINTAINER= dudu@dudu.ro
+COMMENT= Complex C++ API for MySQL${MYSQL_VER}
+
+USE_MYSQL= yes
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} --enable-thread-check
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+
+CONFLICTS= ${PORTNAME}*-1.*
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+post-install:
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} pdf ${DOCSDIR})
+ (cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} html ${DOCSDIR})
+.endif
+.ifndef(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.h ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.cpp ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>