aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-connector-c++/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-02-02 17:10:20 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-02-02 17:18:32 +0000
commit9f69094b522c8ce32863eaf52a827e4dceeb9fee (patch)
treea287155a40a78ebe5431e9cd95a914cc6fa3cdf0 /databases/mysql-connector-c++/Makefile
parentf1e3a685c044a0ef7dd54dd62897d5df63c9aefc (diff)
databases/mysql-connector-c++: Update version 1.1.13=>8.0.32
- Update LICENSE_FILE - Unbreak for mysql 8.0 - OPTIONIZE DOCS - Remove tests as those are no longer provided in distfile Changes: https://dev.mysql.com/doc/relnotes/connector-cpp/en/news-8-0-32.html
Diffstat (limited to 'databases/mysql-connector-c++/Makefile')
-rw-r--r--databases/mysql-connector-c++/Makefile72
1 files changed, 30 insertions, 42 deletions
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index 370203ad1bb1..acc0ce1d0bae 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -1,64 +1,52 @@
PORTNAME= mysql-connector-c++
-PORTVERSION= 1.1.13
-PORTREVISION= 3
+PORTVERSION= 8.0.32
CATEGORIES= databases
MASTER_SITES= MYSQL/Connector-C++
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= bofh@FreeBSD.org
COMMENT= MySQL database connector for C++
WWW= https://dev.mysql.com/doc/relnotes/connector-cpp/en/index.html
LICENSE= GPLv2 # only
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-LIB_DEPENDS= libboost_regex.so:devel/boost-libs
+LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
+ liblz4.so:archivers/liblz4 \
+ libprotobuf.so:devel/protobuf \
+ libzstd.so:archivers/zstd
-USES= cmake compiler:c++11-lang mysql ssl
-IGNORE_WITH_MYSQL= 80
+USES= cmake:noninja compiler:c++17-lang cpe gmake mysql ssl
+CPE_VENDOR= oracle
+USE_CXXSTD= c++17
USE_LDCONFIG= yes
-CMAKE_ARGS= -DDOC_DESTINATION="${DOCSDIR}" -DCMAKE_ENABLE_C++11=ON
+CMAKE_ARGS= -DCMAKE_ENABLE_C++17=ON \
+ -DWITH_LZ4=system \
+ -DWITH_PROTOBUF=system \
+ -DWITH_SYSTEM_LIBS=1 \
+ -DWITH_ZLIB=system \
+ -DWITH_ZSTD=system
PLIST_SUB= PORTVERSION=${PORTVERSION}
-
PORTDOCS= *
+
OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
-post-install:
- @${RM} ${STAGEDIR}${DOCSDIR}/INSTALL \
- ${STAGEDIR}${DOCSDIR}/COPYING
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
+DOCS_CMAKE_ON= -DDOC_DESTINATION="${DOCSDIR}" \
+ -DWITH_DOC=ON
-.if defined(MAINTAINER_MODE)
-CMAKE_ARGS+= -DMYSQLCPPCONN_TEST_NOT_IMPLEMENTED:BOOL=1 \
- -DMYSQLCPPCONN_BUILD_EXAMPLES:BOOL=1
+post-install:
+ @${RM} ${STAGEDIR}${PREFIX}/INFO_BIN
+ @${RM} ${STAGEDIR}${PREFIX}/INFO_SRC
-do-test:
-# These tests assume that a database is running on localhost,
-# with user:root and pass:root
- (cd ${WRKDIR}/.build ; \
- test/CJUnitTestsPort/CJUnitTestsPort --verbose ; \
- test/driver_test --verbose ; \
- test/static_test --verbose ; \
- examples/connect --verbose ; \
- examples/connection_meta_schemaobj --verbose ; \
- examples/debug --verbose ; \
- examples/dynamic_load --verbose ; \
- examples/exceptions --verbose ; \
- examples/prepared_statement --verbose ; \
- examples/resultset --verbose ; \
- examples/resultset_binary --verbose ; \
- examples/resultset_meta --verbose ; \
- examples/resultset_types --verbose ; \
- examples/statement --verbose ; \
- test/unit/classes/art_resultset --verbose ; \
- test/unit/classes/connection --verbose ; \
- test/unit/classes/databasemetadata --verbose ; \
- test/unit/classes/parametermetadata --verbose ; \
- test/unit/classes/preparedstatement --verbose ; \
- test/unit/classes/resultset --verbose ; \
- test/unit/classes/resultsetmetadata --verbose ; \
- test/unit/classes/savepoint --verbose ; \
- test/unit/classes/statement )
-.endif
+post-install-DOCS-on:
+ @${RM} ${STAGEDIR}${DOCSDIR}/INSTALL \
+ ${STAGEDIR}${DOCSDIR}/LICENSE.txt
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${BUILD_WRKSRC}/doc && \
+ ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>