aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-connector-c++
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /databases/mysql-connector-c++
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'databases/mysql-connector-c++')
-rw-r--r--databases/mysql-connector-c++/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index be23c0179789..c35557727230 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
-USES= cmake:outsource compiler:c++11-lang mysql ssl
+USES= cmake compiler:c++11-lang mysql ssl
USE_LDCONFIG= yes
CMAKE_ARGS= -DDOC_DESTINATION="${DOCSDIR}" -DCMAKE_ENABLE_C++11=ON