aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-connector-c++
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-11-21 16:32:19 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-11-21 16:32:19 +0000
commit6f4bb37fddc37aae14efb4d510f0bffaeacb5bab (patch)
tree1548ae8b298f3aa3184f953e5f4510d78e58a099 /databases/mysql-connector-c++
parentb50fe58956080d9973d91c54005ae0d59e0162c3 (diff)
downloadports-6f4bb37fddc37aae14efb4d510f0bffaeacb5bab.tar.gz
ports-6f4bb37fddc37aae14efb4d510f0bffaeacb5bab.zip
Notes
Diffstat (limited to 'databases/mysql-connector-c++')
-rw-r--r--databases/mysql-connector-c++/Makefile26
-rw-r--r--databases/mysql-connector-c++/distinfo2
-rw-r--r--databases/mysql-connector-c++/files/patch-CMakeLists.txt21
-rw-r--r--databases/mysql-connector-c++/files/patch-cppconn_CMakeLists.txt15
-rw-r--r--databases/mysql-connector-c++/pkg-descr16
-rw-r--r--databases/mysql-connector-c++/pkg-plist21
6 files changed, 101 insertions, 0 deletions
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
new file mode 100644
index 000000000000..d685d9c07cf4
--- /dev/null
+++ b/databases/mysql-connector-c++/Makefile
@@ -0,0 +1,26 @@
+# New ports collection Makefile for: mysql-connector-c++
+# Date created: 25 August 2011
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysql-connector-c++
+PORTVERSION= 1.1.0
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_MYSQL}
+MASTER_SITE_SUBDIR= Connector-C++
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A MySQL database connector for C++
+
+LICENSE= GPLv2
+
+USE_MYSQL= 51+
+USE_LDCONFIG= yes
+USE_CMAKE= yes
+CMAKE_OUTSOURCE=yes
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/databases/mysql-connector-c++/distinfo b/databases/mysql-connector-c++/distinfo
new file mode 100644
index 000000000000..38caa15a2086
--- /dev/null
+++ b/databases/mysql-connector-c++/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mysql-connector-c++-1.1.0.tar.gz) = dfb8933dada706a1b3188b162fc5a9686b5ed46323bf09548ce291e8dd4545e2
+SIZE (mysql-connector-c++-1.1.0.tar.gz) = 467089
diff --git a/databases/mysql-connector-c++/files/patch-CMakeLists.txt b/databases/mysql-connector-c++/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..635e357410b9
--- /dev/null
+++ b/databases/mysql-connector-c++/files/patch-CMakeLists.txt
@@ -0,0 +1,21 @@
+--- CMakeLists.txt.orig 2010-09-10 11:47:48.000000000 +0200
++++ CMakeLists.txt 2011-11-21 16:42:10.000000000 +0100
+@@ -225,7 +225,6 @@
+ SET( LICENSE_FILENAME "${CPACK_RESOURCE_FILE_LICENSE}")")
+ ENDIF(WIN32)
+
+-INSTALL(FILES ${CPACK_RESOURCE_FILE_README} ${CPACK_RESOURCE_FILE_LICENSE} "${CMAKE_SOURCE_DIR}/ANNOUNCEMENT" DESTINATION "." OPTIONAL)
+
+ SET(COMMON_IGNORE_FILES "/CMakeFiles/" "/Testing/" "/.bzr/" "_CPack_Packages/"
+ ".cmake$" "~" ".swp" ".log" ".gz" ".directory$" "CMakeCache.txt" "Makefile"
+@@ -252,6 +252,10 @@
+ ENDIF(WIN32)
+ MESSAGE(STATUS "Installation path is: ${CMAKE_INSTALL_PREFIX} (overwrite with -DCMAKE_INSTALL_PREFIX=/your/path)")
+
++# this is where generated config.h files are placed
++INCLUDE_DIRECTORIES(${MYSQLCPPCONN_BINARY_DIR})
++INCLUDE_DIRECTORIES(${MYSQLCPPCONN_BINARY_DIR}/cppconn)
++INCLUDE_DIRECTORIES(${MYSQLCPPCONN_BINARY_DIR}/driver/nativeapi)
+
+ ADD_SUBDIRECTORY(cppconn)
+ ADD_SUBDIRECTORY(driver)
diff --git a/databases/mysql-connector-c++/files/patch-cppconn_CMakeLists.txt b/databases/mysql-connector-c++/files/patch-cppconn_CMakeLists.txt
new file mode 100644
index 000000000000..8bafe1851e38
--- /dev/null
+++ b/databases/mysql-connector-c++/files/patch-cppconn_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- cppconn/CMakeLists.txt.orig 2011-11-21 16:34:57.000000000 +0100
++++ cppconn/CMakeLists.txt 2011-11-21 16:36:39.000000000 +0100
+@@ -55,7 +55,6 @@
+
+ SET(MYSQLCPPCONN_INSTALL_HEADERS
+ build_config.h
+- config.h
+ connection.h
+ datatype.h
+ driver.h
+@@ -70,3 +69,4 @@
+ warning.h)
+
+ INSTALL(FILES ${MYSQLCPPCONN_INSTALL_HEADERS} DESTINATION include/cppconn)
++INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/config.h DESTINATION include/cppconn)
diff --git a/databases/mysql-connector-c++/pkg-descr b/databases/mysql-connector-c++/pkg-descr
new file mode 100644
index 000000000000..dc07cfaf5ea7
--- /dev/null
+++ b/databases/mysql-connector-c++/pkg-descr
@@ -0,0 +1,16 @@
+MySQL Connector/C++ is a MySQL database connector for C++ implementing a subset
+of the JDBC 4.0 API. The MySQL Connector/C++ currently features the following
+classes:
+* Connection
+* DatabaseMetaData
+* Driver
+* PreparedStatement
+* ResultSet
+* ResultSetMetaData
+* Savepoint
+* Statement
+The JDBC 4.0 API defines approximately 450 methods for the above mentioned
+classes. MySQL Connector/C++ implements around 80% of these and makes them
+available in the current release.
+
+WWW: http://forge.mysql.com/wiki/Connector_C++
diff --git a/databases/mysql-connector-c++/pkg-plist b/databases/mysql-connector-c++/pkg-plist
new file mode 100644
index 000000000000..288ad08a4011
--- /dev/null
+++ b/databases/mysql-connector-c++/pkg-plist
@@ -0,0 +1,21 @@
+include/cppconn/build_config.h
+include/cppconn/config.h
+include/cppconn/connection.h
+include/cppconn/datatype.h
+include/cppconn/driver.h
+include/cppconn/exception.h
+include/cppconn/metadata.h
+include/cppconn/parameter_metadata.h
+include/cppconn/prepared_statement.h
+include/cppconn/resultset.h
+include/cppconn/resultset_metadata.h
+include/cppconn/statement.h
+include/cppconn/sqlstring.h
+include/cppconn/warning.h
+include/mysql_connection.h
+include/mysql_driver.h
+lib/libmysqlcppconn-static.a
+lib/libmysqlcppconn.so
+lib/libmysqlcppconn.so.5.%%PORTVERSION%%
+lib/libmysqlcppconn.so.5
+@dirrm include/cppconn