aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-editor
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
commit6b470bae86247b8cb79b0dc6e43078df2f84c4ae (patch)
treee1545740f8801646e19c181252cb4c4e39df9ca8 /databases/mysql-editor
parentb63d72fe5f0a821fa729c344f9b44de714603abc (diff)
downloadports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.tar.gz
ports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.zip
Notes
Diffstat (limited to 'databases/mysql-editor')
-rw-r--r--databases/mysql-editor/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/databases/mysql-editor/Makefile b/databases/mysql-editor/Makefile
index a05a8ca3b9eb..6964d9a1df5a 100644
--- a/databases/mysql-editor/Makefile
+++ b/databases/mysql-editor/Makefile
@@ -15,8 +15,7 @@ DISTNAME= ${PORTNAME}
MAINTAINER= mi@aldan.algebra.com
COMMENT= CGI scripts in Perl to edit your MySQL tables
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${CGI_BIN}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${CGI_BIN}:${PORTSDIR}/www/apache13
NO_BUILD= True
@@ -32,4 +31,14 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/readme.html ${PREFIX}/share/doc/mysql-editor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>