aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-q4m
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2008-09-02 11:32:01 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2008-09-02 11:32:01 +0000
commit0f74e1f3b7ab3837441323423408766aa488a877 (patch)
tree3127cdd5b177803a8697abce007609d463a2bfd9 /databases/mysql-q4m
parent9b0db62ef707ae55b775eb96e030633749e33966 (diff)
downloadports-0f74e1f3b7ab3837441323423408766aa488a877.tar.gz
ports-0f74e1f3b7ab3837441323423408766aa488a877.zip
Notes
Diffstat (limited to 'databases/mysql-q4m')
-rw-r--r--databases/mysql-q4m/Makefile50
-rw-r--r--databases/mysql-q4m/distinfo3
-rw-r--r--databases/mysql-q4m/pkg-descr7
-rw-r--r--databases/mysql-q4m/pkg-plist5
4 files changed, 65 insertions, 0 deletions
diff --git a/databases/mysql-q4m/Makefile b/databases/mysql-q4m/Makefile
new file mode 100644
index 000000000000..87b8864be653
--- /dev/null
+++ b/databases/mysql-q4m/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: Q4M
+# Date created: 1 September 2008
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= q4m
+PORTVERSION= 0.8.3
+CATEGORIES= databases
+MASTER_SITES= http://q4m.31tools.com/dist/
+PKGNAMEPREFIX= mysql${MYSQL_VER}-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A message queue that works as a pluggable storage engine of MySQL
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/databases/mysql${MYSQL_VER}-server:build \
+ ${LOCALBASE}/include/boost/spirit/core.hpp:${PORTSDIR}/devel/boost
+RUN_DEPENDS= ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
+
+USE_MYSQL= yes
+WANT_MYSQL_VER?= 51
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
+CONFIGURE_ARGS= --prefix="${PREFIX}" \
+ --libdir="${PREFIX}/lib/mysql/plugin" \
+ --with-mysql="$$(cd ${PORTSDIR}/databases/mysql${MYSQL_VER}-server; ${MAKE} -V WRKSRC)"
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= AUTHORS ChangeLog README doc
+PORTEXAMPLES= examples support-files
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ cd ${INSTALL_WRKSRC}; ${COPYTREE_SHARE} ${f} ${DOCSDIR}
+.endfor
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in ${PORTEXAMPLES}
+ cd ${INSTALL_WRKSRC}; ${COPYTREE_SHARE} ${f} ${EXAMPLESDIR}
+.endfor
+ ${RM} ${EXAMPLESDIR}/support-files/q4m-forward
+.endif
+
+test:
+ cd ${BUILD_WRKSRC}; ${PERL} run_tests.pl
+
+.include <bsd.port.mk>
diff --git a/databases/mysql-q4m/distinfo b/databases/mysql-q4m/distinfo
new file mode 100644
index 000000000000..bf1a7bda5bf3
--- /dev/null
+++ b/databases/mysql-q4m/distinfo
@@ -0,0 +1,3 @@
+MD5 (q4m-0.8.3.tar.gz) = b9dcf62062eb6cf5ca82f68f6f3a235e
+SHA256 (q4m-0.8.3.tar.gz) = 7b906dcede0c1aec1c1a25a19a7dfc3a29a97f0aff94475319c24833450b3d3c
+SIZE (q4m-0.8.3.tar.gz) = 356144
diff --git a/databases/mysql-q4m/pkg-descr b/databases/mysql-q4m/pkg-descr
new file mode 100644
index 000000000000..c874024e3a19
--- /dev/null
+++ b/databases/mysql-q4m/pkg-descr
@@ -0,0 +1,7 @@
+Q4M (Queue for MySQL) is a message queue licensed under GPL that works
+as a pluggable storage engine of MySQL 5.1, designed to be robust,
+fast, flexible. The development started in late December of 2007, and
+although it is very primitive, operates quite swiftly.
+
+Author: Kazuho Oku at Cybozu Labs, Inc.
+WWW: http://q4m.31tools.com/
diff --git a/databases/mysql-q4m/pkg-plist b/databases/mysql-q4m/pkg-plist
new file mode 100644
index 000000000000..3737601151f7
--- /dev/null
+++ b/databases/mysql-q4m/pkg-plist
@@ -0,0 +1,5 @@
+bin/q4m-forward
+lib/mysql/plugin/libqueue_engine.a
+lib/mysql/plugin/libqueue_engine.la
+lib/mysql/plugin/libqueue_engine.so
+lib/mysql/plugin/libqueue_engine.so.0