aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql-xql
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-23 02:35:54 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-23 02:35:54 +0000
commit417f3033b7bcbe5f5de9d9dd532703cc83e7c289 (patch)
tree5eb00b883bea005a6f440565a575b658d05ebea2 /databases/mysql-xql
parent6abafe3a2cb37e8004d559aedea2d5c2d0e93abf (diff)
downloadports-417f3033b7bcbe5f5de9d9dd532703cc83e7c289.tar.gz
ports-417f3033b7bcbe5f5de9d9dd532703cc83e7c289.zip
Notes
Diffstat (limited to 'databases/mysql-xql')
-rw-r--r--databases/mysql-xql/Makefile32
-rw-r--r--databases/mysql-xql/distinfo3
-rw-r--r--databases/mysql-xql/files/patch-Makefile.in11
-rw-r--r--databases/mysql-xql/files/patch-configure20
-rw-r--r--databases/mysql-xql/pkg-descr10
-rw-r--r--databases/mysql-xql/pkg-message34
6 files changed, 110 insertions, 0 deletions
diff --git a/databases/mysql-xql/Makefile b/databases/mysql-xql/Makefile
new file mode 100644
index 000000000000..095cc3f5d2a1
--- /dev/null
+++ b/databases/mysql-xql/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: mysql-xql
+# Date created: Mon Dec 28 2009
+# Whom: Mina R Waheeb <syncer@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= mysql-xql
+PORTVERSION= 1.0.0
+CATEGORIES= databases
+MASTER_SITES= http://www.mysqludf.org/lib_mysqludf_xql/
+DISTNAME= lib_mysqludf_xql-${PORTVERSION}
+
+MAINTAINER= syncer@gmail.com
+COMMENT= Library provides XML output functions to MySQL server
+
+USE_GNOME= libxml2
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_MYSQL= yes
+USE_LDCONFIG= yes
+
+PLIST_FILES= \
+ lib/mysql/plugin/lib_mysqludf_xql.a \
+ lib/mysql/plugin/lib_mysqludf_xql.la \
+ lib/mysql/plugin/lib_mysqludf_xql.so
+
+PLIST_DIRS= lib/mysql/plugin
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/databases/mysql-xql/distinfo b/databases/mysql-xql/distinfo
new file mode 100644
index 000000000000..f6fe042dfa3d
--- /dev/null
+++ b/databases/mysql-xql/distinfo
@@ -0,0 +1,3 @@
+MD5 (lib_mysqludf_xql-1.0.0.tar.gz) = ba03762316df04bcf894486ce603e428
+SHA256 (lib_mysqludf_xql-1.0.0.tar.gz) = f992fcd77f7596aee32ddeccbd9b31aa67c9cf2cd04f84959db63f87e1ca0321
+SIZE (lib_mysqludf_xql-1.0.0.tar.gz) = 328273
diff --git a/databases/mysql-xql/files/patch-Makefile.in b/databases/mysql-xql/files/patch-Makefile.in
new file mode 100644
index 000000000000..81f053c03bac
--- /dev/null
+++ b/databases/mysql-xql/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.org 2009-11-20 13:25:51.000000000 +0000
++++ Makefile.in 2009-12-28 02:12:35.000000000 +0000
+@@ -226,7 +226,7 @@
+ includedir = @includedir@
+ infodir = @infodir@
+ install_sh = @install_sh@
+-libdir = @libdir@
++libdir = @MYSQL_PLUGINDIR@
+ libexecdir = @libexecdir@
+ localedir = @localedir@
+ localstatedir = @localstatedir@
diff --git a/databases/mysql-xql/files/patch-configure b/databases/mysql-xql/files/patch-configure
new file mode 100644
index 000000000000..06a15e87fd23
--- /dev/null
+++ b/databases/mysql-xql/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.org 2009-11-19 14:51:20.000000000 +0000
++++ configure 2009-12-28 00:24:17.000000000 +0000
+@@ -14555,7 +14555,7 @@
+
+
+
+-if test -n "$MYSQL_PLUGINDIR" && test "$libdir" == '${exec_prefix}/lib' ; then
++if test -n "$MYSQL_PLUGINDIR" ; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: setting libdir to mysql plugin dir $MYSQL_PLUGINDIR" >&5
+ $as_echo "$as_me: setting libdir to mysql plugin dir $MYSQL_PLUGINDIR" >&6;}
+ libdir=$MYSQL_PLUGINDIR
+@@ -14599,6 +14599,8 @@
+ for i in /usr /usr/local ; do
+ if test -f "$i/lib/xml2Conf.sh" ; then
+ XML2_CONFIG="$i/lib/xml2Conf.sh"
++ elif test -f "$i/etc/xml2Conf.sh" ; then
++ XML2_CONFIG="$i/etc/xml2Conf.sh"
+ elif test -f "$i/lib/libxml2.so"; then
+ XML2_DIR="$i"
+ fi
diff --git a/databases/mysql-xql/pkg-descr b/databases/mysql-xql/pkg-descr
new file mode 100644
index 000000000000..e7b4a624a48b
--- /dev/null
+++ b/databases/mysql-xql/pkg-descr
@@ -0,0 +1,10 @@
+The lib_mysqludf_xql library provides an array of functions,
+which can be used to create XML output directly from MySQL
+using a single SQL query. This prevents having to convert a
+MySQL result to XML in a PHP script, Ruby script, etc.
+
+The library provides the same functionality as SQL/XML, seen
+in MS SQL server and Oracle. However it uses normal functions.
+By using subqueries the same results as SQL/XML can be generated.
+
+WWW: http://www.mysqludf.org/lib_mysqludf_xql/index.php
diff --git a/databases/mysql-xql/pkg-message b/databases/mysql-xql/pkg-message
new file mode 100644
index 000000000000..d8cd261b60c4
--- /dev/null
+++ b/databases/mysql-xql/pkg-message
@@ -0,0 +1,34 @@
+To add the custom functions to your MySQL server use the following syntax:
+(you may install only the functions you need):
+
+USE mysql;
+
+DROP FUNCTION IF EXISTS lib_mysqludf_xql_info;
+DROP FUNCTION IF EXISTS xql_textdecl;
+DROP FUNCTION IF EXISTS xql_pi;
+DROP FUNCTION IF EXISTS xql_dtd;
+DROP FUNCTION IF EXISTS xql_element;
+DROP FUNCTION IF EXISTS xql_forest;
+DROP FUNCTION IF EXISTS xql_concat;
+DROP FUNCTION IF EXISTS xql_agg;
+DROP FUNCTION IF EXISTS xql_comment;
+DROP FUNCTION IF EXISTS xql_cdata;
+DROP FUNCTION IF EXISTS xql_encode;
+
+CREATE FUNCTION lib_mysqludf_xql_info RETURNS STRING SONAME 'lib_mysqludf_xql.so';
+CREATE FUNCTION xql_textdecl RETURNS STRING SONAME 'lib_mysqludf_xql.so';
+CREATE FUNCTION xql_pi RETURNS STRING SONAME 'lib_mysqludf_xql.so';
+CREATE FUNCTION xql_dtd RETURNS STRING SONAME 'lib_mysqludf_xql.so';
+CREATE FUNCTION xql_element RETURNS STRING SONAME 'lib_mysqludf_xql.so';
+CREATE FUNCTION xql_forest RETURNS STRING SONAME 'lib_mysqludf_xql.so';
+CREATE FUNCTION xql_concat RETURNS STRING SONAME 'lib_mysqludf_xql.so';
+CREATE AGGREGATE FUNCTION xql_agg RETURNS STRING SONAME 'lib_mysqludf_xql.so';
+CREATE FUNCTION xql_comment RETURNS STRING SONAME 'lib_mysqludf_xql.so';
+CREATE FUNCTION xql_cdata RETURNS STRING SONAME 'lib_mysqludf_xql.so';
+CREATE FUNCTION xql_encode RETURNS STRING SONAME 'lib_mysqludf_xql.so';
+
+Example for deinstalling a function:
+DROP FUNCTION xql_encode;
+
+For function descriptions, see the following webpage:
+http://http://www.mysqludf.org/lib_mysqludf_xql/index.php