aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql2odbc
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2005-08-31 18:43:34 +0000
committerMax Khon <fjoe@FreeBSD.org>2005-08-31 18:43:34 +0000
commitd5cf0d45a2857f5454a000f63d37a0831672dc49 (patch)
tree10c6b27f5cf61f507eb0b5059f15dfd5ebd5d2db /databases/mysql2odbc
parenta3ab71cee10e2a4431ef00e64a6acfd1175c1a27 (diff)
Notes
Diffstat (limited to 'databases/mysql2odbc')
-rw-r--r--databases/mysql2odbc/Makefile40
-rw-r--r--databases/mysql2odbc/distinfo2
-rw-r--r--databases/mysql2odbc/files/patch-configure11
-rw-r--r--databases/mysql2odbc/files/patch-libfakesql.h17
-rw-r--r--databases/mysql2odbc/files/patch-mtest.c11
-rw-r--r--databases/mysql2odbc/pkg-descr7
-rw-r--r--databases/mysql2odbc/pkg-plist5
7 files changed, 93 insertions, 0 deletions
diff --git a/databases/mysql2odbc/Makefile b/databases/mysql2odbc/Makefile
new file mode 100644
index 000000000000..a6eb3aa04dd1
--- /dev/null
+++ b/databases/mysql2odbc/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: mysql2odbc
+# Date created: 8 Aug 2005
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysql2odbc
+PORTVERSION= 0.99.2
+CATEGORIES= databases
+MASTER_SITES= http://www.iodbc.org/downloads/mysql2odbc/
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= Openlink MySQL-ODBC Gateway
+
+OPTIONS= UNIXODBC "Build with unixODBC" on \
+ IODBC "Build with iODBC" off \
+
+.if !defined(WITH_UNIXODBC) && !defined(WITH_IODBC)
+WITH_UNIXODBC= yes
+.endif
+
+.if defined(WITH_UNIXODBC)
+LIB_DEPENDS= odbc:${PORTSDIR}/databases/unixODBC
+CONFIGURE_ARGS= --with-unixodbc=${LOCALBASE}
+.endif
+
+.if defined(WITH_IODBC)
+LIB_DEPENDS= iodbc:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS= --with-iodbc
+.endif
+
+CONFIGURE_ARGS+=--libdir=${PREFIX}/mysql2odbc
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:13
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/databases/mysql2odbc/distinfo b/databases/mysql2odbc/distinfo
new file mode 100644
index 000000000000..aba22cbbdd1b
--- /dev/null
+++ b/databases/mysql2odbc/distinfo
@@ -0,0 +1,2 @@
+MD5 (mysql2odbc-0.99.2.tar.gz) = 2fd2dafc570dcebb48d9b989b7150f87
+SIZE (mysql2odbc-0.99.2.tar.gz) = 201537
diff --git a/databases/mysql2odbc/files/patch-configure b/databases/mysql2odbc/files/patch-configure
new file mode 100644
index 000000000000..712281f23007
--- /dev/null
+++ b/databases/mysql2odbc/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Sat Aug 20 16:05:00 2005
++++ configure Sat Aug 20 16:05:10 2005
+@@ -8915,7 +8915,7 @@
+
+ echo "$as_me:$LINENO: checking for UnixODBC support" >&5
+ echo $ECHO_N "checking for UnixODBC support... $ECHO_C" >&6
+- if test -f "$withval/lib/libodbc.la"
++ if test -f "$withval/lib/libodbc.a"
+ then
+ found_odbc=yes
+ ODBC_CFLAGS="-I$withval/include"
diff --git a/databases/mysql2odbc/files/patch-libfakesql.h b/databases/mysql2odbc/files/patch-libfakesql.h
new file mode 100644
index 000000000000..a161d055ada0
--- /dev/null
+++ b/databases/mysql2odbc/files/patch-libfakesql.h
@@ -0,0 +1,17 @@
+--- libfakesql.h.orig Sat Aug 20 16:16:01 2005
++++ libfakesql.h Sat Aug 20 16:00:18 2005
+@@ -47,6 +47,14 @@
+
+ ///////////////////////////////////////////////////////////////////////////////
+
++#ifndef FALSE
++#define FALSE 0
++#endif
++
++#ifndef TRUE
++#define TRUE 1
++#endif
++
+ #define NAME_LEN 64 /* Field/table name length */
+ #define HOSTNAME_LENGTH 60
+ #define USERNAME_LENGTH 16
diff --git a/databases/mysql2odbc/files/patch-mtest.c b/databases/mysql2odbc/files/patch-mtest.c
new file mode 100644
index 000000000000..ff3cadcdf7d5
--- /dev/null
+++ b/databases/mysql2odbc/files/patch-mtest.c
@@ -0,0 +1,11 @@
+--- mtest.c.orig Sat Aug 20 16:05:55 2005
++++ mtest.c Sat Aug 20 16:06:01 2005
+@@ -27,7 +27,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <memory.h>
+-#include <malloc.h>
++#include <stdlib.h>
+
+ #ifndef WIN32
+ # include <getopt.h>
diff --git a/databases/mysql2odbc/pkg-descr b/databases/mysql2odbc/pkg-descr
new file mode 100644
index 000000000000..b4d2a7b09a01
--- /dev/null
+++ b/databases/mysql2odbc/pkg-descr
@@ -0,0 +1,7 @@
+The MySQL-ODBC SDK enables you to make MySQL-specific applications
+database-independent without wholesale re-writes of your application code.
+Thus, applications that are written directly to the MySQL call level interface
+now end up being database independent via iODBC (or unixODBC), and usable
+against any ODBC accessible database (including MySQL).
+
+WWW: http://www.iodbc.org/index.php?page=mysql2odbc/index
diff --git a/databases/mysql2odbc/pkg-plist b/databases/mysql2odbc/pkg-plist
new file mode 100644
index 000000000000..26f890559ffa
--- /dev/null
+++ b/databases/mysql2odbc/pkg-plist
@@ -0,0 +1,5 @@
+mysql2odbc/libmysqlclient.a
+mysql2odbc/libmysqlclient.la
+mysql2odbc/libmysqlclient.so
+mysql2odbc/libmysqlclient.so.10
+@dirrm mysql2odbc