aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql323-server
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2003-03-26 23:27:15 +0000
committerMartin Blapp <mbr@FreeBSD.org>2003-03-26 23:27:15 +0000
commit4a0ac5cba00c454ad915b2dabe633c8c4a267c75 (patch)
treedf8b68e28af12cf34ba0a8319ee8002b00de4023 /databases/mysql323-server
parent5989e134350299ab04f5f63151881920cf1091c3 (diff)
Under FreeBSD 5.X, libstdc++ and libsupc++ in /usr/lib use FreeBSD
native (libc_r style) mutexes, thus some of the linked application might indirectly try to pass native style mutexes to linuxthreads pthread functions, either hanging at program startup or overwriting data following the native style mutex. <tegge> Reviewed by: tegge
Notes
Notes: svn path=/head/; revision=77499
Diffstat (limited to 'databases/mysql323-server')
-rw-r--r--databases/mysql323-server/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/databases/mysql323-server/Makefile b/databases/mysql323-server/Makefile
index 2baf43e55f70..eead9343d6ad 100644
--- a/databases/mysql323-server/Makefile
+++ b/databases/mysql323-server/Makefile
@@ -57,11 +57,14 @@ CONFIGURE_ARGS+=--with-mysqld-ldflags=--static
CFLAGS+= -mcpu=pentiumpro -O3
.endif
.if defined(WITH_LINUXTHREADS)
-CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R -D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads -L${LOCALBASE}/lib -llthread -llgcc_r'
+CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
+CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
.if ${OSVERSION} > 500000
+CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
LIB_DEPENDS+= lthread.3:${PORTSDIR}/devel/linuxthreads
.else
+CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r'
LIB_DEPENDS+= lthread.2:${PORTSDIR}/devel/linuxthreads
.endif
.endif