aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql40-server/Makefile
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2001-01-25 01:03:09 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2001-01-25 01:03:09 +0000
commit6f3337ca58d466ec206b3ecfc2dd5ee2fab42034 (patch)
tree7ff097e66ef6942bc5d459bb6a71975e016d6183 /databases/mysql40-server/Makefile
parentadb6cf981b408710954799822bd701a18fb03082 (diff)
downloadports-6f3337ca58d466ec206b3ecfc2dd5ee2fab42034.tar.gz
ports-6f3337ca58d466ec206b3ecfc2dd5ee2fab42034.zip
Notes
Diffstat (limited to 'databases/mysql40-server/Makefile')
-rw-r--r--databases/mysql40-server/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/databases/mysql40-server/Makefile b/databases/mysql40-server/Makefile
index b839c992d391..0067223ed025 100644
--- a/databases/mysql40-server/Makefile
+++ b/databases/mysql40-server/Makefile
@@ -35,6 +35,12 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
.if ${MACHINE_ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
+.if defined(WITH_CHARSET) && ${WITH_CHARSET} != ""
+CONFIGURE_ARGS+=--with-charset=${WITH_CHARSET}
+.if defined(WITH_XCHARSET) && ${WITH_XCHARSET} != ""
+CONFIGURE_ARGS+=--with-extra-charsets=${WITH_XCHARSET}
+.endif
+.endif
CONFIGURE_ENV+= PERL=${PERL} \
PERL5=${PERL} \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
@@ -48,6 +54,15 @@ CXXFLAGS= ${CFLAGS} -felide-constructors -fno-rtti
CXXFLAGS+= -fno-exceptions
.endif
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "You may use the following build options:"
+ @${ECHO} ""
+ @${ECHO} " WITH_CHARSET=charset define the primary built-in charset (Latin1);"
+ @${ECHO} " WITH_XCHARSET=list define other built-in charsets (may be 'all');"
+ @${ECHO} " DB_DIR=directory Set alternate directory for database files."
+ @${ECHO} ""
+
# MySQL-Server part
.if !defined(CLIENT_ONLY)
MASTER_SITE_SUBDIR+= db