aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql41-server/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-07-05 10:16:55 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-07-05 10:16:55 +0000
commita26918e4b7a678153d7e1acfe41a0c929de0c2ba (patch)
treeb5fbba3cee3a991a05834fc545bd8e1655f757af /databases/mysql41-server/Makefile
parenta8d2e0b5d858060e2326df30c2f6e4c995b02c09 (diff)
Notes
Diffstat (limited to 'databases/mysql41-server/Makefile')
-rw-r--r--databases/mysql41-server/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/databases/mysql41-server/Makefile b/databases/mysql41-server/Makefile
index 902c051d3d8d..32d0273beeb9 100644
--- a/databases/mysql41-server/Makefile
+++ b/databases/mysql41-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= mysql
-PORTVERSION= 4.1.2
+PORTVERSION= 4.1.3
PORTREVISION?= 0
CATEGORIES= databases
MASTER_SITES= ftp://planetmirror.com/pub/mysql/Downloads/MySQL-4.1/ \
@@ -21,7 +21,7 @@ MASTER_SITES= ftp://planetmirror.com/pub/mysql/Downloads/MySQL-4.1/ \
http://mysql.proserve.nl/Downloads/MySQL-4.1/ \
ftp://ftp.free.fr/pub/MySQL/Downloads/MySQL-4.1/
PKGNAMESUFFIX?= -server
-DISTNAME= ${PORTNAME}-${PORTVERSION}-alpha
+DISTNAME= ${PORTNAME}-${PORTVERSION}-beta
MAINTAINER= ale@FreeBSD.org
COMMENT?= Multithreaded SQL database (server)
@@ -29,10 +29,8 @@ COMMENT?= Multithreaded SQL database (server)
SLAVEDIRS= databases/mysql41-client
PKGINSTALL?= ${WRKDIR}/pkg-install
DB_DIR?= /var/db/mysql
-USE_GNOME= lthack
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
-USE_GMAKE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
@@ -45,6 +43,7 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--with-mysqlfs \
--with-vio \
--with-low-memory \
+ --with-ndbcluster \
--with-comment='FreeBSD port: ${PKGNAME}' \
--enable-thread-safe-client
@@ -112,7 +111,7 @@ LATEST_LINK= mysql41-server
CONFLICTS= mysql-server-3.* mysql-server-4.[02-9].* mysql-server-5.*
PLIST_SUB= DB_DIR=${DB_DIR} \
- VER=${PORTVERSION}-alpha
+ VER=${PORTVERSION}-beta
MAN1= isamchk.1 isamlog.1 mysqld.1 \
mysqld_safe.1 perror.1 replace.1
@@ -195,6 +194,7 @@ CONFIGURE_ARGS+=--without-server
post-patch:
@${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @sql_client_dirs@ tests scripts man|g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|all: config.h|all: config.h all-local|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = mysql_config mysql_fix_privilege_tables mysqlbug|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = mysql_fix_privilege_tables.sql|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man_MANS =|man_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in