aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql41-server
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-02-13 12:25:06 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-02-13 12:25:06 +0000
commitae8be5ee1313e854054d40fc1d922899db9591c2 (patch)
treebd1d5263fe038e9bc36c4e22fcf21577a3c45a50 /databases/mysql41-server
parent86008e4b2349277619bfe309e62f94c7a426d6e3 (diff)
downloadports-ae8be5ee1313e854054d40fc1d922899db9591c2.tar.gz
ports-ae8be5ee1313e854054d40fc1d922899db9591c2.zip
Notes
Diffstat (limited to 'databases/mysql41-server')
-rw-r--r--databases/mysql41-server/Makefile15
-rw-r--r--databases/mysql41-server/distinfo6
-rw-r--r--databases/mysql41-server/pkg-plist.client3
3 files changed, 15 insertions, 9 deletions
diff --git a/databases/mysql41-server/Makefile b/databases/mysql41-server/Makefile
index 0c22a3e2496a..2c37df1eabe1 100644
--- a/databases/mysql41-server/Makefile
+++ b/databases/mysql41-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= mysql
-PORTVERSION= 4.1.16
+PORTVERSION= 4.1.18
PORTREVISION?= 0
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL}
@@ -18,7 +18,6 @@ COMMENT?= Multithreaded SQL database (server)
SLAVEDIRS= databases/mysql41-client
USE_AUTOTOOLS= libtool:15
-USE_REINPLACE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
@@ -143,7 +142,7 @@ pre-fetch:
@${ECHO} ""
post-patch:
- @${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @docs_dirs@ @sql_server_dirs@ scripts @man_dirs@ support-files|g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @docs_dirs@ @zlib_dir@ @sql_server_dirs@ scripts @man_dirs@ support-files|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|all: config.h|all: config.h all-local|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = @server_scripts@ mysql_create_system_tables|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = fill_help_tables.sql|g" ${WRKSRC}/scripts/Makefile.in
@@ -153,8 +152,6 @@ post-patch:
.if defined(WITH_PROC_SCOPE_PTH)
@${REINPLACE_CMD} -e "s|PTHREAD_SCOPE_SYSTEM|PTHREAD_SCOPE_PROCESS|g" ${WRKSRC}/sql/mysqld.cc
.endif
- @${ECHO_CMD} "-- fill_help_tables.sql is broken in 4.1.16 release" \
- > ${WRKSRC}/scripts/fill_help_tables.sql
post-install:
.if !defined(PACKAGE_BUILDING)
@@ -178,8 +175,14 @@ USE_LDCONFIG= ${PREFIX}/lib/mysql
CONFIGURE_ARGS+=--without-server
+.if ${OSVERSION} < 500000
+PLIST_SUB+= ZLIB=""
+.else
+PLIST_SUB+= ZLIB="@comment "
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @sql_client_dirs@ scripts @man_dirs@|g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @zlib_dir@ @sql_client_dirs@ scripts @man_dirs@|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|install-exec-am: install-pkglibLIBRARIES|install-exec-am:|g" ${WRKSRC}/strings/Makefile.in
@${REINPLACE_CMD} -e "s|all: config.h|all: config.h all-local|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = mysql_config mysql_fix_privilege_tables mysqlbug|g" ${WRKSRC}/scripts/Makefile.in
diff --git a/databases/mysql41-server/distinfo b/databases/mysql41-server/distinfo
index 64c35ff965e0..05541ae2bac5 100644
--- a/databases/mysql41-server/distinfo
+++ b/databases/mysql41-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (mysql-4.1.16.tar.gz) = 13c5fdd05e28863db3a1261635890b5f
-SHA256 (mysql-4.1.16.tar.gz) = e135f6089a0b49aeb2f3a1396820089c232505cfda010e77a680921750485557
-SIZE (mysql-4.1.16.tar.gz) = 17146702
+MD5 (mysql-4.1.18.tar.gz) = a2db4edb3e1e3b8e0f8c2242225ea513
+SHA256 (mysql-4.1.18.tar.gz) = 7744d78131619b73a82adb6f73d6cfc6bad11a6ad2806c0f5130f88fe88ac9dd
+SIZE (mysql-4.1.18.tar.gz) = 17172994
diff --git a/databases/mysql41-server/pkg-plist.client b/databases/mysql41-server/pkg-plist.client
index bbb139bceb37..3efd4a847590 100644
--- a/databases/mysql41-server/pkg-plist.client
+++ b/databases/mysql41-server/pkg-plist.client
@@ -47,6 +47,9 @@ lib/mysql/libmysqlclient.so.14
lib/mysql/libmysqlclient_r.a
lib/mysql/libmysqlclient_r.so
lib/mysql/libmysqlclient_r.so.14
+%%ZLIB%%lib/mysql/libz.a
+%%ZLIB%%lib/mysql/libz.so
+%%ZLIB%%lib/mysql/libz.so.3
%%DATADIR%%/mysql_fix_privilege_tables.sql
@dirrm include/mysql
@dirrm lib/mysql