aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql50-server/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2007-10-08 08:30:57 +0000
committerAlex Dupre <ale@FreeBSD.org>2007-10-08 08:30:57 +0000
commit25efd4f481963cdedf679393397b9e9872055e68 (patch)
tree92c310aa8093f100c517be4c9d0ffa8e23df809a /databases/mysql50-server/Makefile
parent0dd69e122ec47c5c99b275a5afbf8445bfa7b937 (diff)
downloadports-25efd4f481963cdedf679393397b9e9872055e68.tar.gz
ports-25efd4f481963cdedf679393397b9e9872055e68.zip
Notes
Diffstat (limited to 'databases/mysql50-server/Makefile')
-rw-r--r--databases/mysql50-server/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/databases/mysql50-server/Makefile b/databases/mysql50-server/Makefile
index 522c564af7d8..f571f4e0afe3 100644
--- a/databases/mysql50-server/Makefile
+++ b/databases/mysql50-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mysql
PORTVERSION= 5.0.45
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL}
MASTER_SITE_SUBDIR= MySQL-5.0
@@ -89,6 +89,9 @@ CFLAGS+= ${PTHREAD_CFLAGS}
CFLAGS+= -O3 -fno-omit-frame-pointer
CFLAGS+= -fno-gcse
.endif
+.if defined(WITHOUT_THR_ALARM)
+CFLAGS+= -DDONT_USE_THR_ALARM
+.endif
CXXFLAGS+= ${CFLAGS} -felide-constructors -fno-rtti
CXXFLAGS+= -fno-exceptions
@@ -130,6 +133,9 @@ pre-fetch:
@${ECHO} " (use it if you need speed)."
@${ECHO} " BUILD_STATIC=yes Build a static version of mysqld."
@${ECHO} " (use it if you need even more speed)."
+ @${ECHO} " WITHOUT_THR_ALARM=yes Disable signals (this reduces kernel lock"
+ @${ECHO} " contention on SMP, but has the side effect
+ @${ECHO} " that you can't kill clients that are sleeping)."
@${ECHO} " WITHOUT_INNODB=yes Disable support for InnoDB table handler."
@${ECHO} " WITH_ARCHIVE=yes Enable support for Archive Storage Engine."
@${ECHO} " WITH_CSV=yes Enable support for CSV Storage Engine."