aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql80-server/Makefile
diff options
context:
space:
mode:
authorMahdi Mokhtari <mmokhi@FreeBSD.org>2018-05-12 15:35:25 +0000
committerMahdi Mokhtari <mmokhi@FreeBSD.org>2018-05-12 15:35:25 +0000
commitacca27b6ca8327e93f12cb06800447a44129d72a (patch)
tree82f92efa85f110d6c1ceb5c7f78a94138fbaaf69 /databases/mysql80-server/Makefile
parent23a165766be1243a355132588fbafc0f54fd4b4e (diff)
databases/mysql80-{client,server}: Upgrade the ports to GA version 8.0.11
Fix build with LibreSSL and OpenSSL-devel ports as well MySQL 8.0.11 is the General Availability (GA) version of MySQL 8. MySQL since this version supports FIPS-mode, if compiled using OpenSSL, AND an OpenSSL library and FIPS Object Module are available at runtime. FIPS mode imposes conditions on cryptographic operations such as restrictions on acceptable encryption algorithms or requirements for longer key lengths. The --ssl-fips-mode client option enables control of FIPS mode on the client side for: mysql, mysqladmin, mysqlbinlog, mysqlcheck, mysqldump, mysqlimport, mysqlpump, ... This update includes bugfixes including (not limited to): -InnoDB: The server was stopped before a fatal error message was written to the error log. -InnoDB: An incorrect GROUP BY result was returned when using the TempTable storage engine and a NO PAD collation. -InnoDB: The data retrieved from INFORMATION_SCHEMA.INNODB_COLUMNS was incorrect for tables containing a virtual column. Full Release-Notes are available at: https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-11.html
Notes
Notes: svn path=/head/; revision=469734
Diffstat (limited to 'databases/mysql80-server/Makefile')
-rw-r--r--databases/mysql80-server/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/databases/mysql80-server/Makefile b/databases/mysql80-server/Makefile
index 06f953a5dda9..a18d0b88a28c 100644
--- a/databases/mysql80-server/Makefile
+++ b/databases/mysql80-server/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME?= mysql
-PORTVERSION= 8.0.2
-PORTREVISION?= 3
-DISTVERSIONSUFFIX?= -dmr
+PORTVERSION= 8.0.11
+PORTREVISION?= 0
CATEGORIES= databases ipv6
MASTER_SITES= MYSQL/MySQL-8.0
PKGNAMESUFFIX?= 80-server
@@ -15,9 +14,6 @@ COMMENT?= Multithreaded SQL database (server)
LICENSE= GPLv2
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= member access into incomplete type 'DH' (aka 'dh_st')
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}${DISTVERSIONSUFFIX}
SLAVEDIRS= databases/mysql80-client
@@ -31,7 +27,10 @@ MY_SECDIR= /var/db/mysql_secure
MY_TMPDIR= /var/db/mysql_tmpdir
LIB_DEPENDS+= libevent.so:devel/libevent \
- liblz4.so:archivers/liblz4
+ libicutu.so:devel/icu \
+ liblz4.so:archivers/liblz4 \
+ libre2.so:devel/re2 \
+ libprotobuf.so:devel/protobuf
CMAKE_BUILD_TYPE= Release
CFLAGS+= -fPIC
@@ -61,6 +60,9 @@ CMAKE_ARGS+= -DINSTALL_LAYOUT=FREEBSD \
-DWITH_LIBEVENT=system \
-DWITH_LZ4=system \
-DWITH_ZLIB=system \
+ -DWITH_ICU=system \
+ -DWITH_RE2=system \
+ -DWITH_PROTOBUF=system \
-DINSTALL_MYSQLTESTDIR=0
SHEBANG_FILES= scripts/*.pl* scripts/*.sh