aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql_last_value
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-24 06:24:58 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-24 06:24:58 +0000
commit364f82df744765724bef8d10347b2cf265bd160c (patch)
treeae15a9d503cea3d64e6ff560f76a47b60293a2c7 /databases/mysql_last_value
parentad10950170ede264b4c1c64182ced4cd1feb55a2 (diff)
downloadports-364f82df744765724bef8d10347b2cf265bd160c.tar.gz
ports-364f82df744765724bef8d10347b2cf265bd160c.zip
Notes
Diffstat (limited to 'databases/mysql_last_value')
-rw-r--r--databases/mysql_last_value/Makefile24
-rw-r--r--databases/mysql_last_value/distinfo1
-rw-r--r--databases/mysql_last_value/pkg-descr7
-rw-r--r--databases/mysql_last_value/pkg-plist1
4 files changed, 33 insertions, 0 deletions
diff --git a/databases/mysql_last_value/Makefile b/databases/mysql_last_value/Makefile
new file mode 100644
index 000000000000..773ca6ab99c6
--- /dev/null
+++ b/databases/mysql_last_value/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: mysql_last_value
+# Date created: 14th Aug 2003
+# Whom: Aftab Jahan Subedar
+# $FreeBSD$
+
+PORTNAME= mysql_last_value
+PORTVERSION= 3.2
+CATEGORIES= databases
+MASTER_SITES= http://www.geocities.com/jahan.geo/
+
+MAINTAINER= jahan@bol-online.com
+COMMENT= Replaces NULL value of current column with value from top row
+
+LIB_DEPENDS= mysqlclient.14:${PORTSDIR}/databases/mysql41-client
+
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mysql_last_value ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/databases/mysql_last_value/distinfo b/databases/mysql_last_value/distinfo
new file mode 100644
index 000000000000..2668840fde6f
--- /dev/null
+++ b/databases/mysql_last_value/distinfo
@@ -0,0 +1 @@
+MD5 (mysql_last_value-3.2.tar.gz) = 5e079427683e11f3edbde6e02913518e
diff --git a/databases/mysql_last_value/pkg-descr b/databases/mysql_last_value/pkg-descr
new file mode 100644
index 000000000000..00ef11fa62bb
--- /dev/null
+++ b/databases/mysql_last_value/pkg-descr
@@ -0,0 +1,7 @@
+mysql_last_value() replace null value of column from row above the current row.
+Its like "same as above".
+
+WWW: http://www.geocities.com/jahan.geo
+
+-Aftab Jahan Subedar
+jahan@bol-online.com jahan@geocities.com
diff --git a/databases/mysql_last_value/pkg-plist b/databases/mysql_last_value/pkg-plist
new file mode 100644
index 000000000000..176bdefefcf3
--- /dev/null
+++ b/databases/mysql_last_value/pkg-plist
@@ -0,0 +1 @@
+bin/mysql_last_value