aboutsummaryrefslogtreecommitdiff
path: root/databases/mysqlbigram
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-06 17:57:03 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-06 17:57:03 +0000
commit644188468b3805ff2b055d70957d5f21a945ca3e (patch)
tree6000573443c973002087180b4cca2dacd51a3939 /databases/mysqlbigram
parent38bf66f22a52bebe61274fde2e83137c9e77e0e4 (diff)
Notes
Diffstat (limited to 'databases/mysqlbigram')
-rw-r--r--databases/mysqlbigram/Makefile26
-rw-r--r--databases/mysqlbigram/distinfo3
-rw-r--r--databases/mysqlbigram/pkg-descr14
-rw-r--r--databases/mysqlbigram/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/databases/mysqlbigram/Makefile b/databases/mysqlbigram/Makefile
new file mode 100644
index 000000000000..564aefbc7cbe
--- /dev/null
+++ b/databases/mysqlbigram/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: mysqlbigram
+# Date created: 2007-07-25
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysqlbigram
+PORTVERSION= 1.0.1
+CATEGORIES= databases
+MASTER_SITES= http://mysqlbigram.googlepages.com/
+DISTFILES= bi_gram-src-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Simple N-Gram (bi-gram) FULLTEXT parser plugin for MySQL 5.1+
+
+CFLAGS+= -I"${LOCALBASE}/include" -I"${LOCALBASE}/include/mysql"
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+GNU_CONFIGURE= yes
+IGNORE_WITH_MYSQL= 323 40 41 50
+LDFLAGS+= -L${LOCALBASE}/lib
+USE_MYSQL= yes
+WANT_MYSQL_VER?= 51
+WRKSRC= ${WRKDIR}/bi_gram
+
+.include <bsd.port.mk>
diff --git a/databases/mysqlbigram/distinfo b/databases/mysqlbigram/distinfo
new file mode 100644
index 000000000000..9973f9845415
--- /dev/null
+++ b/databases/mysqlbigram/distinfo
@@ -0,0 +1,3 @@
+MD5 (bi_gram-src-1.0.1.tar.gz) = f5d52e3abb245461307147ff5421cbde
+SHA256 (bi_gram-src-1.0.1.tar.gz) = 06ebc2d61ac4809f3a3122def3600dbdcef15fb83a7277c4f8eba32e01b85ca8
+SIZE (bi_gram-src-1.0.1.tar.gz) = 308085
diff --git a/databases/mysqlbigram/pkg-descr b/databases/mysqlbigram/pkg-descr
new file mode 100644
index 000000000000..d6e26761db28
--- /dev/null
+++ b/databases/mysqlbigram/pkg-descr
@@ -0,0 +1,14 @@
+MySQL has fulltext index search ability for text field. but it is word
+based index, it cannot be used for no word delimiter laungage like
+Japanese or Chinese. and it also can't search charactors in middle of
+a words. (cf. searching 'in' will not match word 'ping'.)
+
+Starts from MySQL 5.1, MySQL supports a plugin that allows to change
+server components (fulltext search parser) without restarting /
+recompiling the server.
+
+This n-gram parser uses this plugin interface to implement a simple
+n-gram (bi-gram) fulltext index parser which can be index no word
+delimiter laungage.
+
+WWW: http://mysqlbigram.googlepages.com/
diff --git a/databases/mysqlbigram/pkg-plist b/databases/mysqlbigram/pkg-plist
new file mode 100644
index 000000000000..e5750036232a
--- /dev/null
+++ b/databases/mysqlbigram/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+lib/mysql/bi_gramlib.la
+lib/mysql/bi_gramlib.so
+lib/mysql/bi_gramlib.so.0
+@dirrmtry lib/mysql