aboutsummaryrefslogtreecommitdiff
path: root/databases/mysqlreport
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-01 07:24:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-01 07:24:19 +0000
commitc932d53d7a6cbb45657db8bebeca4a955e26877e (patch)
treec301c594f523f79a7f96aa9112bec9fe11327c18 /databases/mysqlreport
parent2ec75b05a46675e49cb1b910eabdc03c0ab45771 (diff)
downloadports-c932d53d7a6cbb45657db8bebeca4a955e26877e.tar.gz
ports-c932d53d7a6cbb45657db8bebeca4a955e26877e.zip
Notes
Diffstat (limited to 'databases/mysqlreport')
-rw-r--r--databases/mysqlreport/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/databases/mysqlreport/Makefile b/databases/mysqlreport/Makefile
index ff08d76f5356..3958dfe3fea8 100644
--- a/databases/mysqlreport/Makefile
+++ b/databases/mysqlreport/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mysqlreport
PORTVERSION= 3.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases
MASTER_SITES= http://hackmysql.com/scripts/
EXTRACT_SUFX= .tgz
@@ -11,24 +11,26 @@ EXTRACT_SUFX= .tgz
MAINTAINER= lippe@FreeBSD.org
COMMENT= Mysqlreport makes a friendly report of important MySQL status values
+LICENSE= GPLv3
+
RUN_DEPENDS= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
-USES= perl5
+OPTIONS_DEFINE= DOCS
+
+USES= perl5 shebangfix
NO_BUILD= yes
PLIST_FILES= bin/mysqlreport
PORTDOCS= COPYING mysqlreportguide.html mysqlreportdoc.html
-NO_STAGE= yes
-do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/mysqlreport ${PREFIX}/bin
+SHEBANG_FILES= mysqlreport
-.if !defined(NOPORTDOCS)
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/mysqlreport ${STAGEDIR}${PREFIX}/bin
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>