aboutsummaryrefslogtreecommitdiff
path: root/databases/mysqlsla/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-23 22:22:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-23 22:22:24 +0000
commit89ac7314a9c188e275e7abd07b74d704ce78eb70 (patch)
treefc30ab9d0344713eaf6949e1953dc9a275c5d271 /databases/mysqlsla/Makefile
parent00fac2543edcd3e3876e2f26036c8392acccfe3e (diff)
downloadports-89ac7314a9c188e275e7abd07b74d704ce78eb70.tar.gz
ports-89ac7314a9c188e275e7abd07b74d704ce78eb70.zip
Notes
Diffstat (limited to 'databases/mysqlsla/Makefile')
-rw-r--r--databases/mysqlsla/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/databases/mysqlsla/Makefile b/databases/mysqlsla/Makefile
new file mode 100644
index 000000000000..b508a2781002
--- /dev/null
+++ b/databases/mysqlsla/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: mysqlsla
+# Date created: 2006-11-23
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+
+PORTNAME= mysqlsla
+PORTVERSION= 1.3
+CATEGORIES= databases
+MASTER_SITES= http://hackmysql.com/scripts/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= Mysqlsla analyzes general, slow, and raw MySQL statement logs
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+
+USE_PERL5= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= bin/mysqlsla
+PORTDOCS= mysqlsladoc.html
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500805
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/mysqlsla ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
+ @${MKDIR} ${DOCSDIR}
+. for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.post.mk>