aboutsummaryrefslogtreecommitdiff
path: root/databases/mytop
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2009-09-14 09:21:06 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2009-09-14 09:21:06 +0000
commit3012404c8dc0656bc296ad15d02371b2e760d2ff (patch)
tree14b27cef10dc604afa2f8667a78d6a05a2adce56 /databases/mytop
parent116e8ad531510d6cd8c516846baa56d6c76c9ae0 (diff)
downloadports-3012404c8dc0656bc296ad15d02371b2e760d2ff.tar.gz
ports-3012404c8dc0656bc296ad15d02371b2e760d2ff.zip
Notes
Diffstat (limited to 'databases/mytop')
-rw-r--r--databases/mytop/Makefile2
-rw-r--r--databases/mytop/files/patch-mytop29
2 files changed, 30 insertions, 1 deletions
diff --git a/databases/mytop/Makefile b/databases/mytop/Makefile
index c85c5fcc875c..e235f292c5fa 100644
--- a/databases/mytop/Makefile
+++ b/databases/mytop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mytop
PORTVERSION= 1.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= databases
MASTER_SITES= http://jeremy.zawodny.com/mysql/mytop/
diff --git a/databases/mytop/files/patch-mytop b/databases/mytop/files/patch-mytop
index f4d1a78abcf5..eb1f1d7bc80e 100644
--- a/databases/mytop/files/patch-mytop
+++ b/databases/mytop/files/patch-mytop
@@ -91,3 +91,32 @@
close P;
}
+--- mytop.orig 2009-09-12 17:20:33.000000000 +0100
++++ mytop 2009-09-12 20:59:45.000000000 +0100
+@@ -156,7 +156,7 @@
+ "idle|i" => \$config{idle},
+ "resolve|r" => \$config{resolve},
+ "prompt!" => \$config{prompt},
+- "long|!" => \$config{long_nums},
++ "long!" => \$config{long_nums},
+ "mode|m=s" => \$config{mode},
+ "sort=s" => \$config{sort},
+ );
+@@ -719,7 +719,7 @@
+ ##
+ if ($config{header})
+ {
+- my @recs = Hashes("show status");
++ my @recs = Hashes("SHOW /*!50002 GLOBAL */ STATUS");
+
+ ## if the server died or we lost connectivity
+ if (not @recs)
+@@ -828,7 +828,7 @@
+ $lines_left--;
+
+
+- printf " Queries: %-5s qps: %4.0f Slow: %7s Se/In/Up/De(%%): %02.0f/%02.0f/%02.0f/%02.0f \n",
++ printf " Queries: %-6s qps: %4.0f Slow: %7s Se/In/Up/De(%%): %02.0f/%02.0f/%02.0f/%02.0f \n",
+ make_short( $STATUS{Questions} ), # q total
+ $STATUS{Questions} / $STATUS{Uptime}, # qps, average
+ make_short( $STATUS{Slow_queries} ), # slow