aboutsummaryrefslogtreecommitdiff
path: root/databases/mywwwatcher
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-01-12 10:15:49 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-01-12 10:15:49 +0000
commit7fd3978cb4c782bc0a998266a760349fe929192b (patch)
tree70aa042f3d5d1ef205d5d283fa52dc80992fc00b /databases/mywwwatcher
parentb977cce380fcaa1e2c18a706bd1f639d315fa2a9 (diff)
Notes
Diffstat (limited to 'databases/mywwwatcher')
-rw-r--r--databases/mywwwatcher/Makefile41
-rw-r--r--databases/mywwwatcher/distinfo3
-rw-r--r--databases/mywwwatcher/pkg-descr15
-rw-r--r--databases/mywwwatcher/pkg-message5
-rw-r--r--databases/mywwwatcher/pkg-plist44
5 files changed, 108 insertions, 0 deletions
diff --git a/databases/mywwwatcher/Makefile b/databases/mywwwatcher/Makefile
new file mode 100644
index 000000000000..1c245ac22e7f
--- /dev/null
+++ b/databases/mywwwatcher/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: mywwwatcher
+# Date created: 10 January 2007
+# Whom: Petr Macek <pm@kostax.cz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mywwwatcher
+PORTVERSION= 3.0
+CATEGORIES= databases www
+MASTER_SITES= http://www.the.cz/mywwwatcher/files/
+DISTNAME= mywwwatcher-${PORTVERSION}
+
+MAINTAINER= pm@kostax.cz
+COMMENT= Simply web-based mysql client + tools (dump, import, scheme, ...)
+
+WRKSRC= ${WRKDIR}/mywwwatcher
+
+DEFAULT_PHP_VER= 4
+USE_PHP= pcre session mysql
+
+NO_BUILD= yes
+
+PKGMESSAGE= ${PKGDIR}/pkg-message
+PLIST_SUB+= INSTALLDIR=${INSTALLDIR}
+
+INSTALLDIR= www/${PORTNAME}
+
+do-install:
+ @${MKDIR} ${PREFIX}/${INSTALLDIR}
+ @${CP} -Rp ${WRKSRC}/* ${PREFIX}/${INSTALLDIR}
+ @${CHMOD} 775 ${PREFIX}/${INSTALLDIR}/ini
+ @${CHMOD} 775 ${PREFIX}/${INSTALLDIR}/query_archive
+ @${ECHO_CMD} ""
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/mywwwatcher/distinfo b/databases/mywwwatcher/distinfo
new file mode 100644
index 000000000000..c917dee8d30e
--- /dev/null
+++ b/databases/mywwwatcher/distinfo
@@ -0,0 +1,3 @@
+MD5 (mywwwatcher-3.0.tar.gz) = fb7279d1bf678234df144701f10cda09
+SHA256 (mywwwatcher-3.0.tar.gz) = c92d99b6188f342f88b70cdc0bbc58fea1460f48b1977fa50dbf53fe54c6f188
+SIZE (mywwwatcher-3.0.tar.gz) = 51238
diff --git a/databases/mywwwatcher/pkg-descr b/databases/mywwwatcher/pkg-descr
new file mode 100644
index 000000000000..3cd14d4eed94
--- /dev/null
+++ b/databases/mywwwatcher/pkg-descr
@@ -0,0 +1,15 @@
+mywwwatcher is php application intended to handle the administration
+of MySQL over the web interface. It is small, quick, easy to use
+alternative to phpMyAdmin. In comparison with with phpMyAdmin
+is this application more oriented to hand writing of SQL queries
+and their use for later use.
+It enables also other tasks like database dump, import, export (csv,html),
+insert data, database scheme, index manager, history and reuse
+of SQL requests, etc.
+Interface is either in English and/or in Czech languages, and it is very
+easy to add other languages.
+
+WWW: http://www.the.cz/mywwwatcher
+
+- Petr Macek
+pm@kostax.cz
diff --git a/databases/mywwwatcher/pkg-message b/databases/mywwwatcher/pkg-message
new file mode 100644
index 000000000000..90c680f097fd
--- /dev/null
+++ b/databases/mywwwatcher/pkg-message
@@ -0,0 +1,5 @@
+***************************************************************
+
+for czech language rename files with extension .cz
+
+***************************************************************
diff --git a/databases/mywwwatcher/pkg-plist b/databases/mywwwatcher/pkg-plist
new file mode 100644
index 000000000000..eba6c911c5f8
--- /dev/null
+++ b/databases/mywwwatcher/pkg-plist
@@ -0,0 +1,44 @@
+%%INSTALLDIR%%/README
+%%INSTALLDIR%%/README.cz
+%%INSTALLDIR%%/copying
+%%INSTALLDIR%%/export.php
+%%INSTALLDIR%%/function.php
+%%INSTALLDIR%%/graphics/cursor_down.gif
+%%INSTALLDIR%%/graphics/cursor_up.gif
+%%INSTALLDIR%%/graphics/intro.gif
+%%INSTALLDIR%%/graphics/intro.gif.cz
+%%INSTALLDIR%%/graphics/outro.gif
+%%INSTALLDIR%%/import.php
+%%INSTALLDIR%%/include/compress.inc.php
+%%INSTALLDIR%%/include/foot.inc.php
+%%INSTALLDIR%%/include/frameset.inc.php
+%%INSTALLDIR%%/include/headers.inc.php
+%%INSTALLDIR%%/include/indexes.inc.php
+%%INSTALLDIR%%/include/sqltips.inc.php
+%%INSTALLDIR%%/include/sqltips.inc.php.cz
+%%INSTALLDIR%%/include/words.inc.php
+%%INSTALLDIR%%/index.php
+%%INSTALLDIR%%/indexes.php
+%%INSTALLDIR%%/ini/default.ini
+%%INSTALLDIR%%/ini/default.ini.cz
+%%INSTALLDIR%%/insert.php
+%%INSTALLDIR%%/lang/cz.lng
+%%INSTALLDIR%%/lang/en.lng
+%%INSTALLDIR%%/logout.php
+%%INSTALLDIR%%/menu.php
+%%INSTALLDIR%%/output.php
+%%INSTALLDIR%%/queries.php
+%%INSTALLDIR%%/query_archive.php
+%%INSTALLDIR%%/query_archive/root.txt
+%%INSTALLDIR%%/scheme.php
+%%INSTALLDIR%%/scripts.js
+%%INSTALLDIR%%/settings.php
+%%INSTALLDIR%%/stat.php
+%%INSTALLDIR%%/styly.css
+%%INSTALLDIR%%/top.php
+@dirrm %%INSTALLDIR%%/query_archive
+@dirrm %%INSTALLDIR%%/lang
+@dirrm %%INSTALLDIR%%/ini
+@dirrm %%INSTALLDIR%%/graphics
+@dirrm %%INSTALLDIR%%/include
+@dirrm %%INSTALLDIR%%