aboutsummaryrefslogtreecommitdiff
path: root/databases/nagios-check_postgres_replication
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2011-06-14 21:39:56 +0000
committerBrooks Davis <brooks@FreeBSD.org>2011-06-14 21:39:56 +0000
commitc43376d335db62d4170fc267989d30d062fdce9c (patch)
tree2d7c7e4ce850bda83d82c23d7bf58b05303583fa /databases/nagios-check_postgres_replication
parent97085c300de960b4f026c6d4b462d83536ca4100 (diff)
downloadports-c43376d335db62d4170fc267989d30d062fdce9c.tar.gz
ports-c43376d335db62d4170fc267989d30d062fdce9c.zip
Notes
Diffstat (limited to 'databases/nagios-check_postgres_replication')
-rw-r--r--databases/nagios-check_postgres_replication/Makefile39
-rw-r--r--databases/nagios-check_postgres_replication/distinfo2
-rw-r--r--databases/nagios-check_postgres_replication/pkg-descr16
-rw-r--r--databases/nagios-check_postgres_replication/pkg-plist2
4 files changed, 59 insertions, 0 deletions
diff --git a/databases/nagios-check_postgres_replication/Makefile b/databases/nagios-check_postgres_replication/Makefile
new file mode 100644
index 000000000000..80abade882b4
--- /dev/null
+++ b/databases/nagios-check_postgres_replication/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: check_postgres_replication
+# Date created: 2011-06-10
+# Whom: Brooks Davis <brooks@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= check_postgres_replication
+PORTVERSION= 2010.12.16
+CATEGORIES= databases python
+MASTER_SITES= https://gist.github.com/raw/743942/4b9454d6aaf919fe77d15ecea09c7a001ae83b59/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMEPREFIX= nagios-
+DISTNAME= check_postgres_replication.py
+EXTRACT_SUFX=
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= Nagios plugin to check the lag between a postgresql replica and master
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nagiosplugin>=0:${PORTSDIR}/sysutils/py-nagiosplugin \
+ ${PYTHON_PKGNAMEPREFIX}psycopg2>=0:${PORTSDIR}/databases/py-psycopg2
+
+USE_PYTHON= yes
+USE_PGSQL= yes
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${CP} ${DISTDIR}/${DISTNAME} ${WRKDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME} \
+ ${PREFIX}/libexec/nagios/${DISTNAME:S/.py//}
+
+.include <bsd.port.mk>
diff --git a/databases/nagios-check_postgres_replication/distinfo b/databases/nagios-check_postgres_replication/distinfo
new file mode 100644
index 000000000000..adaa92166dec
--- /dev/null
+++ b/databases/nagios-check_postgres_replication/distinfo
@@ -0,0 +1,2 @@
+SHA256 (check_postgres_replication.py) = 61542e880d8377e1c4711f37895c71b0d800be0639417798933e112baafef7b7
+SIZE (check_postgres_replication.py) = 3778
diff --git a/databases/nagios-check_postgres_replication/pkg-descr b/databases/nagios-check_postgres_replication/pkg-descr
new file mode 100644
index 000000000000..035af36f750e
--- /dev/null
+++ b/databases/nagios-check_postgres_replication/pkg-descr
@@ -0,0 +1,16 @@
+nagiosplugin is a class library which helps writing Nagios (or
+Icinga) compatible plugins easily in Python. It cares for much of the
+boilerplate code and default logic commonly found in Nagios checks,
+including:
+
+ * Nagios 3 Plugin API compliant parameters and output formatting
+ * Controller to handle the general plugin control flow
+ * Full Nagios range syntax support
+ * Automatic threshold checking
+ * Multiple independend measures and overall state logic
+ * Long output and performance data
+ * Timeout handling
+ * Default options
+ * Persistent "cookies" to retain state information between check runs
+
+WWW: http://pypi.python.org/pypi/nagiosplugin
diff --git a/databases/nagios-check_postgres_replication/pkg-plist b/databases/nagios-check_postgres_replication/pkg-plist
new file mode 100644
index 000000000000..55c4ef52d16b
--- /dev/null
+++ b/databases/nagios-check_postgres_replication/pkg-plist
@@ -0,0 +1,2 @@
+libexec/nagios/check_postgres_replication
+@dirrmtry libexec/nagios