aboutsummaryrefslogtreecommitdiff
path: root/databases/ocaml-pgocaml
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2010-11-17 12:23:11 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2010-11-17 12:23:11 +0000
commit6d88a65a06a523ec9cb8e7e8c9234cc92c01ae6b (patch)
tree982633c48f1e6244139ac422ef34e605303387d8 /databases/ocaml-pgocaml
parent626281669445e462b046c559fb29b4c244ab3bb9 (diff)
Notes
Diffstat (limited to 'databases/ocaml-pgocaml')
-rw-r--r--databases/ocaml-pgocaml/Makefile6
-rw-r--r--databases/ocaml-pgocaml/distinfo5
-rw-r--r--databases/ocaml-pgocaml/files/patch-Makefile22
-rw-r--r--databases/ocaml-pgocaml/files/patch-pGOCaml.ml10
-rw-r--r--databases/ocaml-pgocaml/files/patch-pGOCaml.mli11
5 files changed, 7 insertions, 47 deletions
diff --git a/databases/ocaml-pgocaml/Makefile b/databases/ocaml-pgocaml/Makefile
index dddbe17f82b7..ceb7528a4d81 100644
--- a/databases/ocaml-pgocaml/Makefile
+++ b/databases/ocaml-pgocaml/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= pgocaml
-PORTVERSION= 1.1
+PORTVERSION= 1.4
CATEGORIES= databases
MASTER_SITES= BERLIOS
PKGNAMEPREFIX= ocaml-
+EXTRACT_SUFX= .tgz
MAINTAINER= tcrimi@gmail.com
COMMENT= An OCaml interface to PostgreSQL
@@ -26,6 +27,9 @@ OCAML_PKGDIRS= pgocaml
INSTALL_TARGET= findlib_install
+pre-build:
+ cd ${WRKSRC}; ${GMAKE} depend
+
post-install:
@${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
diff --git a/databases/ocaml-pgocaml/distinfo b/databases/ocaml-pgocaml/distinfo
index 2a07ffcecd36..670004dd1899 100644
--- a/databases/ocaml-pgocaml/distinfo
+++ b/databases/ocaml-pgocaml/distinfo
@@ -1,3 +1,2 @@
-MD5 (pgocaml-1.1.tar.gz) = e52d0f88b4ce850aa592a033c7e7b64d
-SHA256 (pgocaml-1.1.tar.gz) = 9ab3808bb9f2f29bf12a80aac8ca722524b7d6e0e75a1f1a9be5058322be665a
-SIZE (pgocaml-1.1.tar.gz) = 37039
+SHA256 (pgocaml-1.4.tgz) = ee041b2efcf071b0b0e7f48428b2cfd8a1b4550bfe402dbe2a259af2b7b5c190
+SIZE (pgocaml-1.4.tgz) = 41256
diff --git a/databases/ocaml-pgocaml/files/patch-Makefile b/databases/ocaml-pgocaml/files/patch-Makefile
deleted file mode 100644
index 208039919c76..000000000000
--- a/databases/ocaml-pgocaml/files/patch-Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.orig 2007-12-17 18:15:17.332386495 -0500
-+++ Makefile 2007-12-17 18:19:21.926038900 -0500
-@@ -36,7 +36,7 @@
- OBJS := pGOCaml_config.cmo pGOCaml.cmo
- XOBJS := $(OBJS:.cmo=.cmx)
-
--all: pGOCaml_config.ml pgocaml.cma pgocaml.cmxa pa_pgsql.cmo test_pgocaml_lowlevel$(EXECUTABLE_SUFFIX) test_pgocaml$(EXECUTABLE_SUFFIX) pgocaml_prof$(EXECUTABLE_SUFFIX) META
-+all: pGOCaml_config.ml pgocaml.cma pgocaml.cmxa pa_pgsql.cmo pgocaml_prof$(EXECUTABLE_SUFFIX) META
-
- test_pgocaml_lowlevel$(EXECUTABLE_SUFFIX): test_pgocaml_lowlevel.cmo pgocaml.cma
- ocamlfind ocamlc $(OCAMLCFLAGS) $(OCAMLCPACKAGES) $(OCAMLCLIBS) \
-@@ -99,8 +99,8 @@
-
- .depend: pGOCaml_config.ml
- rm -f .depend
-- ocamldep pGOCaml.mli pGOCaml.ml test_pgocaml_lowlevel.ml > $@
-- -ocamldep -pp "camlp4o $(FOR_P4) ./pa_pgsql.cmo" test_pgocaml.ml >> $@
-+ ocamldep pGOCaml.mli pGOCaml.ml > $@
-+ -ocamldep -pp "camlp4o $(FOR_P4) ./pa_pgsql.cmo" >> $@
-
- ifeq ($(wildcard .depend),.depend)
- include .depend
diff --git a/databases/ocaml-pgocaml/files/patch-pGOCaml.ml b/databases/ocaml-pgocaml/files/patch-pGOCaml.ml
deleted file mode 100644
index a8063e954a4e..000000000000
--- a/databases/ocaml-pgocaml/files/patch-pGOCaml.ml
+++ /dev/null
@@ -1,10 +0,0 @@
---- pGOCaml.ml.orig 2009-03-01 09:59:13.864728737 -0500
-+++ pGOCaml.ml 2009-03-01 09:59:53.353002107 -0500
-@@ -22,6 +22,7 @@
-
- open Printf
- open ExtString
-+open CalendarLib
-
- type 'a t = {
- ichan : in_channel; (* In_channel wrapping socket. *)
diff --git a/databases/ocaml-pgocaml/files/patch-pGOCaml.mli b/databases/ocaml-pgocaml/files/patch-pGOCaml.mli
deleted file mode 100644
index 169e264c41bd..000000000000
--- a/databases/ocaml-pgocaml/files/patch-pGOCaml.mli
+++ /dev/null
@@ -1,11 +0,0 @@
---- pGOCaml.mli.orig 2009-03-01 09:59:09.188523102 -0500
-+++ pGOCaml.mli 2009-03-01 09:59:43.562605632 -0500
-@@ -20,6 +20,8 @@
- * Boston, MA 02111-1307, USA.
- *)
-
-+open CalendarLib
-+
- type 'a t (** Database handle. *)
-
- exception Error of string