aboutsummaryrefslogtreecommitdiff
path: root/databases/ocaml-sqlite3
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-27 01:14:25 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-27 01:14:25 +0000
commit999946259f539233794e1cfd894df08f434ee83f (patch)
treeb6d8420948aabd50b1b66d313fb1e2e67986c200 /databases/ocaml-sqlite3
parentd5b76c37c1e7f4f9e0a288794701c4158053564c (diff)
downloadports-999946259f539233794e1cfd894df08f434ee83f.tar.gz
ports-999946259f539233794e1cfd894df08f434ee83f.zip
databases/ocaml-sqlite3: Upgrade from 1.6.1 -> 2.0.4 and stage
The referenced PR was implemented, and then augmented with stage support from pkgsrc. The unique license was also documented. PR: ports/176067 Submitted by: maintainer (Jaap Boender) Stage support: Taken from pkgsrc
Notes
Notes: svn path=/head/; revision=349313
Diffstat (limited to 'databases/ocaml-sqlite3')
-rw-r--r--databases/ocaml-sqlite3/Makefile52
-rw-r--r--databases/ocaml-sqlite3/distinfo4
-rw-r--r--databases/ocaml-sqlite3/files/patch-configure.ac11
-rw-r--r--databases/ocaml-sqlite3/files/patch-lib_sqlite3_stubs.c14
4 files changed, 39 insertions, 42 deletions
diff --git a/databases/ocaml-sqlite3/Makefile b/databases/ocaml-sqlite3/Makefile
index 8c20f773810e..28d2e76c49a5 100644
--- a/databases/ocaml-sqlite3/Makefile
+++ b/databases/ocaml-sqlite3/Makefile
@@ -2,48 +2,42 @@
# $FreeBSD$
PORTNAME= sqlite3
-PORTVERSION= 1.6.1
+PORTVERSION= 2.0.4
CATEGORIES= databases
-MASTER_SITES= http://hg.ocaml.info/release/${PKGNAMEPREFIX}${PORTNAME}/archive/
+MASTER_SITES= http://cdn.bitbucket.org/mmottl/sqlite3-ocaml/downloads/
PKGNAMEPREFIX= ocaml-
-DISTNAME= release-${PORTVERSION}
+DISTNAME= ${PORTNAME}-ocaml-${PORTVERSION}
MAINTAINER= jaapb@kerguelen.org
COMMENT= OCaml bindings to sqlite3 library
-WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}-release-${PORTVERSION}
+LICENSE= OCSQLT3
+LICENSE_NAME= OCaml-SQLite3 unique permissive license
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USE_AUTOTOOLS= autoconf
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_SQLITE= yes
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
USE_OCAMLFIND_PLIST= yes
+HAS_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
+CONFIGURE_ARGS= --destdir "${STAGEDIR}" \
+ --prefix "${PREFIX}"
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= CC="${CC}"\
- CFLAGS="${CFLAGS}"\
- CPPFLAGS="-UHAVE_ALLOCA_H -I${PREFIX}/include"\
- LDFLAGS="-L${PREFIX}/lib"\
- LIBS="${PTHREAD_LIBS}"
-
-USE_BZIP2= yes
-
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-PORTDOCS= style.css *.html
-
-PLIST_FILES= bin/sqlite3top
-
-NO_STAGE= yes
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @( cd ${WRKSRC}/doc;\
- for f in `${FIND} . -type f -print`; do\
- ${INSTALL_DATA} $${f} ${DOCSDIR};\
- done )
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's,"install" :: findlib_name,"install" :: "-destdir ${STAGEDIR}${PREFIX}/lib/ocaml/site-lib" :: "-ldconf /var/null" :: findlib_name,' \
+ ${WRKSRC}/setup.ml
+
+do-configure:
+ (cd ${WRKSRC} && ocaml setup.ml -configure ${CONFIGURE_ARGS})
+
+do-build:
+ (cd ${WRKSRC} && ocaml setup.ml -build)
+
+do-install:
+ (cd ${WRKSRC} && ocaml setup.ml -install)
.include <bsd.port.mk>
diff --git a/databases/ocaml-sqlite3/distinfo b/databases/ocaml-sqlite3/distinfo
index e7550f9fc77d..d17b0f05d4d4 100644
--- a/databases/ocaml-sqlite3/distinfo
+++ b/databases/ocaml-sqlite3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (release-1.6.1.tar.bz2) = 9d5ed422de61497436475329c3a9956870cfb8d0a272f764a9e57faff7ebea9f
-SIZE (release-1.6.1.tar.bz2) = 54462
+SHA256 (sqlite3-ocaml-2.0.4.tar.gz) = 51ccb4c7a240eb40652c59e1770cfe1827dfa1eb926c969d19ff414aef4e80a1
+SIZE (sqlite3-ocaml-2.0.4.tar.gz) = 60665
diff --git a/databases/ocaml-sqlite3/files/patch-configure.ac b/databases/ocaml-sqlite3/files/patch-configure.ac
deleted file mode 100644
index 42997a1ab394..000000000000
--- a/databases/ocaml-sqlite3/files/patch-configure.ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2011-12-17 13:30:46.622160436 +0100
-+++ configure.ac 2011-12-17 13:30:56.046163766 +0100
-@@ -26,7 +26,7 @@
- AC_CHECKING(for sqlite3 library)
- AC_CHECK_LIB(
- sqlite3, sqlite3_open,,
-- AC_ERROR([SQLite is required. See the --with-sqlite3 configure option.]), -ldl)
-+ AC_ERROR([SQLite is required. See the --with-sqlite3 configure option.]))
-
- AC_CHECKING(for Sqlite header files)
- AC_CHECK_HEADER(sqlite3.h,,
diff --git a/databases/ocaml-sqlite3/files/patch-lib_sqlite3_stubs.c b/databases/ocaml-sqlite3/files/patch-lib_sqlite3_stubs.c
new file mode 100644
index 000000000000..13e5a349c5c9
--- /dev/null
+++ b/databases/ocaml-sqlite3/files/patch-lib_sqlite3_stubs.c
@@ -0,0 +1,14 @@
+$NetBSD: patch-lib_sqlite3_stubs.c,v 1.1 2012/09/16 11:34:46 jaapb Exp $
+
+Correct system-dependent defines
+--- lib/sqlite3_stubs.c.orig 2012-07-20 15:39:49.000000000 +0000
++++ lib/sqlite3_stubs.c
+@@ -40,7 +40,7 @@
+
+ #if __GNUC__ >= 3
+ # define inline inline __attribute__ ((always_inline))
+-# if !defined(__FreeBSD__) && !__APPLE__
++# if !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__DragonFly) && !__APPLE__
+ # define __unused __attribute__ ((unused))
+ # endif
+ #else