aboutsummaryrefslogtreecommitdiff
path: root/databases/opendbx/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-09 14:26:40 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-09 14:26:40 +0000
commit1f4401a28ff5f026a7cdf52051c6941a8e0fa89d (patch)
treeada290ece4ee225a15e5ea05956948f45bb1ae3b /databases/opendbx/Makefile
parent5e3cdc0c68edd542e68fd740de5cadc66e4d0159 (diff)
downloadports-1f4401a28ff5f026a7cdf52051c6941a8e0fa89d.tar.gz
ports-1f4401a28ff5f026a7cdf52051c6941a8e0fa89d.zip
Notes
Diffstat (limited to 'databases/opendbx/Makefile')
-rw-r--r--databases/opendbx/Makefile81
1 files changed, 81 insertions, 0 deletions
diff --git a/databases/opendbx/Makefile b/databases/opendbx/Makefile
new file mode 100644
index 000000000000..c6355b836d7e
--- /dev/null
+++ b/databases/opendbx/Makefile
@@ -0,0 +1,81 @@
+# New ports collection makefile for: opendbx
+# Date Created: 17 March 2006
+# Whom: tremere@cainites.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= opendbx
+PORTVERSION= 1.0.0
+CATEGORIES= databases
+MASTER_SITES= http://www.linuxnetworks.de/opendbx/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= tremere@cainites.net
+COMMENT= A C library for accessing databases with a single API
+
+USE_GMAKE= YES
+USE_AUTOTOOLS= libtool:15
+USE_GETTEXT= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --with-backends="${CONFIGURE_MODULES}" --disable-nls
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+USE_LDCONFIG= ${PREFIX}/lib/opendbx
+
+OPTIONS= MYSQL "Support for the MySQL database" off \
+ PGSQL "Support for the PostgreSQL database" on \
+ SQLITE2 "Support for the SQLite 2 database" off \
+ SQLITE "Support for the SQLite 3 database" off
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= doesn't build on FreeBSd < 5.x
+#post-patch:
+# ${REINPLACE_CMD} 's/stdint.h/inttypes.h/' ${WRKSRC}/lib/odbxlib.h
+# ${REINPLACE_CMD} 's/stdint.h/inttypes.h/' ${WRKSRC}/lib/odbx.h
+.endif
+
+.if !defined(WITH_MYSQL) && !defined(WITH_PGSQL) && !defined(WITH_SQLITE2) && !defined(WITH_SQLITE)
+IGNORE= you need to select at least one database
+.endif
+
+.if defined(WITH_MYSQL)
+USE_MYSQL?= YES
+CONFIGURE_MODULES+= "mysql"
+CPPFLAGS+= -I${LOCALBASE}/include/mysql
+LDFLAGS+= -L${LOCALBASE}/lib/mysql
+PLIST_SUB+= WITHMYSQL=""
+.else
+PLIST_SUB+= WITHMYSQL="@comment "
+.endif
+
+.if !defined(WITHOUT_PGSQL)
+USE_PGSQL?= YES
+CONFIGURE_MODULES+= "pgsql"
+PLIST_SUB+= WITHPGSQL=""
+.else
+PLIST_SUB+= WITHPGSQL="@comment "
+.endif
+
+.if defined(WITH_SQLITE2)
+USE_SQLITE?= 2
+CONFIGURE_MODULES+= "sqlite"
+PLIST_SUB+= WITHSQLITE=""
+.else
+PLIST_SUB+= WITHSQLITE="@comment "
+.endif
+
+.if defined(WITH_SQLITE)
+USE_SQLITE?= 3
+CONFIGURE_MODULES+= "sqlite3"
+PLIST_SUB+= WITHSQLITE3=""
+.else
+PLIST_SUB+= WITHSQLITE3="@comment "
+.endif
+
+.include <bsd.port.post.mk>