aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-AnyEvent-CouchDB
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-03 23:28:08 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-03 23:28:08 +0000
commita2808094053fb1113a47ad84b0ae187797ebb8c9 (patch)
tree23162c38112fcdf9d3054d734d4d321f13ad1aef /databases/p5-AnyEvent-CouchDB
parente21b3ca271a3fbe53582b32d81f0f8a8c95bd982 (diff)
Notes
Diffstat (limited to 'databases/p5-AnyEvent-CouchDB')
-rw-r--r--databases/p5-AnyEvent-CouchDB/Makefile36
-rw-r--r--databases/p5-AnyEvent-CouchDB/distinfo2
-rw-r--r--databases/p5-AnyEvent-CouchDB/pkg-descr10
-rw-r--r--databases/p5-AnyEvent-CouchDB/pkg-plist10
4 files changed, 58 insertions, 0 deletions
diff --git a/databases/p5-AnyEvent-CouchDB/Makefile b/databases/p5-AnyEvent-CouchDB/Makefile
new file mode 100644
index 000000000000..028b2468d9b7
--- /dev/null
+++ b/databases/p5-AnyEvent-CouchDB/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-AnyEvent-CouchDB
+# Date created: 2011-09-03
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyEvent-CouchDB
+PORTVERSION= 1.27
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A non-blocking CouchDB client based on jquery.couch.js
+
+BUILD_DEPENDS= couchdb>=0.9.0:${PORTSDIR}/databases/couchdb \
+ p5-AnyEvent-HTTP>=2.11:${PORTSDIR}/www/p5-AnyEvent-HTTP \
+ p5-CouchDB-View>=0:${PORTSDIR}/databases/p5-CouchDB-View \
+ p5-Data-Dump-Streamer>=0:${PORTSDIR}/devel/p5-Data-Dump-Streamer \
+ p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
+ p5-IO-All>=0:${PORTSDIR}/devel/p5-IO-All \
+ p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-Scope-Guard>=0:${PORTSDIR}/devel/p5-Scope-Guard
+BUILD_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= couchdb-push.1
+MAN3= AnyEvent::CouchDB.3 \
+ AnyEvent::CouchDB::Database.3 \
+ AnyEvent::CouchDB::Exceptions.3 \
+ AnyEvent::CouchDB::Stream.3
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/p5-AnyEvent-CouchDB/distinfo b/databases/p5-AnyEvent-CouchDB/distinfo
new file mode 100644
index 000000000000..77d3fb6d1d09
--- /dev/null
+++ b/databases/p5-AnyEvent-CouchDB/distinfo
@@ -0,0 +1,2 @@
+SHA256 (AnyEvent-CouchDB-1.27.tar.gz) = 33f224e55dc191527727aa1de705c1b554018b3a036f5f79b0fc6623b9309af3
+SIZE (AnyEvent-CouchDB-1.27.tar.gz) = 20830
diff --git a/databases/p5-AnyEvent-CouchDB/pkg-descr b/databases/p5-AnyEvent-CouchDB/pkg-descr
new file mode 100644
index 000000000000..86f242fa964a
--- /dev/null
+++ b/databases/p5-AnyEvent-CouchDB/pkg-descr
@@ -0,0 +1,10 @@
+AnyEvent::CouchDB is a non-blocking CouchDB client implemented on top of the
+AnyEvent framework. Using this library will give you the ability to run many
+CouchDB requests asynchronously, and it was intended to be used within a
+Coro+AnyEvent environment. However, it can also be used synchronously if you
+want.
+
+Its API is based on jquery.couch.js, but we've adapted the API slightly so that
+it makes sense in an asynchronous Perl environment.
+
+WWW: http://search.cpan.org/dist/AnyEvent-CouchDB/
diff --git a/databases/p5-AnyEvent-CouchDB/pkg-plist b/databases/p5-AnyEvent-CouchDB/pkg-plist
new file mode 100644
index 000000000000..140ea236a0c3
--- /dev/null
+++ b/databases/p5-AnyEvent-CouchDB/pkg-plist
@@ -0,0 +1,10 @@
+bin/couchdb-push
+%%SITE_PERL%%/AnyEvent/CouchDB.pm
+%%SITE_PERL%%/AnyEvent/CouchDB/Database.pm
+%%SITE_PERL%%/AnyEvent/CouchDB/Exceptions.pm
+%%SITE_PERL%%/AnyEvent/CouchDB/Stream.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/CouchDB/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/CouchDB
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent
+@dirrm %%SITE_PERL%%/AnyEvent/CouchDB
+@dirrmtry %%SITE_PERL%%/AnyEvent