aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Class-DBI-Loader-Relationship
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-08 00:45:08 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-08 00:45:08 +0000
commit41a56135d1e8a68844e4c575702cdbad451d7322 (patch)
tree009db3c80e9f224065cf6fcece6157eb9a5ad509 /databases/p5-Class-DBI-Loader-Relationship
parent8bf833f73199c3dc4303aad884f8483e5c33613a (diff)
downloadports-41a56135d1e8a68844e4c575702cdbad451d7322.tar.gz
ports-41a56135d1e8a68844e4c575702cdbad451d7322.zip
Notes
Diffstat (limited to 'databases/p5-Class-DBI-Loader-Relationship')
-rw-r--r--databases/p5-Class-DBI-Loader-Relationship/Makefile11
-rw-r--r--databases/p5-Class-DBI-Loader-Relationship/files/500503-Relationship.pm33
2 files changed, 1 insertions, 43 deletions
diff --git a/databases/p5-Class-DBI-Loader-Relationship/Makefile b/databases/p5-Class-DBI-Loader-Relationship/Makefile
index a2ca90f32aa4..e3dd0e75f13f 100644
--- a/databases/p5-Class-DBI-Loader-Relationship/Makefile
+++ b/databases/p5-Class-DBI-Loader-Relationship/Makefile
@@ -22,13 +22,4 @@ PERL_CONFIGURE= yes
MAN3= Class::DBI::Loader::Relationship.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-EXTRA_PATCHES= ${PATCHDIR}/500503-Relationship.pm
-
-post-configure:
- ${PERL} -pi -e 's,/usr/local/,\$$(PREFIX)/,g' ${WRKSRC}/Makefile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-Class-DBI-Loader-Relationship/files/500503-Relationship.pm b/databases/p5-Class-DBI-Loader-Relationship/files/500503-Relationship.pm
deleted file mode 100644
index 8d39fa246dea..000000000000
--- a/databases/p5-Class-DBI-Loader-Relationship/files/500503-Relationship.pm
+++ /dev/null
@@ -1,33 +0,0 @@
---- Relationship.pm.orig Wed Nov 9 02:28:38 2005
-+++ Relationship.pm Wed Nov 9 14:27:27 2005
-@@ -1,9 +1,8 @@
- package Class::DBI::Loader::Relationship;
--use 5.006;
- use strict;
--use warnings;
--our $VERSION = '1.3';
--our $DEBUG = 0;
-+use vars qw($VERSION $DEBUG);
-+$VERSION = '1.3';
-+$DEBUG = 0;
-
- 1;
-
-@@ -96,7 +95,7 @@
- "$via_c->has_a(".to_S($to)." => $to_c)\n".
- "$from_c->$method($mapper => [ $via_c => ".to_S($to)." ])\n".
- "$to_c->has_many(".to_PL($from)." => [ $via_c => ".to_S($from)." ])\n"
-- if $DEBUG;
-+ if $Class::DBI::Loader::Relationship::DEBUG;
-
- $via_c->has_a(to_S($from) => $from_c);
- $via_c->has_a(to_S($to) => $to_c);
-@@ -106,7 +105,7 @@
- }
- return "$from_c->$method($mapper => $to_c);\n".
- ($method ne "has_a" && "$to_c->has_a(".to_S($from)." => $from_c);\n")
-- if $DEBUG;
-+ if $Class::DBI::Loader::Relationship::DEBUG;
- $from_c->$method($mapper => $to_c);
- $to_c->has_a(to_S($from) => $from_c) unless $method eq "has_a";
- }