aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Class-DBI-SQLite/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-07-22 14:40:11 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-07-22 14:40:11 +0000
commit7bd1ce6227157924b5495f9b8db88edb7fe0ff05 (patch)
tree58f69384f1f496bfefe7970c2caf0e3ade46011e /databases/p5-Class-DBI-SQLite/Makefile
parenta51078f35395e1a9792aceef4b09e9c5db32f55a (diff)
Notes
Diffstat (limited to 'databases/p5-Class-DBI-SQLite/Makefile')
-rw-r--r--databases/p5-Class-DBI-SQLite/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/databases/p5-Class-DBI-SQLite/Makefile b/databases/p5-Class-DBI-SQLite/Makefile
new file mode 100644
index 000000000000..978137cb614a
--- /dev/null
+++ b/databases/p5-Class-DBI-SQLite/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Class-DBI-SQLite
+# Date created: 22 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-DBI-SQLite
+PORTVERSION= 0.02
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Extension to Class::DBI for sqlite
+
+RUN_DEPENDS= ${SITE_PERL}/Ima/DBI.pm:${PORTSDIR}/databases/p5-Ima-DBI \
+ ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
+ ${SITE_PERL}/SQL/Parser.pm:${PORTSDIR}/databases/p5-SQL-Statement
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::DBI::SQLite.3
+
+.include <bsd.port.mk>