aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-FrontBase
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-06-13 04:40:29 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-06-13 04:40:29 +0000
commitc05b1121b612c645f96b86afa782901aa79040c5 (patch)
treed362054dcf41494b6f6eb83e415802b1d0c3221b /databases/p5-DBD-FrontBase
parent5ebd7f32c87986a43f9a095607336473e92ac294 (diff)
downloadports-c05b1121b612c645f96b86afa782901aa79040c5.tar.gz
ports-c05b1121b612c645f96b86afa782901aa79040c5.zip
Notes
Diffstat (limited to 'databases/p5-DBD-FrontBase')
-rw-r--r--databases/p5-DBD-FrontBase/Makefile34
-rw-r--r--databases/p5-DBD-FrontBase/distinfo3
-rw-r--r--databases/p5-DBD-FrontBase/files/patch-FB.xs24
-rw-r--r--databases/p5-DBD-FrontBase/files/patch-Makefile.PL53
-rw-r--r--databases/p5-DBD-FrontBase/pkg-descr4
-rw-r--r--databases/p5-DBD-FrontBase/pkg-plist9
6 files changed, 127 insertions, 0 deletions
diff --git a/databases/p5-DBD-FrontBase/Makefile b/databases/p5-DBD-FrontBase/Makefile
new file mode 100644
index 000000000000..53f3f30f92d3
--- /dev/null
+++ b/databases/p5-DBD-FrontBase/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: DBD::FrontBase
+# Date created: 19 Jul 2007
+# Whom: Mitchell Smith <mjs@onthenet.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBD-FrontBase
+PORTVERSION= 1.37
+CATEGORIES= databases perl5
+MASTER_SITES+= http://www.frontbase.com/download/perl/
+PKGNAMEPREFIX= p5-
+DISTNAME= DBD-FB-${PORTVERSION}
+EXTRACT_SUFX= .tar
+
+MAINTAINER= q@onthenet.com.au
+COMMENT= DBI driver for FrontBase RDBMS server
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${LOCALBASE}/lib/libFBCAccess.a:${PORTSDIR}/databases/frontbase
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+
+MAN3= DBD::FB.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= perl 5.6 or newer required, Install lang/perl5.8 or lang/perl5 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBD-FrontBase/distinfo b/databases/p5-DBD-FrontBase/distinfo
new file mode 100644
index 000000000000..d3515062aa6a
--- /dev/null
+++ b/databases/p5-DBD-FrontBase/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBD-FB-1.37.tar) = a45dfdf0c7723b7260fcf83386443874
+SHA256 (DBD-FB-1.37.tar) = 71afb3e88e630331b1ef78a799a772183b1b2363086b571938cf8d8c06d529cc
+SIZE (DBD-FB-1.37.tar) = 53557
diff --git a/databases/p5-DBD-FrontBase/files/patch-FB.xs b/databases/p5-DBD-FrontBase/files/patch-FB.xs
new file mode 100644
index 000000000000..9029f53e84bf
--- /dev/null
+++ b/databases/p5-DBD-FrontBase/files/patch-FB.xs
@@ -0,0 +1,24 @@
+--- ../DBD-FB-1.37.orig/FB.xs Wed Jul 26 16:49:08 2006
++++ FB.xs Fri Jul 20 14:30:25 2007
+@@ -111,10 +111,6 @@
+ XSRETURN_YES;
+ }
+ /* pre-disconnect checks and tidy-ups */
+- if (DBIc_CACHED_KIDS(imp_dbh)) {
+- SvREFCNT_dec(DBIc_CACHED_KIDS(imp_dbh));
+- DBIc_CACHED_KIDS(imp_dbh) = Nullhv;
+- }
+ /* Check for disconnect() being called whilst refs to cursors */
+ /* still exists. This possibly needs some more thought. */
+ if (DBIc_ACTIVE_KIDS(imp_dbh) && DBIc_WARN(imp_dbh) && !dirty) {
+@@ -167,10 +163,6 @@
+ }
+ else {
+ /* pre-disconnect checks and tidy-ups */
+- if (DBIc_CACHED_KIDS(imp_dbh)) {
+- SvREFCNT_dec(DBIc_CACHED_KIDS(imp_dbh));
+- DBIc_CACHED_KIDS(imp_dbh) = Nullhv;
+- }
+ if (DBIc_IADESTROY(imp_dbh)) { /* want's ineffective destroy */
+ DBIc_ACTIVE_off(imp_dbh);
+ }
diff --git a/databases/p5-DBD-FrontBase/files/patch-Makefile.PL b/databases/p5-DBD-FrontBase/files/patch-Makefile.PL
new file mode 100644
index 000000000000..b337c3021304
--- /dev/null
+++ b/databases/p5-DBD-FrontBase/files/patch-Makefile.PL
@@ -0,0 +1,53 @@
+--- ../DBD-FB-1.37.orig/Makefile.PL Wed Nov 1 19:44:28 2006
++++ Makefile.PL Fri Jul 20 14:31:09 2007
+@@ -13,37 +13,10 @@
+
+ my $os = $^O;
+
+-if (! $ENV{FRONTBASE_HOME}) {
+- print "Environment variable FRONTBASE_HOME not defined. Searching for Frontbase...\n";
+- if ($os eq 'MSWin32')
+- {
+- foreach(qw(\usr\FrontBase))
+- {
+- if (-d "$_/lib")
+- {
+- $ENV{FRONTBASE_HOME} = $_;
+- last;
+- }
+- }
+- }
+- else
+- {
+- foreach(qw(/Library/Frontbase /Local/Library/FrontBase /usr/FrontBase /opt/FrontBase /usr/local/FrontBase))
+- {
+- if (-d "$_/lib")
+- {
+- $ENV{FRONTBASE_HOME} = $_;
+- last;
+- }
+- }
+- }
+-}
+-
+-if (defined($ENV{FRONTBASE_HOME}) && -d "$ENV{FRONTBASE_HOME}/lib") {
+- print "Found Frontbase in $ENV{FRONTBASE_HOME}\n";
+-} else {
+- die "Unable to find Frontbase\nplease set environment variable FRONTBASE_HOME\n";
+-}
++#
++# The FreeBSD port of FrontBase puts the libs in an unexpected location.
++# The test for the FrontBase lib dir has been removed.
++#
+
+ print "Configuring for ",$os, "\n";
+
+@@ -59,7 +32,7 @@
+ DISTNAME => 'DBD-FB',
+ VERSION_FROM => 'FB.pm',
+ INC => "-I$ENV{FRONTBASE_HOME}/include -I\$(INSTALLSITEARCH)/auto/DBI -I\$(INSTALLARCHLIB)/DBI -I\$(SITEARCH)/auto/DBI -I\$(ARCHLIB)/DBI",
+- OBJECT => "FB\$(OBJ_EXT) dbdimp\$(OBJ_EXT) $ENV{FRONTBASE_HOME}/lib/$libFBCAccess",
++ OBJECT => "FB\$(OBJ_EXT) dbdimp\$(OBJ_EXT) /usr/local/lib/$libFBCAccess",
+ dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', POSTOP => 'mv $(DISTNAME)-$(VERSION).tar.gz ../' },
+ realclean => { FILES => '*.xsi' }
+ );
diff --git a/databases/p5-DBD-FrontBase/pkg-descr b/databases/p5-DBD-FrontBase/pkg-descr
new file mode 100644
index 000000000000..5f856c36717e
--- /dev/null
+++ b/databases/p5-DBD-FrontBase/pkg-descr
@@ -0,0 +1,4 @@
+This is the official implementation of DBD::FrontBase, the DBI Database
+Connectivity driver, for accessing FrontBase databases from Perl.
+
+WWW: http://www.frontbase.com/
diff --git a/databases/p5-DBD-FrontBase/pkg-plist b/databases/p5-DBD-FrontBase/pkg-plist
new file mode 100644
index 000000000000..c183f3c51657
--- /dev/null
+++ b/databases/p5-DBD-FrontBase/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/FB/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/DBD/FB.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DBD/FB/GetInfo.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/FB/FB.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/FB/FB.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/DBD/FB
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/DBD
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/FB
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD